
Microsoft Office Excel

Shipping, Finance & Management Skills

MSc in International Shipping, Finance and Management

Instructor: Stella Moysiadou, Researcher

Laboratory for International Shipping, Finance and 
Management

Contact Details: stm@aueb.gr



CONTENTS

© Stella Moysiadou - stm@aueb.gr 2

Microsoft Office 
Shipping, Finance & 
Management Skills

• STARTING MICROSOFT EXCEL

• NAVIGATING BETWEEN WORKSHEETS

• NAVIGATING WITHIN A WORKSHEET

• WRITTEN COMMUNICATION: CREATING

EFFECTIVE WORKBOOKS

• ENTERING TEXT

• ENTERING DATES

• ENTERING NUMBERS

• CHANGING THE COLUMN WIDTH OR ROW

HEIGHT

• INSERTING A COLUMN OR ROW

• DELETING AND CLEARING A ROW OR COLUMN

• SAVING A WORKBOOK

• WORKING WITH CELLS AND RANGES

• INSERTING, DELETING, RENAMING A

WORKSHEET

• MOVING AND COPYING A WORKSHEET

• UNDOING AND REDOING AN ACTION

• USING FIND AND REPLACE

• USING THE SPELLING CHECKER

• CHANGING WORKSHEET VIEWS

• WORKING WITH PORTRAIT AND LANDSCAPE

ORIENTATION

• PRINTING THE WORKBOOK

• VIEWING AND PRINTING WORKSHEET

FORMULAS

• WORKING WITH FORMULAS

• ENTERING A FORMULA

• COPYING AND PASTING FORMULAS

• UNDERSTANDING CELL REFERENCES

• COPYING FORMULAS AND FORMATS WITH

AUTOFILL

• USING THE AUTO FILL OPTIONS BUTTON

• FILLING A SERIES

• ENTERING A FUNCTION

• ENTERING FUNCTIONS WITH THE AUTOSUM

FEATURE



CONTENTS

© Stella Moysiadou - stm@aueb.gr 3

Microsoft Office 
Shipping, Finance & 
Management Skills

• WORKING WITH LOGICAL FUNCTIONS

• USING THE IF FUNCTION TO EXPLORE FINANCIAL

OPTIONS

• CREATING NESTED IFS

• FINDING AND FIXING ERRORS IN FORMULAS

• USING THE AND FUNCTION

• USING THE OR FUNCTION

• USING STRUCTURED REFERENCES TO CREATE

FORMULAS IN EXCEL TABLES

• USING LOOKUP TABLES AND FUNCTIONS

• USING THE VLOOKUP FUNCTION TO FIND AN

EXACT MATCH

• USING THE VLOOKUP FUNCTION TO FIND AN

APPROXIMATE MATCH

• LOOKING UP VALUES USING THE HLOOKUP 

FUNCTION

• THE INDEX FUNCTION'S SYNTAX AND USAGE

• THE MATCH FUNCTION'S SYNTAX AND USAGE

• HOW TO USE INDEX MATCH FUNCTION IN

EXCEL

• USING THE IFERROR FUNCTION

• SUMMARIZING DATA CONDITIONALLY

• EXCEL’S MATH FUNCTIONS

• EXCEL’S STATISTICAL FUNCTIONS

• CALCULATING MEASURES OF CENTRAL TENDENCY

• CALCULATING MEASURES OF VARIATION

• USING THE ANALYSIS TOOLPAK STATISTICAL

TOOLS

• USING THE DESCRIPTIVE STATISTICS TOOL

• DETERMINING THE CORRELATION BETWEEN DATA

• WORKING WITH HISTOGRAMS

• USING THE RANDOM NUMBER GENERATION TOOL

• WORKING WITH RANK AND PERCENTILE



CONTENTS

© Stella Moysiadou - stm@aueb.gr 4

Microsoft Office 
Shipping, Finance & 
Management Skills

• USING EXCEL’S REGRESSION ADD-IN

• ANALYSIS OF VARIANCE: ONE-WAY ANOVA 

• SETTING UP SOLVER TO FIND A SOLUTION

• CREATING A SOLVER ANSWER REPORT

• SAVING AND LOADING SOLVER MODELS

• CALCULATING THE LOAN PAYMENT

• CALCULATING THE PRINCIPAL AND INTEREST

• CALCULATING THE TERM OF THE LOAN

• CALCULATING THE INTEREST RATE REQUIRED

FOR A LOAN

• CALCULATING HOW MUCH YOU CAN BORROW

• CONVERTING BETWEEN THE NOMINAL RATE

AND THE EFFECTIVE RATE

• CALCULATING THE FUTURE VALUE

• SAVING TIME WITH EXCEL TABLE FEATURES

• SPLITTING THE WORKSHEET WINDOW INTO

PANES

• WRITTEN COMMUNICATION: 

SUMMARIZING DATA WITH A PIVOTTABLE

• CREATING A PIVOTCHART

• WORKING WITH CHARTS

• FORMATTING WORKBOOKS FOR READABILITY

AND APPEAL

• WORKING WITH THEMES

• WORKING WITH TABLE STYLES

• HIGHLIGHTING CELLS WITH CONDITIONAL

FORMATS

• HIDING WORKSHEET DATA

• FORMATTING THE WORKSHEET FOR PRINTING

• GROUPING WORKSHEETS

• USING 3-D REFERENCES TO ADD VALUES ACROSS

WORKSHEETS

• LINKING WORKBOOKS

• NAVIGATING AND ARRANGING MULTIPLE

WORKBOOKS

• CREATING AN EXCEL WORKSPACE



CONTENTS

© Stella Moysiadou - stm@aueb.gr 5

Microsoft Office 
Shipping, Finance & 
Management Skills

• CREATING A HYPERLINK

• CREATING TEMPLATES

• VALIDATING DATA ENTRY

• PROTECTING A WORKSHEET

• PROTECTING A WORKBOOK

• INSERTING COMMENTS

• SHARING A WORKBOOK WITH MULTIPLE USERS

• MERGE AND COMPARE WORKBOOKS

• SETTING DOCUMENT PROPERTIES

• INSPECTING A WORKBOOK

• ENCRYPTING A WORKBOOK

• MARKING A WORKBOOK AS FINAL

• PROVIDING A DIGITAL SIGNATURE

• ENSURING BACKWARD COMPATIBILITY IN A WORKBOOK

• AUTOMATING TASKS WITH MACROS



STARTING MICROSOFT EXCEL

• Click the Start button on the taskbar, click All Programs, click Microsoft Office, and 

then point to Microsoft Excel 2010. 

• If you don’t see Microsoft Excel 2010 on the Microsoft Office submenu, look for it on 

a different submenu or on the All Programs menu. 

• Click Microsoft Excel 2010. The Excel window opens. 

• If you want your Excel window zoomed, click the Zoom In button on the status bar to 

increase the zoom level. The magnification increases the screen size of each cell, but 

reduces the number of worksheet cells visible in the workbook window. 

• If necessary, click the Maximize button on the Excel window title bar. The Excel 

window fills the screen. 

• By default, Excel starts with a blank workbook maximized to fill the Excel window. 

The name of the active workbook, Book1, appears in the title bar. You can open more 

than one workbook window at a time to display the contents of different workbooks. 

You can also open multiple workbook windows for one workbook to display different 

views of the workbook’s contents. 
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VISUAL OVERVIEW
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VISUAL OVERVIEW
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VISUAL OVERVIEW
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VISUAL OVERVIEW

© Stella Moysiadou - stm@aueb.gr 10

Microsoft Office 
Shipping, Finance & 
Management Skills



NAVIGATING BETWEEN WORKSHEETS

• A workbook can have two kinds of sheets: worksheets and chart sheets. 

• A worksheet contains a grid of rows and columns into which the user enters data 

values and formulas. 

• A chart sheet contains an Excel chart that provides a visual representation of 

worksheet data. Charts can also be embedded within worksheets, displaying both the 

data and charts in one sheet. 

• By default, all new Excel workbooks are created with three worksheets named Sheet1, 

Sheet2, and Sheet3. The Sheet1 worksheet is the active sheet. 

• Multiple sheets enable you to better organize data in the workbook. For example, a 

sales report workbook might have a different worksheet for each sales region and 

another worksheet that summarizes the results from all the regions. 

• Some workbooks contain so many sheets that their sheet tabs cannot all be displayed at 

the same time in the workbook window. For these workbooks, you can scroll through 

the sheet tabs using the sheet tab scrolling buttons. Scrolling through the sheet tabs 

does not change the active sheet. To change the active sheet, you must click a sheet tab. 
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NAVIGATING WITHIN A WORKSHEET

• Each cell within a worksheet is identified by a cell reference, which indicates its 

column and row location. For example, the cell reference B6 refers to the cell located 

where column B intersects row 6. 

• The column letter always appears before the row number in any cell reference. 

• Row numbers range from 1 to 1,048,576. 

• The first 26 column letters range in alphabetical order from A to Z. After Z, the next 

column headings are labeled AA, AB, AC, and so forth. 

• Excel allows a maximum of 16,385 columns in a worksheet (the last column has the 

heading XFD). 

• When Excel starts, cell A1 is the active cell. 

• To view more of the active worksheet, you can use the horizontal and vertical scroll 

bars, located at the bottom and right side of the workbook window, respectively, to 

move through the worksheet horizontally and vertically. You can scroll one row or 

column at a time, or you can scroll several rows and columns. Scrolling through the 

worksheet does not change the location of the active cell. 

• As you work, you’ll need to change which cell is the active cell. You can use your 

mouse to click a cell to make it the active cell, or you can use the keyboard to move 

between cells. © Stella Moysiadou - stm@aueb.gr 12
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NAVIGATING WITHIN A WORKSHEET Microsoft Office 
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Press To move the active cell 

↑  ↓   Up, down, left, or right one cell 

Home To column A of the current row 

Ctrl+Home To cell A1 

Ctrl+End
To the last cell in the worksheet that contains 
data 

Enter 
Down one row or to the start of the next row 
of data 

Shift+Enter Up one row 

Tab One column to the right 

Shift+Tab One column to the left 

Page Up, Page Down Up or down one screen 

Ctrl+Page Up, Ctrl+Page Down 
To the previous or next sheet in the 
workbook 



NAVIGATING WITHIN A WORKSHEET

• To use the Go To dialog box to make a different cell active:

• Click the Home tab on the Ribbon. In the Editing group, click the Find & Select 

button, and then click Go To on the menu that opens. The Go To dialog box opens. 

• Type C14 in the Reference box. Click the OK button. Cell C14 is the active cell 

and its cell reference appears in the Name box. 

• To use the Name box to make a different cell active:

• Click in the Name box, type A1, and then press the Enter key. Cell A1 is once 

again the active cell. 
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WRITTEN COMMUNICATION: CREATING EFFECTIVE

WORKBOOKS

• Workbooks convey information in written form. As with any writing, the final product 

creates an impression and provides an indicator of your interest, knowledge, and 

attention to detail. To create the best impression, all workbooks—especially those 

you intend to share with others such as coworkers and clients—should be well planned, 

well organized, and well written. 

• A well-designed workbook should clearly identify its overall goal and present 

information in an organized format. The data it includes should be accurate both in the 

entered values and calculated values. Developing an effective workbook includes the 

following steps: 

• Determine the workbook’s purpose, content, and organization before you start. 

• Create a list of the sheets used in the workbook, making note of each sheet’s 

purpose. 

• Insert a documentation sheet that describes the workbook’s purpose and 

organization. Include the name of the workbook author, the date the workbook was 

created, and any additional information that will help others to track the workbook 

to its source. 
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WRITTEN COMMUNICATION: CREATING EFFECTIVE

WORKBOOKS

• Enter all of the data in the workbook. Add text to indicate what the values 

represent and, if possible, where they originated so others can view the source of 

your data. 

• Enter formulas for calculated items rather than entering the calculated values into 

the workbook. For more complicated calculations, provide documentation 

explaining them. 

• Test the workbook with a variety of values; edit the data and formulas to correct 

errors. 

• Save the workbook and create a backup copy when the project is completed. 

Print the workbook’s contents if you need to provide a hard-copy version to others 

or for your files. 

• Maintain a history of your workbook as it goes through different versions, so 

that you and others can quickly see how the workbook has changed during 

revisions.By including clearly written documentation, explanatory text, a logical 

organization, and accurate data and formulas, you’ll create effective workbooks 

that others can use easily. 
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ENTERING TEXT

• New data values are placed into the cell that is currently active in the worksheet. As 

you enter data, the entry appears in both the active cell and the formula bar. 

• Any text you enter in a cell that doesn’t fit within that cell covers the adjacent cells to 

the right as long as they are empty. If the adjacent cells contain text or data, only the 

text that fits into the cell is displayed. The rest of the text entry is hidden, or truncated, 

from the view. The text itself is not affected. The complete text is still entered in the 

cell; it’s just not displayed. To display all of the text, you must increase the cell’s width.

• As you type text into the active cell, Excel tries to anticipate the remaining characters 

by displaying text that begins with the same letters as a previous entry in the same 

column. This feature, known as AutoComplete, helps make entering repetitive text 

easier. To accept the suggested text, press the Tab or Enter key. To override the 

suggested text, continue to type the text you want to enter in the cell. AutoComplete 

does not work with dates or numbers, or when a blank cell is between the previous 

entry and the text you’re typing. 

• To place text on separate lines within the same cell, you press and hold the Alt key 

while you press the Enter key. This creates a line break within the cell. 
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ENTERING DATES

• You can enter dates in any of the standard date formats. For example, you can enter 

the date April 6, 2013 in any of the following date formats (and many others) and 

Excel recognizes each entry as representing the same date: 4/6/2013, 4/6/13, 4-6-2013, 

April 6, 2013, 6-Apr-13.

• Even though you enter a date as text, Excel stores the date as a numeric value equal

to the number of days between the specified date and January 0, 1900. This means that 

the date January 1, 1900 has a value of 1 and so forth. Times are also entered as text 

and are stored as fractional parts of a 24-hour day. Storing dates and times as numeric 

values allows Excel to perform date and time calculations, such as determining the 

elapsed time between one date and another. 

• Based on the default date format your computer uses, Excel might alter the date 

format you type. For example, if you enter the date 4/6/13 into the active cell, Excel 

might display the date with the four-digit year value, 4/6/2013; if you enter the text 

April 6, 2013, Excel might convert the date format to 6-Apr-13. Changing the date or 

time format doesn’t affect the underlying date or time value. 
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ENTERING NUMBERS

• In Excel, numbers can be integers such as 378, decimals such as 1.95, or negatives 

such as −5.2. In the case of currency and percentages, you can include the currency 

symbol and percent sign when you enter the value. Excel treats a currency value such 

as $87.25 as the number 87.25, and a percentage such as 95% as the decimal 0.95. 

Currency and percentages, like dates, are formatted in a convenient way for you to 

read. Excel right-aligns numbers within each cell. 

• If a number exceeds its cell size, you see ###### for the truncated numeric value. You 
can display the entire number by increasing the column width. 
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CHANGING THE COLUMN WIDTH OR ROW HEIGHT

• Drag the right border of the column heading left to decrease the column width or right 

to increase the column width. 

• Drag the bottom border of the row heading up to decrease the row height or down to 

increase the row height. 

OR

• Double-click the right border of a column heading or the bottom border of a row 

heading to autofit the column or row to the cell contents (or select one or more 

columns or rows, click the Home tab on the Ribbon, click the Format button in the 

Cells group, and then click AutoFit Column Width or AutoFit Row Height). 

OR

• Select one or more columns or rows. 

• Click the Home tab on the Ribbon, click the Format button in the Cells group, and 

then click Column Width or Row Height. 

• Enter the column width or row height you want, and then click the OK button. 
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INSERTING A COLUMN OR ROW

• Select the column(s) or row(s) where you want to insert the new column(s) or row(s); 

Excel will insert the same number of columns or rows as you select to the left of the 

selected columns or above the selected rows. 

OR

• In the Cells group on the Home tab, click the Insert button (or right-click a column or 

row heading or selected column and row headings, and then click Insert on the short-

cut menu). 
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DELETING AND CLEARING A ROW OR COLUMN

• You can remove data in two ways: clearing and deleting. 

• Clearing data from a worksheet removes the data, leaving blank cells where the data 

had been. Deleting data from the worksheet removes both the data and the cells. 

• When a cell is deleted, the remaining cells in the worksheet shift into the deleted 

location. For example, when you delete a column, the columns to the right shift left to 

fill the vacated space. Similarly, the rows below a deleted row shift up to fill the 

vacated space. 

• Note that pressing the Delete key does not delete the selected row or column; instead, 

it clears the contents, leaving the row or column in place. 

• To clear and delete a row: 

• Click the row heading. The entire row is selected. 

• Right-click the row heading, and then click Clear Contents on the shortcut menu. 

Excel clears the values in the row, but leaves the blank row in that space. 

• Verify that the row is still selected. 

• In the Cells group on the Home tab, click the Delete button. The row is deleted, 

and the rows below it shift up. 
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SAVING A WORKBOOK

• Click the File tab on the Ribbon to display Backstage view. 

• Click the Save command in the navigation bar. The Save As dialog box opens because 

this is the first time you are saving this workbook. 

• Navigate to the folder you want to save your file in. 

• Verify that Excel Workbook appears in the Save as type box. If your computer is set up 

to show filename extensions, you will see the Excel file extension .xlsx in the Save as 

type box as well. 

• In the File name box, type a name for your file.

• Click the Save button. The Save As dialog box closes and the workbook file is saved 

with its descriptive filename. 
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WORKING WITH CELLS AND RANGES

• Just as a cell reference indicates the location of an individual worksheet cell, a range 

reference indicates the location and size of a cell range. 

• For adjacent ranges, the range reference includes the cell reference of the upper-left 

and lower-right cells in the rectangular block separated by a colon. For example, the 

range reference A1:G5 refers to all the cells in the rectangular block from cells A1 

through G5. 

• The range reference for non-adjacent ranges separates each adjacent range reference 

by a semicolon. For example, the cell reference A1:A5;F1:G5 references two 

rectangular blocks of cells: one covering cells A1 through A5 and the other covering 

cells F1 through G5. 

• Selecting a range enables you to work with all of the cells in the range as a group. This 

means you can move the groups of cells, delete them, or clear all their contents at the 

same time. 
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SELECTING RANGES

• To select an adjacent range: 

• Click the cell in the upper-left corner of the adjacent range, drag the pointer to the cell in 

the lower-right corner of the adjacent range, and then release the mouse button. 

OR

• Click the cell in the upper-left corner of the adjacent range, press the Shift key as you 

click the cell in the lower-right corner of the adjacent range, and then release the Shift 

key. 

• To select a nonadjacent range of cells: 

• Select a cell or an adjacent range, press the Ctrl key as you select each additional cell or 

adjacent range, and then release the Ctrl key. 

• To select all the cells in a worksheet: 

• Click the Select All button located at the intersection of the row and column headings (or 

press the Ctrl+A keys). 

• To select an entire row or entire rows: 

• Click a row heading to select a single row. To select multiple rows, click and drag the 

pointer over multiple row headings. 

• To select an entire column or entire columns: 

• Click a column heading to select a single column. To select multiple columns, click and 

drag the pointer over multiple column headings. 25
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SELECTING ADJACENT RANGES
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SELECTING NON-ADJACENT RANGES
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MOVING AND COPYING A CELL OR RANGE

• Select the cell or range you want to move or copy. 

• Move the pointer over the border of the selection until the pointer changes shape. 

• To move the range, click the border and drag the selection to a new location (or to copy 

the range, hold down the Ctrl key and drag the selection to a new location). 

• To move to a location that is not visible, drag the selection to the edge of the worksheet 

window until it scrolls down or across, and then drop the selection into the new location. 

OR

• Select the cell or range you want to move or copy. 

• In the Clipboard group on the Home tab, click the Cut button or the Copy button (or 

• right-click the selection, and then click Cut or Copy on the shortcut menu). 

• Select the cell or upper-left cell of the range where you want to move or copy the 

• content. 

• In the Clipboard group, click the Paste button (or right-click the selection, and then click 

Paste on the shortcut menu). 
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INSERTING OR DELETING A RANGE

• Select a range that matches the range you want to insert or delete.

• In the Cells group on the Home tab, click the Insert button or the Delete button. 

OR

• Select the range that matches the range you want to insert or delete. 

• In the Cells group on the Home tab, click the Insert button arrow and then click Insert

Cells, or click the Delete button arrow and then click Delete Cells (or right-click the

selected range, and then click Insert or Delete on the shortcut menu). 

• Click the option button for the direction to shift the cells, columns, or rows. 

• Click the OK button. 
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INSERTING, DELETING, RENAMING A WORKSHEET

• To insert a new worksheet to the left of the active sheet, right-click a sheet tab, click 

Insert on the shortcut menu, select a sheet type, and then click the OK button. 

• To delete a worksheet:

• Right-click the sheet tab, and then click Delete on the shortcut menu. The worksheet 

is removed from the workbook. 

OR

• Click the sheet tab to make it the active sheet. 

• In the Cells group on the Home tab, click the Delete button arrow, and then click 

Delete Sheet. The worksheet is removed from the workbook. 

• To rename a worksheet:

• Double-click sheet tab. The sheet name is selected in the sheet tab. 

• Type the name you want and then press the Enter key. The width of the sheet tab 

adjusts automatically to the new sheet name. 

• You can also rename a sheet by right-clicking the sheet tab and clicking Rename on 

the shortcut menu. 
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MOVING AND COPYING A WORKSHEET

• You can change the placement of the worksheets in a workbook. A good practice is to 

place the most important worksheets at the beginning of the workbook (the leftmost sheet 

tabs) and less important worksheets toward the end (the rightmost tabs). 

• To move a sheet: 

• Click the sheet tab you want to move, to make that worksheet active. 

• Press and hold the mouse button so the pointer changes and a small triangle appears 

in the upper-left corner of the tab. 

• Drag the pointer to the right or left of the other sheet tabs and then release the mouse 

button to the place you want to move the sheet. 

• To copy a sheet:

• To copy a worksheet, hold down the Ctrl key as you drag and drop the sheet tab. The 

copy appears where you drop the sheet tab; the original remains in its initial position. 
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UNDOING AND REDOING AN ACTION

• Αs you revise a workbook, you might need to undo a previous action. Excel maintains a 

list of the actions you perform in a workbook during the current session, so you can undo 

most of these actions. You can reverse the most recent action or you can reverse more 

than one action. If you undo more than one action, all actions subsequent to the earliest 

action you select are also undone. 

• To undo an edit, on the Quick Access Toolbar, click the Undo button. 

• To redo an edit, on the Quick Access Toolbar, click the Redo button. 
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USING FIND AND REPLACE

• For greater speed and accuracy, you can use the Find command to locate a string of characters 

known as a search string and replace that text with a replacement string of new text 

characters. 

• You can limit the search to the current worksheet or search the entire workbook. You can 

specify whether to match the capitalization in the Find what box and whether the search text 

should match the entire cell contents or part of the cell contents. You can choose to review 

each occurrence of the search value and decide whether to replace it, or you can replace all 

occurrences at once. 

• In the Editing group on the Home tab, click the Find & Select button, and then click Replace. 

The Find and Replace dialog box opens.

• Type the search string in the Find what box, press the Tab key, and then type the replacement 

string of new text characters in the Replace with box. 

• Click the Options button. The dialog box expands to display additional Find and Replace 

options. 

• Verify that Sheet appears in the Within box to limit the find and replace to the current 

worksheet only. 

• Click the Replace All button. Excel finds and replaces the search string wherever it appears in 

the current worksheet. A dialog box opens, indicating that Excel has completed its search and 

made x replacements. 33
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USING FIND AND REPLACE
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USING THE SPELLING CHECKER

• Another editing tool is the spelling checker. Although the spelling checker’s dictionary 

includes a large number of words, as well as common first and last names and places, 

many words you use in workbooks might not be included. 

• If the spelling checker finds a word that is not in its dictionary, the word appears in a 

dialog box along with a list of suggested replacements. You can replace the word with one 

from the list, or you can ignore the word and go to the next possible misspelling. You can 

also add words to the dictionary to prevent them from being flagged as misspellings in the 

future. 

• Note that the spelling checker will not find a correctly spelled word used incorrectly, such 

as “there” instead of “their” or “your” instead of “you’re.” The best way to catch these 

types of errors is to proofread your worksheets. 

• To check the spelling in a worksheet: 

• Click cell A1 to start the spell check from the upper-left corner of the sheet. 

• Click the Review tab on the Ribbon, and then click the Spelling button in the 

Proofing group. 

35

Microsoft Office 
Shipping, Finance & 
Management Skills

© Stella Moysiadou - stm@aueb.gr
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CHANGING WORKSHEET VIEWS

• You can view a worksheet in three ways. Normal view shows the contents of the worksheet. 

Page Layout view shows how the worksheet will appear when printed. Page Break Preview

displays the location of the different page breaks within the worksheet. This is useful when a 

worksheet will span several printed pages and you need to control what content appears on 

each page. 

• Switching the worksheet views: 

• Click the Page Layout button on the status bar. The page layout of the worksheet appears 

in the program window. 

• If you want to see the rest of the data, which extends to a second page, use the Zoom 

slider to reduce the zoom level.

• Click the Page Break Preview button on the status bar. The view switches to Page Break 

Preview, which shows only those parts of the current worksheet that will print. A dotted 

blue border separates one page from another. If the Welcome to Page Break Preview 

dialog box opens, this is the first time you’ve switched to Page Break Preview. Click the 

OK button to close the dialog box and continue.

• Zoom the worksheet to 120% so that you can more easily read the contents of the 

worksheet. 

• Click the Normal button on the status bar. The worksheet returns to Normal view. A 

dotted black line indicates where the page break will occur. 37
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WORKING WITH PORTRAIT AND LANDSCAPE ORIENTATION

• In portrait orientation, the page is taller than it is wide. 

• In landscape orientation, the page is wider than it is tall. 

• By default, Excel displays pages in portrait orientation. 

• In many cases, however, you will want to print the page in landscape orientation. 

Changing the page orientation affects only the active worksheet. 

• To change the page orientation of the worksheet: 

• Click the Page Layout tab on the Ribbon. 

• In the Page Setup group, click the Orientation button, and then click Landscape. The 

orientation switches to landscape, and the worksheet contents fit on one page. 

• Click the Page Layout button on the status bar, and then verify that all the worksheet 

contents fit on one page. 
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PRINTING THE WORKBOOK

• You can print the contents of a workbook by using the Print tab in Backstage view. 

• The Print tab provides options for choosing what to print and how to print. For example, 

you can specify the number of copies to print, which printer to use, and what to print. 

• You can choose to print only the selected cells, the active sheets, or all worksheets in the 

workbook that contain data. The printout will include only the data in the worksheet. The 

other elements in the worksheet, such as the row and column headings and the gridlines 

around the worksheet cells, will not print by default. 

• You also see a preview of the workbook so you can see exactly how printed pages will 

look with the settings you’ve chosen before you print. A good practice is to always review 

the print preview before printing to ensure that the printout looks exactly as you intended 

and avoid unnecessary reprinting. 

• To preview and print the workbook: 

• Click the File tab on the Ribbon to display Backstage view. 

• Click the Print tab in the navigation bar to display the print options and preview of 

the first sheet in the workbook.
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VIEWING AND PRINTING WORKSHEET FORMULAS

• The printout of the worksheet displays only the worksheet values and none of the 

formulas. Most of the time, you will be interested in only the final results of the 

worksheet, not the formulas used to calculate those results. However, in some cases, you 

might want to view the formulas used to develop the workbook. This is particularly useful 

when you encounter unexpected results and you want to examine the underlying 

formulas, or you want to discuss your formulas with a colleague. 

• You can view the formulas in a workbook by switching to formula view, a view of the 

worksheet contents that displays formulas instead of the resulting values. 

• To view the formulas in the worksheet: 

• Click the sheet tab, if necessary, and then click the Normal button on the status bar. 

The worksheet is active and displayed in Normal view. 

• To toggle in and out of formula view, press the Ctrl+` keys. The ` grave accent 

symbol is usually located above the Tab key on your keyboard. 
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VIEWING AND PRINTING WORKSHEET FORMULAS

• If you want to get a printout of the formula view, it is possible that the worksheet will 

not fit on one page because of the expanded column widths. You can scale the worksheet 

to force the contents to fit on a single page. Scaling a printout reduces the width and the 

height of the printout to fit the number of pages you specify by shrinking the text size as 

needed. You can also scale a printout proportionally to a percentage of its actual size. 

• To scale the worksheet formulas to print on one page: 

• Click the Page Layout tab on the Ribbon. 

• In the Scale to Fit group, click the Width arrow, and then click 1 page. 

• In the Scale to Fit group, click the Height arrow, and then click 1 page. You’ll verify 

that the worksheet formula view fits on a single page. 

• Click the Page Layout button on the status bar, and then zoom the worksheet to 50%. 

The formula view of the worksheet fits on one page. 

• Click the File tab on the Ribbon to display Backstage view, and then click the Print 

tab in the navigation bar to view the print options. 

• In the Settings group, click the top button, and then click Print Active Sheets to print 

only the active worksheet. 

• Click the Print button. The active sheet prints. 
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WORKING WITH FORMULAS

• A formula is an expression that returns a value. In most cases, this is a numeric value though 

it could also be a text string, a yes/no value, or a date. Every Excel formula begins with an 

equal sign (=) followed by an expression describing the operation that returns the value. Note 

that if you don’t begin the formula with the equal sign, Excel assumes that you are entering 

text and will not treat the cell contents as a formula. 

• A formula is written using operators that combine different values, resulting in a

single value that is then displayed within the cell. The most commonly used operators

are arithmetic operators that perform addition, subtraction, multiplication, division, and 

exponentiation. 

• Most Excel formulas contain references to cells rather than specific values. This allows you to 

change the values being used in the calculation without having to modify the formula itself. 

• If a formula contains more than one arithmetic operator, Excel performs the calculation using 

the same order of precedence you might have already seen in math classes. The order of 

precedence is a set of predefined rules used to determine the sequence in which operators are 

applied in a calculation. Excel first calculates the value of any operation within parentheses, 

then it applies exponentiation (^), multiplication (*), and division (/), and finally it performs 

addition (+) and subtraction (−). 
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Operation 
Arithmetic 

Operator 
Example Description 

Addition + 
=10+A1 

=B1+B2+B3 

Adds 10 to the value in cell A1

Adds the values in cells B1, B2, and B3 

Subtraction − 
=C9–B2 =1–

D2 

Subtracts the value in cell B2 from the value in 

cell C9 Subtracts the value in cell D2 from 1 

Multiplication * 
=C9*B9 

=E5*0.06 

Multiplies the values in cells C9 and B9 

Multiplies the value in cell E5 by 0.06 

Division / 
=C9/B9 

=D15/12 

Divides the value in cell C9 by the value in cell 

B9 Divides the value in cell D15 by 12 

Exponentiation ^ 
=B5^3 

=3^B5 

Raises the value of cell B5 to the third power 

Raises 3 to the value in cell B5 



ENTERING A FORMULA

• To insert a formula:

• Click the cell in which you want the formula results to appear.

• Type = and a formula that calculates a value using cell references and arithmetic operators.

• Press the Enter key or press the Tab key to complete the formula. 

• After a formula has been entered into a cell, the worksheet displays the value returned by the 

formula. If the results are not what you expect, you might have entered the formula incorrectly. 

You can view the formula by selecting the cell and reviewing the expression displayed in the 

formula bar. One challenge with formulas, particularly long formulas, is interpreting the cell 

references. Excel makes this simpler by color coding each cell reference in the formula and its 

corresponding cell in the worksheet. 
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COPYING AND PASTING FORMULAS

• Sometimes you’ll need to repeat the same formula throughout your worksheet. Rather than 

retyping the formula, you can copy a formula from one cell and paste it into another cell. 

Pasting a formula is different from pasting a value. With formulas, Excel adjusts the formula’s 

cell references to reflect the new location of the formula in the worksheet. This is because you 

usually want to copy the actions of a formula rather than the specific value the formula 

generates. 

• To copy and paste a formula: 

• Click the cell that contains the formula you want to copy. 

• In the Clipboard group on the Home tab, click the Copy button. Excel copies the formula 

to the Clipboard. The cell from which the formula was copied has a dotted border to 

remind you that cell is being copied. 

• Select the range of cells in which you want to paste the formula. 

• In the Clipboard group, click the Paste button. Excel pastes the formula into the selected 

range. A shortcut button appears below the selected range, providing options for pasting 

formulas and values. 
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UNDERSTANDING CELL REFERENCES

• Relative references: when Excel copies and pastes them, they are always interpreted in 

relation, or relative, to the location of the cell containing the formula. 

• To enter a relative reference, type the cell reference as it appears in the worksheet. For 

example, enter B2 for cell B2. 

• Instead of using relative references, you may need to use a cell reference that will remain fixed 

when the formula is copied to a new location. Cell references that remain fixed are called 

absolute references. In Excel, absolute references have a $ (dollar sign) before each column 

and row designation. For example, B8 is a relative reference to cell B8, whereas $B$8 is an 

absolute reference to cell B8. 

• To enter an absolute reference, type $ (a dollar sign) before both the row and column 

references. For example, enter $B$2. 

• A formula can also include cell references that are mixed. A mixed reference contains both 

relative and absolute references. For example, a mixed reference for cell A2 can be either $A2 

or A$2. In the mixed reference $A2, the column reference to column A is absolute and the 

reference to row 2 is relative. When you copy and paste a formula with a mixed reference to a 

new location, the absolute portion of the cell reference remains fixed and the relative portion 

shifts. 

• To enter a mixed reference, type $ before either the row or column reference. For 

example, enter $B2 or B$2. 51
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UNDERSTANDING CELL REFERENCES

• As you develop formulas and worksheets, you might want to quickly switch a cell reference 

from relative to absolute or mixed. Rather than retyping the formula, you can switch the 

reference in editing mode by selecting the cell reference and pressing the

F4 key. As you press the function key, Excel cycles through the different reference types, 

starting by changing a relative reference to an absolute reference, then to a mixed refer- ence

with the row absolute, then to a mixed reference with the column absolute, and then finally 

back to a relative reference. 

52

Microsoft Office 
Shipping, Finance & 
Management Skills

© Stella Moysiadou - stm@aueb.gr



UNDERSTANDING CELL REFERENCES

53

Microsoft Office 
Shipping, Finance & 
Management Skills

© Stella Moysiadou - stm@aueb.gr



COPYING FORMULAS AND FORMATS WITH AUTOFILL

• After you select a range, the fill handle appears in the lower-right corner of the selection. 

When you drag the fill handle over an adjacent range, Excel uses AutoFill to copy the 

content and formats from the original cell into the adjacent range. This process is often 

more efficient than the two-step process of copying and pasting. 

• Select the cell or range that contains the formula or formulas you want to copy. 

• Drag the fill handle in the direction you want to copy the formula(s) and then release 

the mouse button. 

• To copy only the formats or only the formulas, click the Auto Fill Options button and 

select the appropriate option. 
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USING THE AUTO FILL OPTIONS BUTTON

• By default, AutoFill copies both the content and the formatting of the original range

to the selected range. However, sometimes you might want to copy only the content

or only the formatting. The Auto Fill Options button that appears after you release the 

mouse button lets you specify what is copied. Clicking this button provides a list of Auto-

Fill options. 

• The Copy Cells option, which is the default, copies both the content and the 

formatting. 

• The Fill Formatting Only option copies the formatting into the selected cells but not 

any content. 

• The Fill Without Formatting option copies the content but not the formatting. 
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FILLING A SERIES

• AutoFill can also be used to create a series of numbers, dates, or text based on a pattern. 

• To create a series of numbers, you enter the initial values in the series in a selected range 

and then use AutoFill to complete the series. 
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FILLING A SERIES

• For more complex patterns, you can use the Series dialog box. 

• To do so, enter the first value of the series in a worksheet cell, select the entire range that 

will contain the series, click the Fill button in the Editing group on the Home tab, and 

then click Series. 

• The Series dialog box opens. From the Series dialog box you can specify a linear or 

growth series for numeric values; a Date series for dates that increase by day, weekday, 

month, or year; or an AutoFill series for patterned text. 

• With numeric values, you can also specify the step value (indicating how much each 

numeric value increases over the previous entry) and a stop value (to specify the endpoint 

for the entire series). 
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INTRODUCING FUNCTIONS

• A function is a named operation that returns a value. Functions are used to simplify 

formulas, reducing what might be a long formula into a compact statement. 

• For example, to add the values in the range A1:A10, you could enter the following long 

formula: 

• =A1+A2+A3+A4+A5+A6+A7+A8+A9+A10. Or, you could use the SUM function to 

calculate the sum of cell values found within a specified range. In this case, the formula 

would appear as: =SUM(A1:A10) 

• In both instances, Excel adds the values in cells A1 through A10, but the SUM function is 

faster and simpler to enter and less prone to a typing error. You should always use a 

function, if one is available, in place of a long, complex formula. 

• Excel supports more than 300 different functions from the fields of finance, business, 

science, and engineering. Excel provides functions that work with numbers, text, and 

dates. 
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ENTERING A FUNCTION

• To enter the SUM function:

• Click the cell in which you want to enter the function to make it active.

• Type ‘ =SUM(F6:F9)’. 

• As you begin to type the function, a ScreenTip lists the names of all functions that 

start with the letter “S.” 

• When you type the cell references, Excel highlights all the cells in the specified range 

to provide a visual reminder of exactly which cells the SUM function is using. 
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ENTERING FUNCTIONS WITH THE AUTOSUM FEATURE

• A fast and convenient way to enter commonly used functions is with the AutoSum 

feature. The AutoSum feature includes buttons to quickly insert the SUM, AVERAGE, 

COUNT, MIN, and MAX functions to generate the following: 

• Sum of the values in the column or row

• Average value in the column or row

• Total count of numeric values in the column or row 

• Minimum value in the column or row

• Maximum value in the column or row 

• Excel determines the range reference needed for the function being inserted by the 

AutoSum feature by examining the layout of the data and choosing what seems to be the 

most likely range. When you use the Sum button, Excel highlights the range it thinks you 

want to use. For example, if you use the Sum button in a cell that is below a column of 

numbers, Excel assumes that you want to summarize the values in the column. You can 

change that range by typing a different range reference or selecting a different range. 

• Make sure to always verify the range AutoSum selected, especially when a worksheet’s 

column or row titles contain numbers. AutoSum cannot differentiate between numbers 

used as titles (such as years) and numbers used as data for the calculation. 61
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WORKING WITH LOGICAL FUNCTIONS

• A logical function is a function that works with statements that are either true or false. 

Consider a statement such as “cell A5 = 3”. If cell A5 is equal to 3, this statement has a 

value of true; if cell A5 is not equal to 3, this statement has a value of false. Excel sup-

ports many different logical functions, one of which is the IF function. 

• Using the IF Function:

• The IF function is a logical function that returns one value if a statement is true and 

returns a different value if that statement is false. 

• The syntax of the IF function is IF( logical_test, [value_if_true,] [value_if_false] ), 

where logical_test is a statement that is either true or false, value_if_true is the value 

returned by the IF function if the statement is true, and value_if_false is the value 

returned by the function if the statement is false. 

• For example, the following formula tests whether the value in cell A1 is equal to the value 

in cell B1. If it is, the formula returns a value of 100; otherwise it returns a value of 50. 

=IF(A1=B1, 100, 50) 

• In many cases, however, you will not use values directly in the IF function. The following 

formula uses cell references, returning the value of cell C1 if A1 equals B1; otherwise, it 

returns the value of cell C2: =IF(A1=B1,C1,C2) 
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WORKING WITH LOGICAL FUNCTIONS

• The IF function also works with text. 

• For example, the following formula tests whether the value of cell A1 is equal to YES. If 

the value of cell A1 is equal to YES, the formula returns the text DONE; otherwise, it 

returns the text RESTART : =IF(A1=”YES”, “DONE”, “RESTART”) 

• In addition, you can nest other functions inside an IF statement. The following formula 

first tests whether cell A5 is equal to the maximum of values within the range A1:A100. If 

it is, the formula returns the text “Maximum”; otherwise, it returns no text: 

=IF(A5=MAX(A1:A100), “Maximum”, “ ”)
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USING THE IF FUNCTION TO EXPLORE FINANCIAL OPTIONS

• With financial decisions, you will often explore the impact of alternative scenarios on a 

projected outcome. Budget planning should not be limited to a single budget projection, 

but instead include several possible budgets. Your decision is then based on the evaluation 

of these different budgets. The budget you choose should prepare you to deal with short-

ages in future revenue or ways to take advantage of better-than-expected revenue. 

• Using Excel to manage your finances allows you to quickly explore these multiple 

scenarios. You can quickly examine how changing one or more values will affect such 

outcomes as income, expenses, and cash flow. You can use logical functions such as the 

IF function to help you explore these what-if scenarios because you can set the outcome 

of one value only if certain conditions are met. Different scenarios can be coded with 

names such as Option1, Option2, and Option 3. By using these scenario names as input 

values to an IF function, you can set up the worksheet to display the results specific to 

each scenario. In a well-designed workbook, you can quickly switch between scenarios 

simply by changing a few values in the worksheet. 

• By applying Excel’s logical functions, you can more easily plan for different outcomes, 

and avoid the problems associated with unexpected occurrences. 
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• The IF function can choose between only two outcomes; it cannot choose from among 

three or more outcomes. However, you can nest IF functions to allow for three or 

more outcomes. A nested IF function is when one IF function is placed inside another 

IF function to test an additional condition. You can nest more than one IF function. 

• Example:

• Purpose: To determine the fee for a driver’s license 

• Logic Scenario: Driver’s license fee varies by age:

• Data: cell B1 stores the driver’s age 

• Formula: Nested IF functions

=IF(B1<16,“Too Young”, IF(B1<=45,30,IF(B1<=60,25,20))) 



FINDING AND FIXING ERRORS IN FORMULAS
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• If formulas in a worksheet are returning errors or not working as expected, you need

to find and fix the problems. Two common categories of formula errors in Excel are syntax 

errors and logic errors. 

• A syntax error is an error in a statement that violates the rules of Excel. A syntax 

error might occur due to unmatched parentheses or a required argument that is omitted 

in a function. 

• Logic errors occur in formulas that work but return an incorrect result. A logic error 

could occur because the formula uses the wrong calculation, the formula references 

the wrong cell, or the formula uses faulty reasoning, leading to incorrect results. 

• Some problem-solving approaches can help resolve these types of errors. 

• First, examine the formulas in worksheet cells instead of the results by pressing the 

Ctrl+ ~ keys to show the formulas in each cell. 

• Next, troubleshoot problem areas in the worksheet by pressing the F9 key to highlight 

part of a formula and temporarily display the actual value in the cell so you can check 

intermediate results. 

• Press the Esc key to return the cell references. 

• Finally, you can use the Formula Auditing tools on the Formulas tab to visually 

identify and trace cells used in a formula. This can help you locate and fix inaccurate 

cell references and faulty logic. 



USING THE AND FUNCTION
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• The IF function evaluates a single condition. However, you often need to test two or 

more conditions and determine whether all conditions are true. You can do this with 

the AND function. 

• The AND function is a logical function that returns the value TRUE if all the logical 

conditions are true and the value FALSE if any or all of the logical conditions are 

false. 

• The syntax of the AND function is AND(logical1 [,logical2,]...), where logical1 and 

logical2 are conditions that can be either true or false. 

• If all of the logical conditions are true, the AND function returns the logical value 

TRUE; otherwise, the function returns the logical value FALSE. 

• You can include up to 255 logical conditions in an AND function. However, keep in 

mind that all the logical conditions listed in the AND function must be true for the 

AND function to return a TRUE value. 
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USING THE OR FUNCTION
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• The OR function is a logical function that returns a TRUE value if any of the logical 

conditions are true and a FALSE value if all of the logical conditions are false. 

• The syntax of the OR function is OR(logical1 [,logical2,]...), where logical1 and 

logical2 are conditions that can be either true or false. 

• If any of the logical conditions are true, the OR function returns the logical value 

TRUE; otherwise, the function returns the logical value FALSE. 

• You can include up to 255 logical conditions in the OR function. However, keep in 

mind that if any logical condition listed in the OR function is true, the OR function 

returns a TRUE value. 
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USING STRUCTURED REFERENCES TO CREATE

FORMULAS IN EXCEL TABLES
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• When you create a formula that references all or parts of an Excel table, you can 

replace the specific cell or range address with a structured reference, the actual 

table name or column header. This makes the formula easier to create and understand. 

• The default Excel table name is Table1, Table2, and so forth unless you entered a 

more descriptive table name, for example ‘Employee’ table. 

• Column headers provide a description of the data entered in each column. Structured 

references make it easier to create formulas that use portions or all of an Excel table 

because the names or headers are usually simpler to identify than cell addresses. 

• For example, in the Employee table, the table name ‘Employee’ refers to the range 

A2:N101, which is the range of data in the table excluding the header row and the 

Total row. 

• When you want to reference an entire column of data in a table, you create a column 

qualifier, which has the syntax Tablename[qualifier], where Tablename is the name 

entered in the Table Name box in the Properties group on the Table Tools Design tab, 

and qualifier is the column header enclosed in square brackets. 

• For example, the structured reference Employee[Annual Salary] references the annual 

salary data in the range K2:K101 of the Employee table. 



USING STRUCTURED REFERENCES TO CREATE

FORMULAS IN EXCEL TABLES
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• You use structured references in formulas. The following formula adds the annual salary 

data in the range K2:K101 of the Employee table; in this case, [Annual Salary] is the 

column qualifier: =SUM(Employee[Annual Salary]) 

• When you create a calculated column, you can use structured references to create the 

formula. A formula that includes a structured reference can be fully qualified or 

unqualified. 

• In a fully qualified structured reference, the table name precedes the column qualifier. 

• In an unqualified structured reference, only the column qualifier appears in the 

reference. 

• For example, you could have used either of the following formulas with structured 

references to calculate Life Ins Premium in the calculated column of the Employee table: 

• Fully qualified: =IF(Employee[Add Life Ins]=”Y”,Employee[Annual Salary]*.001,0) 

• Unqualified: =IF([Add Life Ins]=”Y”,[Annual Salary]*.001,0) I

• f you are creating a calculated column or formula within an Excel table, you can use either 

the fully qualified structured reference or the unqualified structured reference in the 

formula. 

• If you use a structured reference outside the table or in another worksheet to reference an 

Excel table or portion of the table, you must use a fully qualified reference. 
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• Lookup functions allow you to use tables of data to “look up” values and insert them in 

another worksheet location. For example, you might enter a product table in a worksheet 

that includes the product ID, product name, and price of all products a company sells. You 

could then use this product table to build an invoice in another worksheet by entering a 

product ID and having Excel look up the product name and price, and insert these values in 

the invoice. 

• The table that stores the data you want to retrieve is called a lookup table, and it organizes 

the data you want to retrieve into different categories, such as by product ID. The 

categories for the lookup table, called compare values, are located in the table’s first 

column or row. To retrieve a particular value from the table, a lookup value (the value you 

are trying to find) needs to match one of the compare values. When a match is found, the 

corresponding value in the lookup table is displayed in the cell where the lookup formula is 

entered. Lookup values can also be used as part of a formula. 

• Lookup tables can be constructed as either exact match or approximate match lookups. 

• An exact match lookup occurs when the value entered must match one of the values in 

the first column of the lookup table. 

• An approximate match lookup occurs when the value entered falls within a range of 

values in the first column of the lookup table. 
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• The VLOOKUP function has the syntax VLOOKUP(lookup_value, table_array, 

col_index_num, [range_lookup]), where 

• lookup_value is the value you want to use to search the first column of the 

lookup table 

• table_array is the range reference of the lookup table or its table name

• col_index_num is the number of the column in the lookup table that contains the 

value you want to return

• range_lookup indicates whether the compare values are a range of values (for an 

approximate match) or an exact match.

• When you use a range of values, you set the range_lookup value to TRUE.

• When you want the lookup_value to exactly match a value in the first column of the 

table_array, you set the range_lookup value to FALSE. 

• The range_lookup argument is optional; if you don’t include a range_lookup value, the 

value is considered TRUE (an approximate match). 
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• You’ll use the VLOOKUP function to calculate the annual health plan cost for an 

employee. Suppose you want to derive from the first column of the HealthPlanRates

table (range B4:C8), the monthly Health Plan Rate for the employee whose code is 

stored in row 2 of the Health Plan column (column L) of the Employee table. You 

want the function to return the annual Health Plan cost for this employee in the second 

column of the HealthPlanRates lookup table.

• You can use range references or structured references, as follows: 

• Range references =VLOOKUP(L2, 'Lookup Tables'! $B$4:$C$8, 2, FALSE)*12 

• Structured references =VLOOKUP([HealthPlan], HealthPlanRates, 2, FALSE)*12 

• Both of these formulas use the VLOOKUP function to search for the code in the 

Health Plan column (column L) of the Employee table, in the first column of the 

lookup table (the HealthPlanRates table in the range B4:C8 in the Lookup Tables 

worksheet), and then return the value in the second column of the HealthPlanRates

lookup table, which shows the monthly cost. The formulas use FALSE as the 

range_lookup argument because you want the lookup value to exactly match a value 

in the first column of the HealthPlanRates table. 
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• You can also use a VLOOKUP function to return a value from a table that is based on 

an approximate match lookup. The previous table lookup used the HealthPlanRates

table to return a value only if Excel found an exact match in the first column of the 

lookup table. The categories in the first column or row of a lookup table can also 

represent a range of values. Quantity discounts, shipping charges, and income tax rates 

are a few examples of approximate match lookups. 

• Suppose that the management of a company plans to give employee-recognition 

awards based on the number of years individuals have worked for the company. The 

criteria developed are as follows:
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• You need to use an approximate match lookup, which determines whether the lookup 

value falls within a range of values. 

• When a lookup table is used with a range of values, the compare values must be 

sorted in alphabetical order if they are text and in low-to-high order if they are 

numbers. 

• When the compare values are arranged in a different order, Excel may not retrieve the 

correct value, leading to incorrect results. The setup of the lookup table in an 

approximate match is critical for a VLOOKUP formula to work. 

• To determine whether a lookup value falls within a range of values in the lookup table, 

Excel searches the first column of the table until it locates the largest value that is less 

than the lookup value. Then Excel moves across the row in the table to retrieve the 

corresponding value. 

• For an employee working at the company for six years, Excel would search the lookup 

table until the compare value is 5 (the largest value less than the lookup value) and 

retrieve 300 from column 2 of the corresponding row. 
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• The HLOOKUP function is very similar to the VLOOKUP function. The HLOOKUP 

function (horizontal lookup function) searches horizontally across the top row of the 

lookup table and retrieves the value in the column you specify. 

• You use the HLOOKUP function when the comparison values are located in the 

first row of the lookup table and you want to look down a specified number of rows 

to find the data to enter in another cell. 

• The HLOOKUP function has the syntax HLOOKUP(lookup_value, table_array, 

row_index_num, [range_lookup]), where 

• lookup_value is the value you want to use to search the first row of the

lookup table

• table_array is the range reference of the lookup table or its table name

• row_index_num is the number of the row in the lookup table that contains the 

value you want to return

• range_lookup indicates whether the compare values are a range of values or an 

exact match. 
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• When you use a range of values (such as in a tax rate table), you set the range_lookup value to 

TRUE.

• When you want the lookup_value to exactly match a value in the first row of the table_array, 

you set the range_lookup value to FALSE. 

• The range_lookup argument is optional; if you don’t include a range_lookup value, the value is 

considered TRUE (an approximate match). 

• The major difference between HLOOKUP and VLOOKUP functions is the way the lookup 

tables are organized:

• With the lookup tables of the previous example, 

• the exact match formula to calculate the annual health plan cost is 

=HLOOKUP([HealthPlan], HealthPlanRates, 2, FALSE)*12

• the approximate match formula to calculate the recognition award is =HLOOKUP([Years 

Service], Recognition, 2) 
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• The Excel INDEX function returns a value in an array based on the row and column 

numbers you specify. 

• The syntax of the INDEX function is straightforward: INDEX(array, row_num, 

[column_num]) where

• array is a range of cells that you want to return a value from

• row_num is the row number in array from which you want to return a value. If 

omitted, the column_num is required.

• column_num is the column number in array from which you want to return a 

value. If omitted, row_num is required.

• If both row_num and column_num parameters are used, the INDEX function returns 

the value in the cell at the intersection of the specified row and column.

• Here is the simplest example of the INDEX formula: =INDEX(A1:C10,2,3)

• The formula searches in cells A1 through C10 and returns a value of the cell in 

the 2nd row and the 3rd column, i.e. cell C2.
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• The Excel MATCH function searches for a lookup value in a range of cells, and returns the 

relative position of that value in the range.

• For example, if the range B1:B3 contains the values "New-York", "Paris", "London", then the 

formula =MATCH("London",B1:B3,0) returns the number 3, because "London" is the third 

entry in the range.

• The syntax of the MATCH function is MATCH(lookup_value, lookup_array, [match_type]) 

where

• lookup_value is the number or text you are looking for. This can be a value, a cell 

reference or logical value.

• lookup_array is a range of cells being searched

• match_type tells the MATCH function whether you want to return an exact match or the 

nearest match:

• 1 or omitted - finds the largest value that is less than or equal to the lookup value. The 

values in the lookup array must be sorted in ascending order, i.e. from smallest to 

largest.

• 0 - finds the first value that is exactly equal to the lookup value. In the INDEX / 

MATCH combination, you almost always need the exact match, so the third argument 

of your MATCH function is "0".

• -1 - finds the smallest value that is greater than or equal to lookup_value. The values 

in the lookup array must be sorted in descending order, i.e. from largest to smallest.
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• At first sight, the usefulness of the MATCH function may seem questionable. Who cares 

about the position of a value in a range? What we do want to know is the value itself.

• The relative position of the lookup value (i.e. a row or/and column number) is exactly what 

you need to supply to the row_num or/and column_num argument of the INDEX function. 

The INDEX function can return the value at the juncture of a given row and column, but it 

cannot determine which exactly row and column you want.

• Let's find the population of some capital, say the capital of Japan, using the following 

Index Match formula: =INDEX($D$2:$D$10,MATCH("Japan",$B$2:$B$10,0))

• The MATCH function searches for the lookup value "Japan" in column B, more 

precisely cells B2:B10, and returns the number 3, because "Japan" is the third in the 

list.

• The INDEX functions takes "3" in the second parameter (row_num), which indicates 

which row you want to return a value from, and turns into a simple 

=INDEX($D$2:$D$10,3). Translated into plain English, the formula reads: search in 

cells D2 through D10 and return a value of the cell in the 3rd row, i.e. cell D4, because 

we start counting from the second row.

• Important! The number of rows and columns in the INDEX array should match those in 

the row_num or/and column_num parameters of the MATCH functions, respectively. 

Otherwise, the formula will return incorrect result.
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• Right to left lookup: Excel VLOOKUP cannot look to its left, meaning that your lookup 

value should always reside in the left-most column of the lookup range. With INDEX 

MATCH, your lookup column can be on the right side of your table as well. 

• Insert or delete columns safely: VLOOKUP formulas get broken or return incorrect 

results when a new column is deleted from or added to a lookup table. With VLOOKUP, 

any inserted or deleted column changes the results returned by your formulas because the 

VLOOKUP function's syntax requires specifying the entire table array and a certain 

number indicating which column you want to pull the data from.

• For example, if you have a table A1:C10 and want to return a value from column B, 

you will put "2" in the third parameter (col_index_num) of a VLOOKUP formula, say 

=VLOOKUP("lookup value", A1:C10, 2). If at a later point, you insert a new column 

between A and B, you will have to change "2" to "3" in your formula, otherwise it 

would return a value from the newly inserted column.With INDEX MATCH, you can 

delete or insert new columns in your lookup table without distorting the results since 

you specify directly the column containing the value you want to get. This is a really 

great benefit, especially when working with large datasets, since you are able to insert 

and remove columns without worrying about updating every associated vlookup

formula.
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• No limit for a lookup value's size: When using the VLOOKUP function, the total length 

of your lookup criteria should not exceed 255 characters, otherwise you will end up having 

the #VALUE! error. So, if your dataset contains long strings, INDEX MATCH is the only 

working solution. 

• Suppose, you are using the following VLOOKUP formula that searches through cells 

B5 to D10 for the value in cell A2: =VLOOKUP(A2,B5:D10,3,FALSE) The 

formula won't work if the lookup value in cell A2 exceeds 255 symbols. Instead, you 

shall use the analogous INDEX / MATCH function: =INDEX(D5:D10, 

MATCH(TRUE, INDEX(B5:B10=A2, 0), 0))

• Higher processing speed: If you are working with relatively small tables, the difference in 

Excel's performance will most likely be unnoticeable, especially in recent versions. But if 

you use large worksheets with thousands of rows and thousands of lookup formulas, Excel 

will work much faster if you use MATCH INDEX rather than VLOOKUP. Generally, the 

use of Index / Match formulas increases Excel's performance by 13% compared to 

equivalent Vlookup formulas. 
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• Error values indicate that some element in a formula or a cell referenced in a formula 

is preventing Excel from returning a calculated value. 

• An error value begins with a number sign (#) followed by an error name that indicates 

the type of error. 
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• These error value messages are not particularly descriptive or helpful. To display a 

more descriptive message that helps users fix the problem, you can use the 

IFERROR function. 

• The IFERROR function can determine if a cell contains an error value and then 

display the message you choose rather than the default error value. 

• The IFERROR function has the syntax IFERROR(expression, valueIfError), where 

• expression is the formula you want to check for an error

• valueIfError is the message you want displayed if Excel detects an error in the 

formula you are checking. 

• If Excel does not detect an error, the result of the expression is displayed. 

• For example, referring to the previous example, you can enter the following formula to 

determine whether an invalid code was entered in the Health Plan column of the 

Employee table and then display a more descriptive message if Excel detects an error: 

=IFERROR(VLOOKUP(L2,HealthPlanRates,2,False)*12,”Invalid code”) 
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• Based on this formula, if the value in cell L2 is for example HMOF, the result of the VLOOKUP 

formula is $1,500 (the corresponding value from the HealthPlanRates table), the first argument in the 

IFERROR function (shown in purple) is executed, and the health cost is displayed. 

• On the other hand, if cell L2 has an invalid health plan code, such as HMOG, the VLOOKUP 

function returns the error value #N/A, the second argument in the IFERROR function is executed, 

and “Invalid code” is displayed. 
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• The COUNT function allies the number of data values in a range, the SUM function adds the 

values in a range, and the AVERAGE function calculates the average of the values in a range. 

However, sometimes you need to calculate a conditional count, sum, or average using only 

those cells that meet a particular condition. In those cases, you need to use the COUNTIF, 

SUMIF, and AVERAGEIF functions. 

• Using the COUNTIF Function: 

• You can calculate the number of cells in a range that match criteria you specify using the 

COUNTIF function, which is sometimes referred to as a conditional count. 

• The COUNTIF function has the syntax COUNTIF(range, criteria) where 

• range is the range of cells you want to count

• criteria is an expression that defines which cells to count. 
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• Using the SUMIF Function: 

• The SUMIF function adds the values in a range that meet criteria you specify. The SUMIF function 

is also called a conditional sum. 

• The syntax of the SUMIF function is SUMIF(range, criteria [, sum_range]) where 

• range is the range of cells you want to filter before calculating a sum

• criteria is the condition used to filter the range

• sum_range is the range of cells to total. 

• The sum_range is optional; if you omit it, Excel will total the values specified in the range 

argument. For example, if you want to total the salaries for all employees with salaries greater than 

$50,000, you do not use the optional third argument. 
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• Using the AVERAGEIF Function:

• You use the AVERAGEIF function to calculate the average of values in a range that meet 

criteria you specify. 

• The syntax of the AVERAGEIF function is AVERAGEIF(range, criteria [average_range]) 

where 

• range is the range of cells you want to filter before calculating the average 

• criteria is the condition used to filter the range

• average_range is the range of cells to average. 

• The average_range is optional; if you omit it, Excel will average the values specified in the 

range argument. 
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• Using the COUNTIFS, SUMIFS, and AVERAGEIFS Functions:

• The COUNTIFS, SUMIFS, and AVERAGEIFS functions are similar to the 

COUNTIF, SUMIF, and AVERAGEIF functions except the latter functions enable 

you to specify only one condition to summarize the data, whereas the former 

functions enable you to sum- marize the data using several conditions. 

• The COUNTIFS function counts the number of cells within a range that meet multiple 

criteria. 

• Its syntax is COUNTIFS(,criteria_range1,criteria1[,criteria_range2,criteria2,...]) 

where 

• criteria_range1, criteria_range2, and up represent up to 127 ranges (columns of data) in 

which to evaluate the associated criteria

• criteria1, criteria2, and up represent 127 criteria in the form of a number, an expression, a 

cell reference, or text that define which cells will be counted. Each cell in a range is 

counted only if all of the corresponding criteria specified in the COUNTIFS function are 

true. 
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• The SUMIFS and AVERAGEIFS functions have a slightly different syntax. 

• The SUMIFS function adds values in a range that meet multiple criteria using the syntax 

SUMIFS(sum_range, criteria_range1, criteria1 [,criteria_range2, criteria2,...]) where 

• sum_range is the range you want to add; 

• criteria_range1, criteria_range2, and so on represent up to 127 ranges (columns of 

data) in which to evaluate the associated criteria; 

• criteria1, criteria2, and so on up to 127 criteria in the form of a number, expression, 

cell reference, or text define which cells will be added. 

• To calculate the total salary paid to full-time (FT) employees hired after 2012 who

are living in Austin, you can use the following SUMIFS function to add the salaries 

• (Employee[Annual Salary]) 

• of employees located in Austin (Employee[Location],“Austin”) 

• who have a hire date on or later than 1/1/2012 (Employee[Hire Date],“>=1/1/2012”) 

and 

• are full-time employees (Employee[Job Status],“FT”): 

=SUMIFS(Employee[Annual Salary],Employee [Location],”Austin”, 

Employee[Hire Date],”>=1/1/2012”,Employee[Job Status],”FT”) 
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• The AVERAGEIFS function calculates the average of values within a range of cells that 

meet multiple conditions. 

• Its syntax is AVERAGEIFS(average_range, criteria_range1, 

criteria1[,criteria_range2, criteria2,...]) where 

• average_range is the range to average

• criteria_range1, criteria_range2, and so on represent up to 127 ranges in which to 

evaluate the associated criteria

• criteria1, criteria2, and so on up to 127 criteria in the form of a number, an 

expression, a cell reference, or text define which cells will be averaged. 

• To calculate the average salary paid to males (M) who have worked at Talent Tracs for 

more than five years, you can use the following AVERAGEIFS function to average the 

• salaries (Employee[Annual Salary]) 

• of male employees (Employee[Sex],“M”) 

• having more than five years of service (Employee[Years Service],“>5”): 

=AVERAGEIFS(Employee[Annual Salary],Employee[Sex],“M”, Employee[Years 

Service],“>5”) 
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• AVERAGE Function:

• The mean is what you probably think of when someone uses the term average. This 

occurs because the average is the arithmetic mean of a set of numbers. 

• In Excel, you calculate the mean using the AVERAGE() function: 

AVERAGE(number1[,number2,...])

• MEDIAN Function:

• The median is the value in a data set that falls in the middle when all the values are 

sorted in numeric order. In other words, 50 percent of the values fall below the 

median and 50 per- cent fall above it. The median is useful in data sets that have one 

or two extreme values that can throw off the mean result because the median isn’t 

affected by extremes. 

• You calculate the median using the MEDIAN() function: 

MEDIAN(number1[,number2,...])
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• MODE Function:

• The mode is the value in a data set that occurs most frequently. The mode is most 

useful when you’re dealing with data that doesn’t lend itself to being either added 

(necessary for calculating the mean) or sorted (necessary for calculating the median). 

For example, you might be tabulating the result of a poll that included a question 

about the respondent’s favorite color. The mean and median don’t make sense with 

such a question, but the mode will tell you which color was chosen the most. 

• You calculate the mode using one of the following functions: 

• MODE.MULT(number1[,number2,...]) 

• MODE.SNGL(number1[,number2,...]) 

• MODE(number1[,number2,...]) 

• The MODE.SNGL() function returns the most common value in the list, so it’s the 

function you’ll use most often in Excel 2010. 

• If your list has multiple common values, use MODE. MULT() to return those values 

as an array. 

• If you need to maintain compatibility with earlier versions of Excel, use the MODE() 

function.
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• MAX and MIN Functions:

• If you want to know the largest value in a data set, use the MAX() function: 

MAX(number1[,number2,...])

• To get the smallest value in a data set, use the MIN() function: 

MIN(number1[,number2,...])

• If you need to determine the maximum or minimum over a range or array that 

includes text values or logical values, use the MAXA or MINA functions instead. 

These functions ignore text values and treat logical values as either 1 (for TRUE) or 0 

(for FALSE). 

• LARGE and SMALL Functions:

• Instead of knowing just the largest value, you might need to know the kth largest 

value, where k is some integer. You can calculate this using Excel’s LARGE() 

function: LARGE(array, k) 

• Similarly, instead of knowing just the smallest value, you might need to know the kth

smallest value, where k is some integer. You can determine this value using the 

SMALL() function: SMALL(array, k)
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• Performing Calculations on the Top k Values :

• Sometimes you might need to sum only the top 3 values in a data set or take the 

average of the top 10 values. You can do these calculations by combining the 

LARGE() function and the appropriate arithmetic function such as SUM() in an array 

formula. Here’s the general formula: {=FUNCTION(LARGE(range, {1,2,3,...,k}))} 

• Performing Calculations on the Bottom k Values

• You can probably figure out that performing calculations on the smallest k values is 

similar. In fact, the only difference is that you substitute the SMALL() function for 

LARGE(): {=FUNCTION(SMALL(range, {1,2,3,...,k}))} 

• For example, the following array formula sums the smallest three values in the 

database: {=SUM(SMALL(D3:D22,{1,2,3}))} 
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• Descriptive statistics such as the mean, median, and mode fall under what statisticians call 

measures of central tendency, which are sometimes referred to as measures of location. 

These numbers are designed to give you some idea of what constitutes a “typical” value 

in the data set. 

• This is in contrast to the so-called measures of variation, which are sometimes referred to 

as measures of dispersion. These variations are designed to give you some idea of how the 

values in the data set vary with respect to one another. For example, a data set in which all 

the values are the same will have no variability. In contrast, a data set with wildly 

different values will have high variability. 

• Calculating the Range: 

• The simplest measure of variability is the range, also sometimes called the spread, 

which is defined as the difference between a data set’s maximum and minimum 

values. Excel doesn’t have a function that calculates the range directly. Instead, you 

first apply the MAX() and MIN() functions to the data set. Then, when you have 

these extreme values, you calculate the range by subtracting the minimum from the 

maximum. For example, =MAX(D3:D22) - MIN(D3:D22).
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• Calculating the Variance:

• When computing the variability of a set of values, one straightforward approach is to 

calculate how much each value deviates from the mean. You could then add those 

differences and divide by the number of values in the sample to get what might be 

called the average difference. However, the problem is that, by definition of the 

arithmetic mean, adding the differences, some of which are positive and some are 

negative, gives the result 0. To get around this, statisticians use the square of each 

deviation from the mean, which always results in a positive number. They sum these 

squares and divide by the number of values, and the result is the called the variance. 

• Excel calculates the variance using the VAR.P(), VAR.S(), and VAR() functions: 

• VAR.P(number1[,number2,...]) 

• VAR.S(number1[,number2,...]) 

• VAR(number1[,number2,...]) 

• You use the VAR.P() function if your data set represents the entire population such as 

in the product defects case, and you use the VAR.S() function if your data set 

represents only a sample from the entire population. If you need to maintain 

compatibility with earlier versions of Excel, use the VAR() function (which assumes 

your data represents a sample from the entire population). 
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• Calculating the Standard Deviation:

• The standard deviation is defined as the square root of the variance. You can calculate 

the standard deviation by taking the square root of the VAR() result, but Excel offers 

a more direct route: 

• STDEV.P(number1[,number2,...]) 

• STDEV.S(number1[,number2,...]) 

• STDEV(number1[,number2,...]) 

• You use the STDEV.P() function if your data set represents the entire population

• You use the STDEV.S() function if your data set represents only a sample from the 

entire population. 

• If you want to maintain compatibility with versions of Excel prior to 2010, use the 

STDEV() function (which assumes your data represents a sample from the entire 

population). 

• If you need to determine the standard deviation over a range or array that includes text 

values or logical values, use the STDEVPA() or STDEVA() functions instead. These 

functions ignore text values and treat logical values as either 1 (for TRUE) or 0 (for 

FALSE). 
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• When you load the Analysis ToolPak, the add-in inserts a new Data Analysis button in the 

Data tab on the Ribbon. Click this button to display the Data Analysis dialog box. This 

dialog box gives you access to 19 statistical tools. Here’s a summary of what each 

statistical tool can do for your data: 

• Anova: Single Factor—A simple analysis of variance, also known as a single factor 

analysis of variance. An analysis of variance (anova) tests the hypothesis that the means 

from several samples are equal. 

• Anova: Two-Factor with Replication—An extension of the single-factor anova to 

include more than one sample for each group of data. 

• Anova: Two-Factor Without Replication—A two-factor anova that doesn’t include 

more than one sampling per group. 

• Correlation—Returns the correlation coefficient: a measure of the relationship between 

two sets of data. This is also available via the following worksheet function: 

CORREL(array1, array2).

• Covariance—Returns the average of the products of deviations for each data point pair. 

Covariance is a measure of the relationship between two sets of data. This is also 

available via the following worksheet functions: COVARIANCE.P(array1, array2), 

COVARIANCE.S(array1, array2), COVAR(array1, array2).
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• Descriptive Statistics—Generates a report showing various statistics such as median, mode, and 

standard deviation for a set of data. 

• Exponential Smoothing—Returns a predicted value based on the forecast for the previous period, 

adjusted for the error in that period. 

• F-Test Two-Sample for Variances—Performs a two-sample F-test to compare two population 

variances. This tool returns the one-tailed probability that the variances in the two sets aren’t 

significantly different. This is also available via the following work- sheet functions: 

F.TEST(array1, array2), FTEST(array1, array2).

• Fourier Analysis—Performs a Fast Fourier Transform. You use Fourier Analysis to solve problems 

in linear systems and to analyze periodic data. 

• Histogram—Calculates individual and cumulative frequencies for a range of data and a set of data 

bins. The FREQUENCY() function is a simplified version of the Histogram tool. 

• Moving Average—Smoothes a data series by averaging the series values over a specified number 

of preceding periods.

• Random Number Generation—Fills a range with independent random numbers. 

• Rank and Percentile—Creates a table containing the ordinal and percentage rank of each value in 

a set. These are also available via the following worksheet functions: RANK.AVG(number, ref, 

[order]), RANK.EQ(number, ref, [order]), RANK(number, ref, [order]), PERCENTILE.EXC(array, 

k), PERCENTILE.INC(array, k), PERCENTILE(array, k).
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• Regression—Performs a linear regression analysis that fits a line through a set of values using 

the least squares method. 

• Sampling—Creates a sample from a population by treating the input range as a population. 

• t-Test: Paired Two-Sample for Means—Performs a paired two-sample student’s t-Test to 

determine whether a sample’s means are distinct. This is also available via the following 

worksheet function (set type equal to 1): T.TEST(array1, array2, tails, type) TTEST(array1, 

array2, tails, type).

• t-Test: Two-Sample Assuming Equal Variances—Performs a paired two-sample student’s t-

Test, assuming that the variances of both data sets are equal. You can also use the TTEST() 

worksheet function with the type argument set to 2. 

• t-Test: Two-Sample Assuming Unequal Variances—Performs a paired two-sample student’s 

t-Test, assuming that the variances of both data sets are unequal. You can also use the TTEST() 

worksheet function with the type argument set to 3. 

• z-Test: Two-Sample for Means—Performs a two-sample z-Test for means with known 

variances. This is also available via the following worksheet function: Z.TEST(array, x, 

[sigma]) ZTEST(array, x, [sigma]).
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• This tool automatically calculates 16 of the most common statistical functions and lays them 

all out in a table. Follow these steps to use this tool: 

• Select the range that includes the data you want to analyze including the row and column 

headings, if any. 

• Select Data, Data Analysis to display the Data Analysis dialog box. 

• Click the Descriptive Statistics option and click OK. Excel displays the Descriptive 

Statistics dialog box. 
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• Use the Output Options group to select a location for the output. For each set of data included 

in the input range, Excel creates a table that is two columns wide and up to 18 rows high. 

• Choose the statistics you want to include in the output:

• Summary Statistics—Activate this option to include statistics such as the mean, median, 

mode, and standard deviation. 

• Confidence Level for Mean—Activate this option if your data set is a sample of a larger 

population and you want Excel to calculate the confidence interval for the population 

mean. A confidence level of 95 percent means that you can be 95 percent confident that 

the population mean will fall within the confidence interval. For example, if the sample 

mean is 10 and Excel calculates a confidence interval of 1.5, you can be 95 percent sure 

that the population mean will fall between 8.5 and 12.5. 

• Kth Largest—Activate this option to add a row to the output that specifies the kth largest 

value in the sample. The default value for k is 1, which is the largest value. However, if 

you want to see any other number, enter a value for k in the text box. 

• Kth Smallest—Activate this option to include the sample’s kth smallest value in the 

output. Again, if you want k to be something other than 1, which is the smallest value, 

enter a number in the text box. 

• Click OK. Excel calculates the various statistics and displays the output table.
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• To calculate the correlation between data sets, follow these steps: 

• Select Data, Data Analysis to display the Data Analysis dialog box. 

• Click the Correlation tool and then click OK. The Correlation dialog box appears.

• Excel displays the correlation coefficients in a table, so use the Output Range box to enter a 

reference to the upper-left corner of the table. If you’re comparing two sets of data, the output 

range is three columns wide by three rows high. You also can select a different sheet or 

workbook. 

• Click OK. Excel calculates the correlation and displays the table. 
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• Use the Input Range box to select the data range 

you want to analyze, including the row or column 

headings. 

• If you included labels in your range, select the 

Labels in First Row check box. If your data is 

arranged in rows, this check box reads Labels in 

First Column. 
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• The Analysis ToolPak’s Histogram tool calculates the frequency distribution of a range of 

data. It also calculates cumulative frequencies for your data and produces a bar chart that 

shows the distribution graphically. 

• Before you use the Histogram tool, you need to decide which groupings, also known as bins, 

you want Excel to use for the output. These bins are numeric ranges, and the Histogram tool 

works by counting the number of observations that fall into each bin. You enter the bins as a 

range of numbers, where each number defines a boundary of the bin. 

• For example, the following Figure shows a worksheet with two ranges. One is a list of student 

grades. The second range is the bin range. For each number in the bin range, Histogram counts 

the number of observations that are greater than or equal to the bin value, and less than (but not 

equal to) the next higher bin value. Therefore, the six bin values in the Figure correspond to 

the following ranges: 
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Make sure that you enter 
your bin values in 
ascending order. 
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• Follow these steps to use the Histogram tool: 

• Select Data, Data Analysis to display the Data Analysis dialog box. 

• Click the Histogram option and then click OK. Excel displays the Histogram dialog box. 

• Use the Input Range and Bin Range text boxes to enter the ranges holding your data and bin 

values, respectively. 

• Use the Output Options group to select a location for the output. The output range will be one 

row taller than the bin range, and it could be up to six columns wide, depending on which of 

the following options you choose. 

• Select the other options you want to use for the frequency 

distribution: 

• Pareto—If you select this check box, Excel displays a second 

output range with the bins sorted in order of descending 

frequency. This is called a Pareto distribution. 

• Cumulative Percentage—If you activate this option, Excel 

adds a new column to the output that tracks the cumulative 

percentage for each bin. 

• Chart Output—If you activate this option, Excel 

automatically generates a chart for the frequency distribution. 

• Click OK. Excel displays the histogram data 
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• Unlike the RAND() function that generates real numbers only between 0 and 1, the Analysis 

ToolPak’s Random Number Generation tool can produce numbers in any range and can 

generate different distributions, depending on the application. 
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• Unlike the RAND() function that generates real numbers only between 0 and 1, the Analysis 

ToolPak’s Random Number Generation tool can produce numbers in any range and can 

generate different distributions, depending on the application. 
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If you’ll be using a Discrete distribution, be sure to enter the appropriate values and 

probabilities before starting the Random Number Generation tool. 
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• Complete the steps outlined in the following procedure to use the Random Number Generation 

tool. 

• Select Data, Data Analysis to display the Data Analysis dialog box. 

• Click the Random Number Generation option and then click OK. The Random Number 

Generation dialog box appears. 

• If you want to generate more than one set of random numbers, enter the number of sets (or 

variables) you need in the Number of Variables box. Excel enters each set in a separate 

column. If you leave this box blank, Excel uses the number of columns in the Output Range. 

• Use the Number of Random Numbers text box to enter how many random numbers you need. 

Excel enters each number in a separate row. If you leave this box blank, Excel fills the Output 

Range. 

• Use the Distribution drop-down list to click the distribution you want to use. 

• In the Parameters group, enter the parameters for the distribution you selected. 

• The Random Seed number is the value Excel uses to generate the random numbers.

If you leave this box blank, Excel generates a different set each time. If you enter a value 

(which must be an integer between 1 and 32,767), you can reuse the value later to reproduce 

the same set of numbers. 

• Use the Output Options group to select a location for the output. 

• Click OK. Excel calculates the random numbers and displays them in the worksheet. 
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• If you need to rank data, use the Analysis ToolPak’s Rank and Percentile tool. This command 

not only ranks your data from first to last, but it also calculates the percentile—the percentage 

of items in the sample that are at the same level or a lower level than a given value. Follow the 

steps in the following procedure to use the Rank and Percentile tool: 

• Select Data, Data Analysis to display the Data Analysis dialog box. 

• Click the Rank and Percentile option and then click OK. Excel displays the Rank and 

Percentile dialog box.
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• Use the Input Range text box to enter a reference for the data you want to rank. 

• Click the appropriate Grouped By option (Columns or Rows). 

• If you included row or column labels in your selection, select the Labels in First Row check 

box. If your data is in rows, the check box will read Labels in First Column. 

• Use the Output options group to select a location for the output. For each sample, Excel 

displays a table that is four columns wide and the same height as the number of values in the 

sample. 

• Click OK. Excel calculates the results and displays them in a table.
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• Click the Data tab on the Ribbon and then click Data Analysis in the Analysis group. In 

versions prior to Excel 2007, choose Tools, Data Analysis. 

• Select Regression from the Analysis Tools list box. 

• Click OK. The dialog box appears. 

• With the flashing cursor in the Input Y Range 

edit box, select cells C3:C20 or type the address 

directly in the edit box. 

• Click in the Input X Range edit box, 

and select cells A3:B20 or type the address.

• Make sure that the Confidence Level 

edit box contains 95 and that 

the New Worksheet Ply option button is selected. 
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• When you’re trying to determine whether the means in several sets of data that depend on 

one factor are significantly different, one-way analysis of variance, or ANOVA, is the 

correct tool to use. In analyzing the data, you can choose between two hypotheses: 

• Null hypothesis, which indicates that the means of all groups are identical. 

• Alternative hypothesis, which indicates that there is a statistically significant 

difference between the groups’ means. 

• To test these hypotheses in Microsoft Excel, you can use the Anova: Single Factor 

option in the Data Analysis dialog box. 

• If the p-value computed by Excel is small (usually less than or equal to 0.15), you 

can conclude that the alternative hypothesis is true (the means are significantly 

different). 

• If the p-value is greater than 0.15, the null hypothesis is true (the populations have 

identical means). 
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• Example:

• The owner of a company, which publishes computer books, wants to know whether the 

position of our books in the computer book section of bookstores influences sales. More 

specifically, does it really matter whether the books are placed in the front, back, or 

middle of the computer book section? Weekly sales (in hundreds) were monitored at 12 

different stores. At five stores, the books were placed in the front; at four stores, in the 

back; and at three stores, in the middle. Resulting sales are contained in the following 

worksheet:

© Stella Moysiadou - stm@aueb.gr



ANALYSIS OF VARIANCE: ONE-WAY ANOVA 

134

Microsoft Office 
Shipping, Finance & 
Management Skills

• You can assume that the 12 stores have similar sales patterns and are approximately the same size. 

This assumption allows you to use one-way ANOVA because you believe that at most one factor 

(the position of the display in the computer book section) is affecting sales. (If the stores were 

different sizes, you would need to analyze the data with two-way ANOVA).

• To analyze the data, on the Data tab, click Data Analysis, and then select Anova: Single Factor. 
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• The data for the input range, 

including labels, is in cells B3:D8. 

• Select the Labels In First Row option 

because the first row of the input 

range contains labels. 

• Select the Columns option because 

the data is organized in columns. 

• Select C12 as the upper-left cell of 

the output range. 

• The selected alpha value is not 

important. You can use the default 

value. 

• After clicking OK, you obtain the 

results 
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• In cells F16:F18, you see 

average sales depending on the 

location of the display. 

• When the display is at the front 

of the computer book section, 

average sales are 900. 

• When the display is at the back 

of the section, sales average 

1,400. 

• When the display is in the 

middle, sales average 1,100. 

• Because the p-value of 0.003 

(in cell H23) is less than 0.15, 

you can conclude that these 

means are significantly 

different. 
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• Question:

• If I am determining whether populations have significantly different means, why is 

the technique called analysis of variance? 

• Suppose that the data in our book sales study is the data 

shown in the following worksheet:

• If you run a one-way ANOVA on this data, you obtain the following results:
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• Note that the mean sales for each part of the store are exactly as before, yet the p-value 

of .66 indicates that you should accept the null hypothesis and conclude that the 

position of the display in the computer book section doesn’t affect sales. 

• The reason for this strange result is that in the second data set, you have much more 

variation in sales when the display is at each position in the computer book section. In 

the first data set, for example, the variation in sales when the display is at the front is 

between 700 and 1,100, whereas in the second data set, the variation in sales is between 

200 and 2,000. 

• The variation of sales within each store position is measured by the sum of the squares 

of data within a group. This measure is shown in cell D24 in the first data set and in cell 

F24 in the second. In the first data set, the sum of squares of data within groups is only 

22, whereas in the second data set, the sum of squares within groups is 574! This large 

variation within the data points at each store position masks the variation between the 

groups (store positions) themselves and makes it impossible to conclude for the second 

data set that the difference between sales in different store positions is significant. 
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• Problems such as “What product mix will e profit?” or “What transportation routes will 

minimize shipping costs while maximizing demand?” traditionally have been solved by 

numerical methods such as linear programming and nonlinear programming. An entire 

mathematical field known as operations research has been developed to handle such 

problems, which are found in all kinds of disciplines. The drawback to linear and 

nonlinear programming is that solving even the simplest problem by hand is a 

complicated, arcane, and time-consuming business. In other words, it’s a perfect job to 

slough off on a computer. 

• This is where Solver comes in. Solver incorporates many of the algorithms from 

operations research, but it keeps the sordid details in the background. All you do is fill 

out a dialog box or two, and Solver does the rest. 
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• Solver is an add-in, a program that adds customized commands and features to Microsoft 

Office programs such as Excel. Because Solver is an added feature of Excel, it might not be 

activated in your version of Excel. Before running Solver, you might have to activate it: 

• Check whether Solver appears in the Analysis group on the Data tab. If it does, Solver 

is already active. If not, continue with the rest of these steps. 

• Click the File tab, and then click the Options button in the navigation bar. 

• Click Add-Ins in the left pane, click the arrow next to the Manage box, and then click 

Excel Add-ins. 

• Click the Go button to open the Add-Ins dialog box. 

• Click the Solver Add-in check box, and then click the OK button. 

• Follow the remaining prompts to install Solver, if it is not already installed. 

• You’ll check whether Solver is already active on your version of Excel by checking whether 

the Solver button appears on the Data tab. 
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• To use Solver, you must specify three items, or Solver parameters: the objective cell, the 

variable (or changing) cells, and the constraints on the problem. 

• The objective cell is a cell that you want to maximize, minimize, or change to a specific 

value. For example, the company’s net income is your objective cell, whose value you 

want to maximize. 

• A variable cell is a cell that Excel changes to produce the desired result in the objective 

cell. For example, the adjustable cell is the sales price of each product item. 

• Finally, a constraint is a limit that is placed on the problem’s solution. For example, it 

may be a physical limit on the number of items the company can produce in a given 

year (no matter how profitable it would be to produce extra items), so this would be a 

constraint that Solver would have to include when finding the maximum net income. 

• To set the Solver parameters:

• In the Analysis group on the Data tab, click the Solver button.

• In the Set Objective box, specify the cell whose value you want to set to match a 

specific objective.

• Click the Max, Min, or Value Of option buttons to maximize, minimize, or set the 

objective cell to a specified value, respectively.

• In the By Changing Variable Cells input box, specify the changing cells. 
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• Next, you’ll add constraints, or limits, for the solution. Constraints are important because 

they confine the solution within a reasonable set of limits that you define. 

• Solver supports six possible constraints:

• The <=, >=, and = constraints are used when you want to set a cell’s value to always be 

less than or equal to, greater than or equal to, or equal to a specified value. 

• You can also use an integer or int constraint, which forces a cell value to always be a 

whole number, and you can apply a binary or bin constraint that forces a cell value to 

always be either 0 or 1. 

• Finally, you can apply the dif or AllDifferent constraint, which forces all values within 

the selected cell range to have different

integer values. 

• To Set Constraints on the Solver Solution:

• In the Solver Parameters dialog box, click the Add button. 

• Enter the cell reference of the cell or cells containing the constraint. 

• Specify the nature of the constraint (<=, =, >=, int, bin, or dif). 

• Enter the constraint value in the Constraint box. 

• Click the OK button to add the constraint and return to the Solver Parameters dialog 

box. 

• Repeat for each constraint you want to add. 
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• Solver arrives at optimal solutions through an iterative procedure, in which Solver starts with 

an initial solution (usually the current values from the worksheet) and uses that as a basis to 

calculate a new set of values. If those values improve the value of the objective cell, the new 

values are used as a basis to generate the next set of values. If they don’t improve the solution, 

Solver tries a different set of values. Each step, or iteration, in this process improves the solution 

until Solver reaches the point where the new solutions are not significantly better than the 

solution from the previous step. At that point, Solver will stop and indicate that it has found an 

answer. 

• What does “significantly better” mean? The default convergence value is 0.001, which means 

that if the change in the value of the objective cell between the new solution and the previous 

solution is less than or equal to 0.001, Solver will consider that it has converged to the solution 

and stop the iterative process. Solver will also stop if it is not making progress toward a solution. 

• The default length of time that Solver will spend on the iterative process is 100 seconds or 100 

total iterations (whichever comes first). If 100 seconds or 100 iterations have passed and Solver 

has not found a solution, it will report this fact. At that point, you can have Solver continue the 

iterative process or stop the process without finding a solution. If Solver is taking too long to find 

a solution, you can halt the program at any time by pressing the Esc key. 

• If you want to see the iterative process in action, click the Show Iteration Results check box in 

the Options dialog box, and Excel will pause after each iteration and show the intermediate 
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• How do you evaluate the solution that Solver produced? 

• Solver can create three different reports—an answer report, a sensitivity report, and a limits 

report. 

• The answer report may be the most useful of the three because it summarizes the 

results of a successful solution by displaying information about the objective cell, 

changing cells, and constraints. This report includes the original and final values for the 

objective and changing cells, as well as the constraint formulas. 

• The sensitivity report and limits report are often used in science and engineering 

environments when the user wants to investigate the mathematical aspects of the Solver 

solution. 

• These reports allow you to quantify the reliability of the solution. 

• You cannot use these reports when the problem contains integer constraints. 

• To create an answer report: 

• In the Solver Results dialog box, click Answer in the Reports box, and then verify that 

the Keep Solver Solution option button is selected. 

• Click the OK button to accept the solution and generate the answer report in a separate 

sheet. 
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• The answer report is divided into four sections. 

• The first section includes titles that indicate that this is an Excel answer report created 

from the specific worksheet in the specific workbook on the day and at the time 

specified. 

• The second section displays information about the objective cell, its location, the cell 

label, and the cell’s original value and final values. 

• The third section displays information about the changing cells, which the report calls 

variable cells. This section of the report shows the location, column and row label, 

original value, and final value of each cell. 

• The fourth section of the report displays information about the constraints. In addition 

to the location, name, and value of each constraint, this section shows the constraint 

formulas. The second column from the right shows the status of each constraint. The 

status of both of the constraints is listed as “Not Binding.” A not binding constraint is a 

constraint that was not a limiting factor in arriving at the solution. The other possibility 

is a binding constraint, which Solver was forced to include as part of the final solution. 

For example, if the maximum net income occurred when the number of units produced 

was equal to 15,000 (one of the constraints in your Solver model), this would be a 

binding constraint. 
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• The last column on the right shows the slack for each constraint. The slack is the 

difference between the value in the cell and the value at the limit of the constraint. The 

slack for the first constraint is 14,093.44998 because that is the difference between

the final cell value, 20,907, and the first constraining value, 35,000. The slack is useful 

because it indicates how close the optimal price value is to a constraining point. In this 

case, the slack for both constraints is large, so the constraints do not have any impact on 

the solution. Binding constraints always show a slack of 0. 

© Stella Moysiadou - stm@aueb.gr



SAVING AND LOADING SOLVER MODELS

152

Microsoft Office 
Shipping, Finance & 
Management Skills

• Rather than reentering the Solver param- eters for each model, you can save the parameters 

in cells in the worksheet. Then, if you want to rerun a particular problem, you can reload the 

parameters from the worksheet cells without having to reformulate the problem. 

• To save a Solver model: 

• Open the Solver dialog box. 

• Click the Load/Save button, and then select an empty range containing the number of

cells specified in the dialog box. 

• Click the Save button.

• To load a Solver model:

• Open the Solver dialog box. 

• Click the Load/Save button, and then select the cell range containing the saved model.

• Click the Load button. 
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• When negotiating a loan, the first concern that comes up is almost always the size of the 

payment you’ll need to make each period. This is just basic cash-flow management because 

the monthly (or whatever) payment must fit within your budget. 

• To return the periodic payment for a loan, use the PMT() function: 

• PMT(rate, nper, pv[, fv][, type]) where

• rate is the fixed rate of interest over the term of the loan

• nper is the number of payments over the term of the loan

• pv is the loan principal

• fv is the future value of the loan. 

• type is the type of payment - Use 0 (the default) for end-of-period payments; use 1 

for beginning-of-period payments. 

• For example, the following formula returns the monthly payment of a $10,000 loan with an 

annual interest rate of 6% (0.5% per month) over 5 years (60 months): =PMT(0.005, 60, 

10000) 
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• Many loans are set up so that the payments take care of only a portion of the principal, with 

the remainder due as an end-of-loan balloon payment. This balloon payment is the future 

value of the loan, so you need to factor it into the PMT() function as the fv argument. 

• You might think that the pv argument should be the partial principal—that is, the original 

loan principal minus the balloon amount. This seems right because the loan term is designed 

to pay off the partial principal. That’s not the case, however. In a balloon loan, you also 

pay interest on the balloon part of the principal. That is, each payment in a balloon loan 

has three components: 

• A paydown of the partial principal

• Interest on the partial principal

• Interest on the balloon portion of the principal 

• Therefore, the PMT() function’s pv argument must be the entire principal, with the balloon 

portion as the (negative) fv argument. 

• For example, suppose that the loan from the previous section has a $3,000 balloon payment. 

The monthly payment is calculated as follows:  =PMT(0.06 / 12, 5 * 12, 10000, -3000) 
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• To calculate the principal and interest components of a loan payment, use the PPMT() and 

IPMT() functions, respectively: 

• PPMT(rate, per, nper, pv[, fv][, type]) 

• IPMT(rate, per, nper, pv[, fv][, type]) where

• Rate is the fixed rate of interest over the term of the loan.

• Per is the number of the payment period (where the first payment is 1 and the last 

payment is the same as nper). 

• nper is the number of payments over the term of the loan. 

• pv is the loan principal. 

• fv is the future value of the loan (the default is 0). 

• type is the type of payment - Use 0 (the default) for end-of-period payments; use 1 

for beginning-of-period payments.

• The following Figure shows a worksheet that applies these functions to the loan. The data 

table shows the principal (column E) and interest (column F) components of the loan for the 

first 10 periods and for the final period. Note that with each period, the principal portion 

increases and the interest portion decreases. However, the total remains the same (as con-

firmed by the Total column), which is as it should be because the payment remains constant 

through the life of the loan. 
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• Knowing how much principal and interest you pay each period is useful, but it’s 

usually more often handy to know how much principal or interest you’ve paid in total 

up to a given period. For example, if you sign up for a mortgage with a five-year term, 

how much principal will you have paid off by the end of the term? Similarly, a 

business might need to know the total interest payments a loan requires in the first 

year so that it can factor the result into its expense budgeting. 

• To calculate the cumulative principal and interest of a loan payment, use the following 

functions: 

• CUMPRINC(rate, nper, pv, start_period, end_period, type) 

• CUMIPMT(rate, nper, pv, start_period, end_period, type) where

• rate is the fixed rate of interest over the term of the loan. 

• nper is the number of payments over the term of the loan. 

• Pv is the loan principal.

• start_period is the first period to include in the calculation. 

• end_period is the last period to include in the calculation. 

• type is the type of payment - Use 0 for end-of-period payments; use 1 for 

beginning- of-period payments. 
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• In both CUMPRINC() and CUMIPMT(), all of the arguments are required. If you omit 

the type argument (which is optional in most other financial functions), Excel returns the 

#N/A error. 

• The main difference between CUMPRINC() and CUMIPMT() and PPMT() and IPMT() 

is the start_period and end_period arguments. For example, to find the cumulative 

principal or interest in the first year of a loan, you set start_period to 1 and end_period to 

12; for the second year, you set start_period to 13 and end_period to 24. 

• Τhe CUMIPMT() function gives you an easier way to calculate the total interest costs 

for a loan. Just set the start_period to 1 and the end_period to the number of periods (the 

value of nper). 

• Although the CUMPRINC() function works as advertised if the loan includes a balloon 

payment, the CUMIPMT() function does not. 
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• In some loan scenarios, you need to borrow a certain amount at the current interest rates, 

but you can spend only so much on each payment. If the other loan factors are fixed, the 

only way to adjust the payment is to adjust the term of the loan: A longer term means 

smaller payments; a shorter term means larger payments. 

• Excel offers a direct solution in the form of the NPER() function, which returns the 

number of periods of a loan: 

• NPER(rate, pmt, pv[, fv][, type]) where 

• rate is the fixed rate of interest over the term of the loan. 

• pmt is the periodic payment.

• pv is the loan principal.

• fv is the future value of the loan (the default is 0). 

• type is the type of payment - Use 0 (the default) for end-of-period payments; use 

1 for beginning-of-period payments. 

• For example, suppose that you want to borrow $10,000 at 6 percent interest with no 

balloon payment, and the most you can spend is $750 per month. What term should you 

get? Use NPER() to calculate the answer: 13.8 months. 
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• Here are some things to note about this model: 

• The interest rate is an annual value, so the NPER() function’s rate argument divides 

the rate by 12. 

• The payment is negative because it’s money that you pay to the lender. 

• The cumulative principal values are calculated using the SUM() function. You can’t 

use the CUMPRINC() function in this case because CUMPRINC() truncates the nper

argument to an integer value. 
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• A slightly less common loan scenario arises when you know the loan term, payment, and 

principal, and you need to know what interest rate will satisfy these parameters. This is 

useful in a number of circumstances: 

• You might decide to wait until interest rates fall to the value you want.

• You might regard the calculated interest rate as a maximum rate that you can pay, 

knowing that anything less will enable you to reduce either the payment or the term. 

• You could use the calculated interest rate as a negotiating tool with your lender by 

asking for that rate and walking away from the deal if you don’t get it. 

• To determine the interest rate given the other loan factors, use the RATE() functions: 

RATE(nper, pmt, pv[, fv][, type][, guess]) where

• nper is the number of payments over the term of the loan. 

• Pmt is the periodic payment.

• Pv is the loan principal.

• Fv is the future value of the loan (the default is 0). 

• Type is the type of payment - use 0 (the default) for end-of-period payments; use 

1 for beginning-of-period payments. 

• Guess is a percentage value that Excel uses as a starting point for calculating the 

interest rate (the default is 10 percent). 
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• For example, suppose that you want to borrow $10,000 over 5 years with no balloon pay-

ment and a monthly payout of $200. What rate will satisfy these criteria? 

• The worksheet in the following Figure uses RATE() to derive the result of 7.4 percent. 

• Here are some notes about this model: 

• The term is in years, so the RATE() function’s 

nper argument multiplies the term by 12. 

• The payment is already a monthly number, 

so no adjustment is necessary for the 

pmt attribute. 

• The payment is negative because 

it’s money that you pay to the lender. 

• The result of the RATE() function 

is multiplied by 12 to get the annual interest rate. 
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• If you know the current interest rate that your bank is offering for loans, when you want 

to have the loan paid off, and how much you can afford each month for the payments, 

you might then wonder what is the maximum amount you can borrow under those 

terms? To figure this out, you need to solve for the principal—that is, present value. You 

do that in Excel by using the PV() function: 

PV(rate, nper, pmt[, fv][, type]) where

• rate is the fixed rate of interest over the term of the loan. 

• nper is the number of payments over the term of the loan. 

• pmt is the periodic payment.

• fv is the future value of the loan (the default is 0). 

• type is the type of payment - Use 0 (the default) for end-of-period payments; use 

1 for beginning-of-period payments. 

• For example, suppose that the current loan rate is 6 percent, you want the loan paid off in 

5 years, and you can afford payments of $500 per month. The following Figure shows a 

worksheet that calculates the maximum amount that you can borrow—$25,862.78—using 

the following formula: 

=PV(B2 / 12, B3 * 12, B4, B5, B6) 

© Stella Moysiadou - stm@aueb.gr



CALCULATING HOW MUCH YOU CAN BORROW

166

Microsoft Office 
Shipping, Finance & 
Management Skills

© Stella Moysiadou - stm@aueb.gr



CONVERTING BETWEEN THE NOMINAL RATE

AND THE EFFECTIVE RATE

167

Microsoft Office 
Shipping, Finance & 
Management Skills

• The two ways that most interest rates are most often quoted: 

• The nominal rate—This is the annual rate before compounding (the 10 percent rate, 

in the example). The nominal rate is always quoted along with the compounding 

frequency—for example, 10 percent compounded semiannually. 

• The effective rate—This is the annual rate that an investment actually earns in the 

year after the compounding is applied (the 10.25 percent, in the example). 

• To convert a nominal annual interest rate to the effective annual rate, use the EFFECT() 

function: 

• EFFECT(nominal_rate, npery) where 

• nominal_rate is the nominal annual interest rate 

• npery is the number of compounding periods in the year.

• For example, the following formula returns the effective annual interest rate for an 

investment with a nominal annual rate of 10 percent that compounds semiannually: 

=EFFECT(0.1, 2)
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• Just as the payment is usually the most important value for a loan calculation, the future 

value is usually the most important value for an investment calculation. After all, the pur-

pose of an investment is to place a sum of money (the present value) in some instrument 

for a time, after which you end up with some new (and hopefully greater) amount: the 

future value. 

• To calculate the future value of an investment, Excel offers the FV() function: 

FV(rate, nper[, pmt][, pv][, type]) 

• rate is the fixed rate of interest over the term of the investment. 

• nper is the number of periods in the term of the investment. 

• pmt is the amount deposited in the investment each period (The default is 0.) 

• pv is the initial deposit (The default is 0.). 

• type is the type of deposit - Use 0 (the default) for end-of-period deposits; use 1 for 

beginning- of-period deposits. 

• Because both the amount deposited per period (the pmt argument) and the initial 

deposit (the pv argument) are sums that you pay out, these must be entered as 

negative values in the FV() function. 
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• Excel’s FV() function doesn’t work with continuous compounding. Instead, you need to 

use a worksheet formula that takes the following general form (where e is the 

mathematical consant e): 

=pv * e ^ (rate * nper)

• For example, the follow formula calculates the future value of $10,000 invested at 5 

percent over 10 years compounded continuously (and returns a value of $16,487.21): 

=10000 * EXP(0.05 * 10) 
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• For investments that offer a variable rate over the term, or when the rate fluctuates over the 

term, Excel offers the FVSCHEDULE() function, which returns the future value of some 

initial amount, given a schedule of interest rates: 

FVSCHEDULE(principal, schedule) where

• principal is the initial investment 

• schedule is a range or array containing the interest rates.

• For example, the following formula returns the future value of an initial $10,000 deposit that 

makes 5 percent, 6 percent, and 7 percent over 3 years:

=FVSCHEDULE(10000, {0.5, 0.6, 0.7}) 
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• Excel tables provide many advantages to structured ranges of data. When you create an 

Excel table, you can perform the same operations as you can for a structured range of 

data. In addition, you can use Excel tables to do the following to be more productive and 

reduce the chance of error: 

• Format the Excel table quickly using a table style. 

• Add new rows and columns to the Excel table that automatically expand the range. 

• Add a Total row to calculate the summary function you select, such as SUM, 

AVERAGE, COUNT, MIN, and MAX. 

• Enter a formula in one table cell that is automatically copied to all other cells in that

table column. 

• Create formulas that reference cells in a table by using table and column names

instead of cell addresses.

• These Excel table features let you focus on analyzing and understanding the data,

leaving the more time-consuming tasks for the program to perform. 
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• Verify that the active cell is a cell in the range of the data you want to insert in the table.

• Click the Insert tab on the Ribbon. The Ribbon displays the Insert options. 

• In the Tables group, click the Table button. The Create Table dialog box opens. The 

range of data for the table is entered in the dialog box. 

• Click the OK button. The dialog box closes, and the range of data is converted to an 

Excel table. Filter arrows appear in the header row, the table is formatted with a 

predefined table style, and the Table Tools Design contextual tab appears on the Ribbon. 

• Scroll the table down. The text of the header row replaces the standard lettered column 

headings (A, B, C, and so on) as you scroll so that you don’t need to freeze panes to keep 

the header row visible. 
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• In the Properties group on the Design tab, select the default table name in the Table 

Name box.

• Type the new name, and then press the Enter key. The Excel table is renamed.
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• The simplest and most convenient way to add a record to an Excel table is to enter the 

data in the first blank row below the last record. You can then sort the data to arrange 

the table in the order you want. If you want the record in a specific location, you can also 

insert a row within the table for the new record. 

• Click in the row below the last row of the Excel table.

• Type the values for the new record, pressing the Tab key to move from field to field. 

• Press the Tab key to create another new record. 

or 

• Press the Enter key if this is the last record. 
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• Press the Ctrl+Home keys to move to the top of the worksheet, and then click the first 

cell of the table to make it active.

• In the Editing group on the Home tab, click the Find & Select button, and then click 

Find. The Find and Replace dialog box opens. 

• Type in the Find what box the word you need to find, and then click the Find Next button.

The cell which contains the word you typed is selected. This is the record you want. If it 

is not, you can click the Find Next button again to display the next record that meets the 

search criteria. 

• Click the Close button. The Find and Replace dialog box closes. 

• In the Cells group on the Home tab, click the Delete button arrow, and then click Delete 

Table Rows. The record is deleted from the table.
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• Click any cell in the column. You do not need to select the entire table. Excel determines 

the table’s range when you click any cell in the table. 

• Click the Data tab on the Ribbon. The Data options appear on the Ribbon. 

• In the Sort & Filter group, click the Sort A to Z button . The data is sorted in ascending 

order .
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• Click any cell in a table or range. 

• In the Sort & Filter group on the Data tab, click the Sort button. 

• If necessary, click the Add Level button to insert the Sort by row. 

• Click the Sort by arrow, select the column heading for the primary sort field, click the 

Sort On arrow to select the type of data, and then click the Order arrow to select the sort 

order. 

• To sort by a second column, click the Add Level button. Click the Then by arrow, select 

the column heading for the secondary sort field, click the Sort On arrow to select the type 

of data, and then click the Order arrow to select the sort order. 

• To sort by additional columns, click the Add Level button and select appropriate Then by, 

Sort On, and Order values. 

• Click the OK button. 
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• Text is sorted in ascending or descending alphabetical order unless you specify a different 

order using a custom list. A custom list indicates the sequence in which you want data 

ordered. 

• Excel provides four predefined custom sort lists. Two days-of-the-week custom lists (Sun, 

Mon, Tues, ... and Sunday, Monday, Tuesday, ...) and two months-of- the-year custom 

lists (Jan, Feb, Mar, Apr, ... and January, February, March, April, ...). If a column consists 

of day or month labels, you can sort them in their correct chronological order using one 

of these predefined custom lists. 

• You can also create custom lists to sort records in a sequence you define. For example, 

you may want to create a custom list to arrange art objects based on their condition, with 

the top quality condition appearing first, as follows: Excellent, Good, Fair, Poor. 

• In the Sort & Filter group on the Data tab, click the Sort button. 

• Click the Order arrow, and then click Custom List. 

• In the List entries box, type each entry for the custom list, pressing the Enter key 

after each entry. 

• Click the Add button. 

• Click the OK button. 
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• When you create an Excel table, a filter arrow appears in each column header. You

click a filter arrow to open the AutoFilter menu for that field. You can use options on

the AutoFilter menu to create three types of filters. You can filter a column of data by its 

cell colors or font colors; by a specific text, number, or date filter, although the choices 

depend on the type of data in the column; or by selecting the exact values by which you 

want to filter in the column. After you filter a column, the Clear Filter command 

becomes available so you can remove the filter and redisplay all the records.

• You can display or hide filter arrows for an Excel table or a range of data by using the 

Filter button in the Sort & Filter group on the Data tab. 

• The AutoFilter menu also includes options to Sort by Color and Filter by Color. These 

options enable you to filter and sort data using color, one of many cell attributes. Suppose 

that you use specific cell background colors for certain records in a table. You can then 

click the Sort by Color option in the AutoFilter menu to display a list of available colors 

by which to sort, and then click the specific color so that all the records formatted with it 

will appear together.
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• You can use different text filters to display the records you want. If you know only part of 

a text value or if you want to match a certain pattern, you can use the Begins With, Ends 

With, and Contains operators to filter a text field to match the pattern you specify. 

• The following examples are based on a student directory table that includes First Name, 

Last Name, Address, City, State, and Zip fields: 

• To find a student named Smith, Smithe, or Smythe, create a text filter using the 

Begins With operator. In this example, use “Begins With Sm” to display all records 

that have “Sm” at the beginning of the text value. 

• To Find anyone whose Last Name ends in “son” (such as Robertson, Anderson, 

Dawson, Gibson, and so forth), create a text filter using the Ends With operator. In 

this example, use “Ends With son” to display all records that have “son” as the last 

characters in the text value. 

• To find anyone whose street address includes “Central” (such as 101 Central Ave., 

1024 Central Road, or 457 Avenue De Central), create a text filter using the Contains 

operator. In this example, use “Contains Central” to display all records that have 

“Central” anywhere in the text value. 

• When you create a text filter, think about the results you want. Then, consider what text 

filter you can use to best achieve those results. 
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• If you need to further restrict the records that appear in a filtered table, you can filter

by one or more of the other columns. Each additional filter is applied to the currently 

filtered data and further reduces the records that are displayed. 

• When you want to redisplay all of the data in a filtered table, you need to clear (or 

remove) the filters. When you clear a filter from a column, any other filters are still 

applied. To Clear a filter from a table, click the respective filter arrow, and then click 

Clear Filter From “x”.
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• Filter items enable you to filter a range of data or an Excel table based on exact values in

a column. However, many times you need broader criteria. 

• Criteria filters enable you to specify various conditions in addition to those that are based 

on an “equals” criterion. For example, you might want to find all art objects with an appraised 

value greater than $20,000 or those that were acquired after 7/1/2011. You use criteria filters 

to create these conditions. 

• The type of criteria filters available change depending on whether the data in a column 

contains text, numbers, or dates. 

• To create a number filter: 

• Click the filter arrow in the respective column, and then point to Number Filters. A menu 

opens, displaying the comparison operators available for columns of numbers. 

• Click, for example, Greater Than. The Custom AutoFilter dialog box opens. The upper-

left box lists is greater than, the comparison operator you want to use to filter the column. 

• You enter the value you want to use for the filter criteria in the upper-right box, which, 

let’s say, is $20,000. Type 20000 in the upper-right box. 

• You use the lower set of boxes if you want the filter to meet a second condition. 

• You click the And option button to display rows that meet both criteria. 

• You click the Or option button to display rows that meet either of the two criteria. 
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• You can split the worksheet window into two or four separate panes. This allows you to 

easily view data from several areas of the worksheet at the same time. Each pane has its own 

scroll bars so you can navigate easily within one pane or display different parts of the 

worksheet. You can move between panes using the mouse. 

• Press the Ctrl+Home keys to jump to the top of the table, and then click the cell which 

you want to be the first cell included in the second separate pane. 

• Click the View tab on the Ribbon, and then click the Split button in the Window group. 

The worksheet window splits into two panes. Each pane has its own set of scroll bars.

• To remove the split panes from the worksheet window: 

• Click the View tab on the Ribbon. 

• In the Window group, click the Split button. The split bar is removed, and the worksheet 

is again a single window. 

• You can also double-click the split bar to remove the panes. 
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• PivotTables are a great way to summarize data from selected fields of an Excel table or 

range, which can help you back up or support specific points in written documents. The 

PivotTable omits all the detailed data, enabling readers to focus on the bigger picture. This 

makes it easier for readers to understand the results and gain insights about the topic. 

• You can show summaries in written documents based on function results in PivotTables. The 

SUM function is probably the most frequently used function. For example, you might show 

the total sales for a region. However, you can use many other functions to summarize the data, 

including COUNT, AVERAGE, MIN, MAX, PRODUCT, COUNT NUMBERS, STDEV, 

STDEVP, VAR, and VARP. For example, you might show the average sales for a region, the 

minimum price of a product, or a count of the number of products sold. 

• When you write a report, you want supporting data to be presented in the way that best 

communicates your points. With PivotTables, you display the values in different views. For 

example, to compare one item to another item in the PivotTable, you can show the values as a 

percentage of a total. You can display the data in each row as a percentage of the total for the 

row. You can also display the data in each column as a percentage of the total for the column 

or display the data as a percentage of the grand total of all the data in the PivotTable. Viewing 

data as a percentage of the total is useful for analyses such as comparing product sales with 

total sales within a region or comparing expense categories to total expenses for the year 
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• As you can see, PivotTables provide great flexibility in how you analyze and display data. 

This makes it easier to present data in a way that highlights and supports the points you are 

communicating, making your written documents much more effective. 

• To create a PivotTable report, you need to specify which fields in the data source to 

summarize. 

• In PivotTable terminology, the fields that contain summary data are known as values fields. 

• Category fields are the fields that group the values in a PivotTable, such as condition, 

location, and year acquired. Category fields appear in PivotTables as row labels, column 

labels, and report filters, which allows you to focus on a subset of the PivotTable by 

displaying one, several, or all items. 

• You can easily rearrange, hide, and display different category fields in the PivotTable to 

provide alternative views of the data. This ability to “pivot” the table—for example, change 

row headings to column positions and vice versa—gives the PivotTable its

name and makes it a powerful analytical tool. 
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• To create a PivotTable, you will use the PivotTable dialog box to select the data to analyze 

and the location of the PivotTable report. 

• When you create a PivotTable, you need to specify where to find the data for the PivotTable. 

The data can be in an Excel table or range in the current workbook or an external data source 

such as an Access database file. 

• You also specify whether to place the PivotTable in a new or an existing worksheet. If you 

place the PivotTable in an existing worksheet, you must also specify the cell in which you 

want the upper-left corner of the PivotTable to appear. 

• Click in the Excel table or select the range of data for the PivotTable. 

• In the Tables group on the Insert tab, click the PivotTable button. 

• Click the Select a table or range option button and verify the reference in the Table/ 

Range box. 

• Click the New Worksheet option button or click the Existing Worksheet option button 

and specify a cell. Click the OK button. 

• Click the check boxes for the fields you want to add to the PivotTable (or drag fields to 

the appropriate box in the layout section). 

• If needed, drag fields to different boxes in the layout section. 

• You can also create a PivotTable by clicking the Summarize with PivotTable button in the 

Tools group on the Table Tools Design tab. 
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• The PivotTable Field List is divided into two sections. 

• The upper field list section displays the names of each field in the table. You check a field 

check box to add that field to the PivotTable. 

• The lower layout section includes boxes for the four areas in which you can place fields: 

Report Filter, Row Labels, Column Labels, and Values. 

• Initially, selected fields with numeric data are placed in the Values area and the SUM function 

is used to summarize the PivotTable. Fields with nonnumeric data are placed in the Row 

Labels area. You can change these default placements of fields. 
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• By default, the PivotTable report uses the SUM function for numbers in the Values area and 

the COUNT function for text and other nonnumeric values. 

• If you want a different summary function, such as AVERAGE, MAX, or MIN, click the 

appropriate button in the Values box (in this case, the button is called “Sum of Appraised 

Value”) in the PivotTable Field List, and then click Value Field Settings. The Value Field 

Settings dialog box opens. You can then select the type of calculation you want from the list 

of available functions, and then click the OK button. 
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• As with worksheet cells and Excel tables, you can quickly format a PivotTable report using 

a preset style. You can choose from a gallery of PivotTable styles similar to the gallery of 

Table styles. You can point to any style in the gallery to see a Live Preview of the PivotTable 

with that style applied. You also can modify the appearance of PivotTables by adding or 

removing banded rows, banded columns, row headers, and column headers. 

• You can add, remove, and rearrange fields to change the PivotTable’s layout. Recall that 

the benefit of a PivotTable is that it summarizes large amounts of data into a readable format. 

After you create a PivotTable, you can view the same data in different ways. The PivotTable 

Field List enables you to change, or pivot, the view of the data in the PivotTable by dragging 

the field buttons to different areas in the layout section. 

• The Compact report layout places all fields from the row area in a single column and 

indents the items from each field below the outer fields. This is the default layout for 

PivotTable reports. You can choose two other layouts. In the Outline report layout, each 

field in the row area takes a column in the PivotTable. By default, the outline form shows the 

subtotals for each group at the top of every group. The Tabular report layout displays one 

column for each field and leaves space for column headers. A total for each group appears at 

the bottom of each group. You can find these report layout options on the PivotTable Tools 

Design tab in the Layout group. 
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• Most PivotTable summaries are based on numeric data, but PivotTables can also contain only non-

numeric data. You cannot add non-numeric data, so you must use the COUNT function to 

produce summaries. For example, you could count the number of art objects by Location and 

Category. 

• You can use PivotTables to combine items into groups. Items that appear as row labels or column 

labels can be grouped. If items are numbers or dates, they can be grouped automatically using the 

Grouping dialog box, or they can be grouped manually using the Ctrl key to select items in a group 

and choosing Group from the shortcut menu. For example, you can manually combine the 

Courtyard and Garden locations into an Outdoor group, combine the three pavilion locations into 

an Indoor group, and then provide counts or total appraised values by these groups within the 

PivotTable. Being able to combine categories that aren’t part of your original data using the 

grouping feature gives you flexibility to summarize your PivotTables in a way that meets your 

analysis requirements. 

• You can develop PivotTables using the value filter, which allows you to filter one of your row or 

column fields in the PivotTable based on numbers that appear in the Values area of the 

PivotTable. For example, a PivotTable can show the total value of art objects for each artist and be 

filtered to display only artists whose total is greater than $25,000. Filtering provides you with a 

more precise way to view the PivotTable results by enabling you to include or remove data from 

the report. 
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• You can drag a field to the Report Filter area to create a filtered view of the PivotTable 

report. A report filter is used to filter the PivotTable to display summarized data for one 

or more field items or all field items in the Report Filter area. 

• In the PivotTable Field List, drag the field button you want from the Row Labels 

box to the Report Filter box. The Report Filter field item shows “All” to indicate 

that the PivotTable report displays all the summarized data associated with the 

specific field. 

• Click the report filter arrow. The AutoFilter menu opens, showing the field items 

displayed. 

• Click an option in the AutoFilter menu, and then click the OK button. The 

PivotTable displays the data filtered according to the option you have made. 

• The report filter arrow changes to an icon to indicate the PivotTable is currently 

filtered. 

• To filter more than one item at a time, click the Select Multiple Items check box in 

the AutoFilter menu to add a check mark next to each item, and then uncheck items 

you don’t want to include. 
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• Filtering a field lets you focus on a subset of items in that field. 

• You can filter field items in the PivotTable by clicking the field arrow button in the 

PivotTable that represents the data you want to hide, and then uncheck the check 

box for each item you want to hide. 

• To show hidden items, you click the field arrow button and check the check box for 

the item you want to show. 
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• You can expand and collapse items in the row labels of the PivotTable to view fields 

at different levels of detail. 

• The Expand and Collapse buttons identify where more details exist. The Expand button 

indicates you can show more details for that item, and the Collapse button indicates you 

can hide details for that item. The lowest level of the hierarchy does not have Expand 

and Collapse buttons because there is no data to expand or collapse. 

• These buttons are helpful when you have complex PivotTables where you want to switch 

quickly between a detailed view and an overview. 
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• You can sort a PivotTable field either by its own items or by the values in the body of the 

PivotTable. 

• To sort a PivotTable field, you can use any of the Sort buttons on the Options tab to sort 

the information in a PivotTable report. 
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• Although you can filter a PivotTable using the report filter arrow, column label arrows, and row 

label arrows, a slicer provides a quicker and easier way to filter a PivotTable

or PivotChart. 

• You can create a slicer for any field in a range or an Excel table. 

• Every slicer consists of an object that contains a button for each unique value in that field. You can 

format the slicer and its buttons, changing its style, height, and width. 

• You also can create more than one slicer at a time. 

• To add a slicer to the PivotTable: 

• In the Sort & Filter group on the PivotTable Tools Options tab, click the Insert Slicer 

button. The Insert Slicers dialog box opens, displaying a list of available PivotTable fields. 

You can select any or all of the fields. 

• Click the check box you want to insert a check mark, and then click the OK button. The 

respective slicer control appears on the worksheet. 

• If necessary, click the slicer to select the slicer object. The Slicer Tools Options tab appears on 

the Ribbon. 

• In the Size group on the Slicer Tools Options tab, you can change the height and width. The 

slicer object is resized, eliminating the extra space below the buttons and to the right of the 

labels. 

• In the Slicer Styles group, click the More button , and then you can select a Slicer Style. The 

slicer colors now match the PivotTable. 
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• To filter the PivotTable using the slicer:

• Click the slicer buttons you want the PivotTable to be filtered to display. The other slicer 

buttons are gray because they are not part of the report. 

• To select several buttons, press and hold the Ctrl key while clicking on them.
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• You cannot change data directly in the PivotTable. Instead, you must edit the Excel table, and 

then refresh, or update, the PivotTable to reflect the updated data.

• After editing the Excel table, click any cell in the PivotTable, click the PivotTable Tools 

Options tab on the Ribbon, and then click the Refresh button in the Data group. 
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• When a field contains numbers, dates, or times, you can combine items in the rows of 

a PivotTable and combine them into groups automatically. For example, grouping 

items can combine dates into larger groups such as months, quarters, or years so 

that the PivotTable can include the desired level of summarization. 

• If you want, for example, the PivotTable layout to show a count of items’ acquisitions 

by year, not by date:

• Click any date value in the Row Labels column of the PivotTable. 

• In the ‘Group’ group on the PivotTable Tools Options tab, click the Group Field 

button. The Grouping dialog box opens. 

• Click Months to deselect it, and then click Years to select it. 

• Click the OK button. The PivotTable report is grouped by year, displaying the 

number of item acquisitions in each year. 
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• Click any cell in the PivotTable. 

• In the Tools group on the PivotTable Tools Options tab, click the PivotChart button. 

The Insert Chart dialog box opens. 

• Click, for example, the Clustered Column chart (the first chart in the first row of the 

Column section), if necessary, and then click the OK button. A PivotChart appears next 

to the PivotTable along with the PivotTable Field List. 

• Click the PivotChart Tools Layout tab, click the Legend button arrow in the Labels 

group, and then click None. The legend is removed from the PivotChart. You do not 

need a legend if the PivotChart has only one series. 

• In the PivotChart, right-click the chart title, and then click Edit Text. The insertion 

point appears in the title so you can edit it. 

• You can also create a PivotChart based directly on an Excel table, in which case both a 

PivotTable and a PivotChart are created.
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• The PivotChart Tools contextual tabs enable you to manipulate and format the selected 

PivotChart the same way as an ordinary chart. A PivotChart and its associated PivotTable are 

linked. When you modify one, the other also changes. 

• You can quickly display different chart views of the PivotChart using the chart filter button on 

the PivotChart to filter the data. 
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• Line charts are typically used when the data consists of values drawn from categories 

that follow a sequential order at evenly spaced intervals, as with historical data in 

which the data values are recorded periodically such as monthly, quarterly, or yearly. 

• To create a line chart: 

• Select the range of the data that you want to be depicted in the chart. 

• Click the Insert tab on the Ribbon. 

• In the Charts group, click the Line button, and then click the Line chart (the first 

chart in the 2-D Line section). A line chart is embedded in worksheet. 

• To move the chart to a new/an existing worksheet, in the Location group on the 

Chart Tools Design tab, click the Move Chart button. The Move Chart dialog box 

opens. 

• Click either the New Sheet or the Object in arrow. Name the new sheet or select the 

existing sheet that you want the chart to be moved to. 

• Click the OK button. The line chart moves to the location of your choice.
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• To edit the title of the chart:

• Click the Chart Tools Layout tab on the Ribbon.

In the Labels group, click the Chart Title button, and then click Above Chart. A 

chart title appears above the line chart surrounded by a selection box. 

• Type a title name, and then press the Enter key. The new, descriptive title appears 

above the chart. 

• You can edit the Title fonts. the axis fonts as well as the Chart Legend fonts from 

the Font group on the Home tab on the Ribbon. 

• To modify the value axis scale and set specific range and increment values:

• Double-click the value axis to open the Format Axis dialog box.

• Next to Maximum, click the Fixed option button, and then type the maximum 

value of the range of your data. 

• Next to Major Unit, click the Fixed option button, and then type the increment 

value in the box. 

• Click the Close button. 
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• In addition to numbers, a scale can be based on dates. As with numerical scales, you can set 

the minimum and maximum dates to use in the scale’s range. You can also set the major and 

minor units as days, months, or years to use for the scale’s interval. 

• You can also format the category labels to show the four-digit year value rather than the 

complete date. Excel does not have a built-in format to display only four-digit year values, but 

you can create a custom format to accomplish this. 

• Custom date formats use combinations of the letters “m”, “d”, and “y” for months, days, and 

years, respectively. The number of letters controls how Excel displays the date, as follows: 

• With months, m or mm displays the one- or two-digit month number, mmm displays the 

month’s three-letter abbreviation, and mmmm displays the month’s full name. 

• With days, d or dd displays the one- or two-digit day value and dddd displays the day’s 

full name. 

• With years, yyyy displays the four-digit year value. 

• For example, a custom format of mmm-dd displays a three-letter month abbreviation 

followed by a hyphen and a two-digit day number (such as Apr-05). 

• You can apply such changes through the Axis Options menu on the Format Axis dialog box. 
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• When a chart involves large numbers, the axis labels can take up a lot of the available chart area 

and be difficult to read. 

• You can simplify the chart’s appearance by displaying units of measure more appropriate to the 

data values. For example, you can display the value 20 to represent 20,000 or 20,000,000. 

• This is particularly useful when space is at a premium, such as in an embedded chart confined to a 

small area of the worksheet. When you select the display units, such as Thousands, you can choose 

to show the display unit in the axis title. 

• To set the display unit for the value axis:

• Double-click the value axis to open the Format Axis dialog box with the Axis Options 

displayed. 

• Click the Display units arrow, and then click, for example, Thousands. 

• The scale of the value axis changes. The axis title “Thousands” indicates that the values are 

expressed in units of 1000. To save space, you can remove this title from the chart.

• Click the Show display units label on chart check box to remove the check mark. The axis title 

is removed from the chart. 

• You can apply custom formats to numbers just as with dates. One application of custom formats is 

to add text to a number. This is often used to include the units of measure alongside the value, such 

as 10k to indicate 10,000. To add text to a value, you use the custom format value “text”, where 

value is the number format applied to the value and text is the text to include next to the value. The 

text must be placed within quotation marks. 
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• Chart elements, such as titles and legends, overlay the chart area, which means they are 

placed on top of the chart. Overlaying chart elements is a way to make more space for the plot 

area because the chart does not resize to make room for that element. 

• To overlay and format the chart legend: 

• Double-click the legend to open the Format Legend dialog box. 

• Click the ‘Show the legend without overlapping the chart’ check box to remove the check 

mark. The legend moves left, overlaying the chart. The plot and the legend intersect, and 

the plot area shows through the legend. 

• Click Fill on the left side of the Format Legend dialog box, and then click the Solid fill 

option button. 

• Click the Color button , and then click white (the first color in the Theme Colors section). 

The legend now has a solid white background, making it easier to read. 

• Click Border Color on the left side of the Format Legend dialog box, and then click the 

Solid line option button. 

• Click the Color button , and then click Blue (the eighth color in the Standard Colors 

section). 

• Click the Close button. The Format Legend dialog box closes, and the reformatted legend 

overlays the chart. 
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• An overlaid chart element floats in the chart area and is not fixed to a particular 

position. This means that you can drag the chart element to a new location. This is 

helpful because when you overlay a chart element, it might overlap some of the 

chart contents, as the legend does. You’ll drag the overlaid legend down a bit so 

that it doesn’t obscure any of the data in the line chart. 

• To move the chart legend:

• Position the pointer over a blank spot in the chart legend so the pointer 

changes to and “Legend” appears in a ScreenTip. 

• Drag the legend to the lower-right corner of the plot area so the bottom of the 

legend is on the horizontal axis. 

• Click and drag the upper-left sizing handle of the legend down a few pixels 

until the legend no longer overlaps the lines on the chart. 
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• By default, Excel places horizontal gridlines on line charts and column charts. Each 

gridline is aligned with a major tick mark on the value axis. From the Axes group on 

Chart Tools Layout tab on the Ribbon, you can change the gridlines so that they 

appear for only the minor units, appear for both the major and minor units, or do not 

appear at all. The category axis has these same gridline options. 

• An axis title is descriptive text that appears next to the axis values. An axis title can 

provide additional information that is not covered in the chart title. It can include 

information about the source of the data and the units in which the data is measured. 

You can add/edit an axis title from the Chart Tools Layout tab in the Labels group.

© Stella Moysiadou - stm@aueb.gr



GRIDLINES AND AXIS TITLES

238

Microsoft Office 
Shipping, Finance & 
Management Skills

© Stella Moysiadou - stm@aueb.gr



EDITING AND REVISING CHART DATA

239

Microsoft Office 
Shipping, Finance & 
Management Skills

• Chart data can be edited and revised at any time. You do this by modifying the data range that 

the chart is based on, not by directly modifying the data in the chart. The change can be as 

simple as updating a specific value within the data source. Or it can be as involved as adding 

another data series to the chart. 

• Charts remain linked or connected to their data sources, even if they appear in different 

worksheets. If you change any values or labels in the data source, the chart is automatically 

updated to show the new content. One advantage of Excel charts is that you can quickly see 

how changing one or more values affects a graph. 
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• Select the chart to which you want to add a data series.

• In the Data group on the Chart Tools Design tab, click the Select Data button.

• Click the Add button in the Select Data Source dialog box.

• Select the range with the series name and series values you want for the new data 

• series.

• Click the OK button in each dialog box. 
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• A combination chart is a chart that combines two or more chart types in a single graph, such 

as a column chart and a line chart. To create a combination chart, you select a data series in an 

existing chart, and then apply a new chart type to that series, leaving the other data series in its 

original format. 

• Select a data series in an existing chart that you want to appear as another chart type. 

• In the Type group on the Chart Tools Design tab, click the Change Chart Type button, and 

then click the chart type 

you want. 

• Click the OK button. 
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• Line charts are appropriate when the categories can be ordered sequentially, that is when the 

categories represent dates. In the previous Figure, the sector categories do not have a sequential 

order and the lines connecting the different categories have no meaning. 

• To remove the lines and edit the markers in a line chart: 

• Click the line to select it. 

• Click the Chart Tools Layout tab 

on the Ribbon, and then click Format 

Selection in the Current Selection group. 

The Format Data Series dialog box opens. 

• Click Line Color on the left side of the 

dialog box, and then click the 

No line option button to 

remove the line from the line chart. 

• Click Marker Options on the left side of the dialog box, and then click the Built-in option 

button. You can now select the type and size of the marker. 
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• You can add visual interest to charts by using 3-D (three dimensional) effects. The

3-D effects provide the illusion of depth and distance, which makes the charts appear to stand 

out on the page. 

• To create a 3-D effect, Excel adds three spatial dimensions to the chart, which it labels the x-, y, 

and z-axes. 

• The x-axis represents the length of the object. 

• The y-axis represents the height of the object. 

• The z-axis represents the object’s depth. 

• To increase the 3-D effect, you need to rotate the chart. You can only rotate the chart 

horizontally or vertically. 

• Increasing the rotation horizontally spins the chart clockwise (as seen from above).

• Increasing the rotation vertically raises the user’s viewpoint higher above the chart. 

• Often you’ll need to experiment to find the right angles for a 3-D chart by rotating the chart 

in different directions until it looks good without distorting the data. 

• Excel charts cannot be rotated around the z- or depth axis, but you can specify the chart’s 

depth. Depth values can range from 0 to 2000 units. The larger the value, the thicker or deeper 

the chart appears to extend away from the viewer. 
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• You can also change the chart’s perspective, which controls how fast the chart appears to 

recede from the viewer’s eye. Perspective values range from 0 degrees to 90 degrees. A 90 

degree perspective value exaggerates the 3-D effect, making distant objects appear very small, 

whereas perspective values near 0 degrees minimize this effect. 

• Excel immediately applies your choices for depth and perspective, so you can try different 

depth and perspective values to determine which work best for your chart. 

• To change a pie chart to 3-D:

• Click the pie chart, and then click the Chart Tools Design tab on the Ribbon. 

• In the Type group, click the Change Chart Type button. The Change Chart Type dialog box 

opens. 

• In the Pie section, click Pie in 3-D (the second Pie chart type). 

• Click the OK button. The pie chart is now a 3-D chart, and has a slight shadow along its 

lower edge. 
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• You can also change the chart’s perspective, which controls how fast the chart appears to 

recede from the viewer’s eye. Perspective values range from 0 degrees to 90 degrees. A 90 

degree perspective value exaggerates the 3-D effect, making distant objects appear very small, 

whereas perspective values near 0 degrees minimize this effect. 

• Excel immediately applies your choices for depth and perspective, so you can try different 

depth and perspective values to determine which work best for your chart. 

• To change a pie chart to 3-D:

• Click the pie chart, and then click the Chart Tools Design tab on the Ribbon. 

• In the Type group, click the Change Chart Type button. The Change Chart Type dialog box 

opens. 

• In the Pie section, click Pie in 3-D (the second Pie chart type). 

• Click the OK button. The pie chart is now a 3-D chart, and has a slight shadow along its 

lower edge. 

• To rotate and reorient the 3-D pie chart: 

• Click the Chart Tools Layout tab on the Ribbon. 

• In the Background group, click the 3-D Rotation button. The Format Chart Area dialog box 

opens with the 3-D Rotation options displayed. 

• In the Rotation section, use the X box and the Y box to adjust rotation.
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• For more compact graphing, you can insert charts within worksheet cells. Excel provides two 

tools to do this—sparklines and data bars. Both convey graphical information about worksheet 

data without occupying a lot of space. 

• A sparkline is a mini chart that is displayed within a worksheet cell. Because sparklines are 

compact in size, they don’t include chart elements such as legends, titles, gridlines, or axes. The 

goal of a sparkline is to convey the maximum amount of graphical information within a very 

small space. As a result, sparklines are useful when you don’t want charts to overwhelm the rest 

of your worksheet or take up valuable page space. 

• Excel supports the following three types of sparklines: 

• A line sparkline for highlighting trends

• A column sparkline used for column charts

• A win/loss sparkline for highlighting positive and negative values.
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• In the Sparklines group on the Insert tab, click the Line, Column, or Win/Loss button. 

• In the Data Range box, enter the range for the data source of the sparkline. 

• In the Location Range box, enter the range into which to place the sparkline. 

• Click the OK button. 

• To edit a sparkline’s appearance, click the Sparkline Tools Design tab. 

• In the Show group, click the appropriate check boxes to specify which markers to display on 

the sparkline. 

• In the Group group, click the Axis button, and then click Show Axis to add an axis to the 

sparkline. 
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• A data bar is a conditional format that adds a horizontal bar to the background 

of a cell containing a numeric value. When applied to a range of cells, the data 

bars have the same appearance as a bar chart with each cell containing one bar. 

• The lengths of data bars are based on the value of each cell in the selected 

range. Cells with larger values have longer bars; cells with smaller values have 

shorter bars. 

• Data bars are dynamic, which means that if one cell’s value changes, the 

lengths of the data bars in the selected range are automatically updated. 

• Data bars differ from sparklines in that the bars are always placed in the cells 

containing the value they represent and each cell represents only a single bar 

from the bar chart. By contrast, a column sparkline can be inserted anywhere 

within the workbook and can represent data from several rows or columns. 

However, like sparklines, data bars can be used to create compact graphs that 

can be easily integrated alongside the text and values stored in your worksheet 

cells. 
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• To add data bars: 

• Select the relevant data 

range. 

• Click the Home tab on the 

Ribbon. 

• In the Styles group, click 

the Conditional Formatting 

button, and then point to 

Data Bars to display the 

Data Bars gallery. 

• In the Solid Fill group, 

click Blue Data Bar (the 

first data bar style). The 

data bars are added to the 

selected cells. 
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• The lengths of the data bars are determined based on the values in the selected range. The 

cell with the largest value contains a data bar that extends across the entire width of the cell, 

and the lengths of the other bars in the selected range are determined relative to that bar. In 

some cases, this means that the longest data overlaps the cell’s data value, making it difficult 

to read. You can modify the length of the data bars by altering the rules of the conditional 

format. 

• To modify the data bar rule: 

• Select the range which contains the data bars. 

• In the Styles group on the Home tab, click the Conditional Formatting button, and then 

click Manage Rules. The Conditional Formatting Rules Manager dialog box opens, 

displaying all the rules applied to any conditional format in the workbook. 

• Make sure Current Selection appears in the Show formatting rules for box. 

• Click the Edit Rule button. The Edit Formatting Rule dialog box opens. 

• In the Type row, click the Maximum arrow, and then click Number.

• In the Value row, type the value you want in the Maximum box.
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• Chart sheets are helpful for detailed charts that need more space to be seen clearly or when you 

want to show a chart without any worksheet text or data. 

• Some reports require large expansive charts rather than compact graphs to provide more detail 

and make them easier to view and share. In those situations, you may want to devote an entire 

sheet to a graph rather than embed it within a worksheet. 

• To create a larger version of a chart that covers an entire sheet, you move the chart to a chart 

sheet. Chart sheets are used for graphic elements like charts and images, and do not contain 

worksheet cells for calculating numeric values. 

• To create a chart sheet:

• Select the relevant data range.

• Click the Insert tab on the Ribbon. 

• In the Charts group, click the Line button, and then click the 3-D Line chart type. The 3-D 

line chart is embedded in the worksheet. You’ll move this chart to a chart sheet. 

• In the Location group on the Chart Tools Design tab, click the Move Chart button. The 

Move Chart dialog box opens. 

• Click the New sheet option button, and then type the name for the new chart sheet. 

• Click the OK button. A chart sheet that contains the 3-D line chart is inserted in the 

workbook. 
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• You can format a chart in a chart sheet using all the same options and tools as you

do to format a chart embedded in a worksheet. 
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• Formatting is the process of changing a workbook’s appearance by defining the fonts, styles, 

colors, and decorative features. Formatting changes only the appearance of data—it does not 

affect the data itself. 

• Excel organizes its formatting tools in terms of themes. A theme is a collection of formats for 

text, colors, images, and graphical effects applied throughout a workbook. Each theme has a 

name. The Office theme is the default, although you can apply other themes or create your own. 

You can also use fonts and colors that are not part of the current theme. As you format a 

workbook, Live Preview shows the effects of the formats on the workbook’s appearance. 

• Formatting Cell Content:

• To change the font, select the cell or range. In the Font group on the Home tab, click the 

Font arrow, and then click a font. 

• To change the font size, select the cell or range. In the Font group on the Home tab, click 

the Font Size arrow, and then click a font size. 

• To change a font style, select the cell or range. In the Font group on the Home tab, click 

the Bold, Italic, or Underline button. 

• To change a font color, select the cell or range. In the Font group on the Home tab, click 

the Font Color button arrow, and then click a color. 

• To format a text selection, double-click the cell to enter Edit mode, select the text to 

format, change the font, size, style, or color, and then press the Enter key. 
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• You can use a picture or an image as the background for a worksheet. An image can give the 

worksheet a textured appearance, like that of granite, wood, or fibered paper. The image is 

repeated until it fills the entire worksheet.

• The background image does not affect any cell’s format or content. Background colors 

applied to cells appear on top of the image, covering that portion of the image. 

• Background images do not print. 

• To add a background image to the worksheet:

• Click the Page Layout tab on the Ribbon. The page layout options appear on the Ribbon. 

• In the Page Setup group, click the Background button. The Sheet Background dialog 

box opens. 

• Navigate to the image file, and then click the Insert button. The image is added to the 

background of the worksheet. 
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• Designing a workbook requires the same care as designing any written document or report. A well-

formatted workbook is easier to read and establishes a sense of professionalism with readers. Do the 

following to improve the appearance of your workbooks: 

• Clearly identify each worksheet’s purpose with column or row titles and a descriptive sheet name. 

• Don’t crowd individual worksheets with too much information. Each worksheet should deal with 

only one or two topics. Place extra topics on separate sheets. Readers should be able to interpret each 

worksheet with a minimal amount of horizontal and vertical scrolling. 

• Place worksheets containing the most important information first in the workbook. Position 

worksheets summarizing your findings near the front of the workbook. Position worksheets with 

detailed and involved analysis near the end as an appendix. 

• Use consistent formatting throughout the workbook. If negative values appear in red on one 

worksheet, format them in the same way on all sheets. Also, be consistent in the use of thousands 

separators, decimal places, and percentages. 

• Pay attention to the format of the printed workbook. Make sure your printouts are legible with 

informative headers and footers. Check that the content of the printout is scaled correctly to the page 

size and that page breaks divide the information into logical sections. 

• Excel provides many formatting tools. However, too much formatting can be intrusive, overwhelm data, 

and make the document difficult to read. Always remember, the goal of formatting is not simply to make a 

“pretty workbook,” but also to accentuate important trends and relationships in the data. 
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• When used wisely, color can enhance any workbook. However, when used improperly, color 

can distract the user, making the workbook more difficult to read. As you format a workbook, 

keep in mind the following tips: 

• Use colors from the same theme within a workbook to maintain a consistent look and feel 

across the worksheets. If the built-in themes do not fit your needs, you can create a custom 

theme. 

• Use colors to differentiate types of cell content and to direct users where to enter data. For 

example, format a worksheet so that formula results appear in cells without a fill color and 

users enter data in cells with a light gray fill color. 

• Avoid garish color combinations that can annoy the reader and be difficult to read. 

• Print the workbook on both color and black-and-white printers to ensure that the printed 

copy is readable in both versions. 

• Understand your printer’s limitations and features. Colors that look good on your monitor 

might not look as good when printed. 

• Be sensitive to your audience. About 8 percent of all men and 0.5 percent of all women 

have some type of color blindness and might not be able to see the text when certain color 

combinations are used. Red-green color blindness is the most common, so avoid using red 

text on a green background or green text on a red background. 
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• You can format values using a number format, which displays the values in a way that 

makes it easy for the reader to quickly understand and interpret them. You can change the 

number format for the displayed value without affecting the underlying stored value. 

• Excel formats numbers by default in the General number format, which, for the most part, 

displays values exactly as they are typed by the user. If the value is calculated from a formula 

or function, Excel shows as many digits after the decimal point as will fit in the cell with the 

last displayed digit rounded. Calculated values too large to fit into the cell are displayed in 

scientific notation. 

• The General number format is good for simple calculations, but some values require additional 

formatting to make the numbers easier to interpret. Using Excel, you can: 

• Set the number of digits displayed to the right of the decimal point. 

• Add commas to act as a thousands separator for large values. 

• Apply currency or accounting symbols to numeric values to identify the monetary unit 

being used. 

• Display percentages using the % symbol.
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• Because Excel stores dates and times as numbers and not as text, you can apply different 

formats without affecting the date and time value. 
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• The buttons on the Home tab provide quick access to the most commonly used formatting 

choices. For more options, you can use the Format Cells dialog box. 

• You can open the Format Cells dialog box by right-clicking a cell or selected range, and then 

clicking Format Cells on the shortcut menu.

• The Format Cells dialog box has six tabs, each focusing on a different set of formatting options, 

as described below. You can apply the formats in this dialog box to selected worksheet cells. 

• Number provides options for formatting the appearance of numbers, including dates and 

numbers treated as text (for example, telephone or Social Security numbers). 

• Alignment provides options for how data is aligned within a cell. 

• Font provides options for selecting font types, sizes, styles, and other formatting attributes 

such as underlining and font colors. 

• Border provides options for adding and removing cell borders as well as selecting a line 

style and color. 

• Fill provides options for creating and applying background colors and patterns to cells. 

• Protection provides options for locking or hiding cells to prevent other users from 

modifying their contents. 
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• By default, cell text is aligned with the left and bottom borders of a cell and cell values are 

aligned with the right and bottom borders. In some cases, you might want to change the text 

alignment to make the text more readable or visually appealing. In general, you should center 

column titles, left-align other cell text, and align numbers to keep their decimal places lined up 

within a column. The buttons to set these alignment options are located in the Alignment group 

on the Home tab. 
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• A workbook often contains several cells that store the same type of data. For example, each 

worksheet might have a cell displaying the sheet title, or a range of financial data might have 

several cells containing summary totals. It’s good design practice to apply the same format to 

worksheet cells that contain the same type of data. 

• One way to ensure that you are using consistent formats is to copy and paste your formats using 

the Format Painter. The Format Painter is effective, but it can also be time consuming if you 

need to copy the same format to several cells scattered across the workbook. Moreover, if you 

decide to modify the format, you must copy and paste the revised format all over again. 

Another way to ensure that cells displaying the same type of data use the same format is with 

styles. 

• A style is a selection of formatting options using a specific font and color from the current 

theme. For example, you can create a style to display sheet titles in a bold, white, 20-point 

Calibri font on a blue background. You can then apply that style to any sheet title in a 

workbook. If you later revise the style, the appearance of any cell formatted with that style is 

updated automatically. This saves you the time and effort of reformatting each cell 

individually. 
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• Select the cell or range to which you want to apply a style. 

• In the Styles group on the Home tab, click the Cell Styles button. 

• Point to each style in the Cell Styles gallery to see a Live Preview of that style on the selected 

cell or range. 

• Click the style you want to apply to the selected cell or range. 
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• Fonts, colors, and cell styles are organized in theme and non-theme categories. 

• The appearance of these fonts, colors, and cell styles depends on the workbook’s current theme. 

If you change the theme, the formatting of these elements also changes throughout the entire 

workbook. 

• To change the workbook’s theme: 

• Click the Page Layout tab on the Ribbon. 

• In the Themes group, click the Themes button. The Themes gallery opens. Office—the 

current theme—is the default. 

• Point to each theme in the Themes gallery. Live Preview shows how each theme changes 

the appearance of the Yearly Sales worksheet. 

• Click a theme to apply that theme to the workbook. 
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• Using a common style and design theme for all the files you create in Microsoft Office is a simple 

way to give your files a consistent look and feel and project a professional image. This 

consistency is especially important when a team of workers is collaborating on a set of documents. 

When all team members work from a common set of style and design themes, readers will not be 

distracted by inconsistent or clashing styles. 

• To quickly copy the styles from one workbook to another, open the workbook with the styles you 

want to copy, and then open the workbook in which you want to copy those styles. In the Styles 

group on the Home tab, click the Cell Styles button, and then click Merge Styles. The Merge Styles 

dialog box opens, listing the currently open workbooks. Select the workbook with the styles you 

want to copy, and then click the OK button to copy those styles into the current workbook. If you 

modify any styles, you must copy the styles to the other workbook; Excel does not update styles 

between workbooks. 

• Because other Office files, including those created with Word or PowerPoint, use the same file 

format for themes, you can create one theme to use with all the Office files you create. To save a 

theme, in the Themes group on the Page Layout tab, click the Themes button, and then click Save 

Current Theme. The Save Current Theme dialog box opens. Select a save location (in a default 

Theme folder on your computer or another folder), type a descriptive name in the File name box, 

and then click the Save button. If you saved the theme file in a default Theme folder, the theme 

appears in the Themes gallery, and any changes made to the theme are reflected in any Office file 

that uses that theme. © Stella Moysiadou - stm@aueb.gr
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• By creating a library of styles and themes, you can create a report containing pages generated 

from different Office programs and those pages will still share a consistent set

of design elements. Employees with expertise in page design can design a theme for the rest 

of the team to use. If those styles and themes are changed or modified, the new design style 

can be quickly applied to new and existing documents without having to reformat each 

document. Through careful planning, a well-designed theme can save you and your 

colleagues a lot of effort later on. 
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• Formatting an entire table with a table style is more efficient than formatting individual cells 

in the table. 

• In addition, using a table style ensures that the table’s formatting reflects any changes made to 

the table, such as adding or deleting table rows or columns. For example, many tables display 

alternate rows with different fill colors. This banded rows effect makes the data easier to read, 

especially in large tables with many rows. You could create the banded rows effect by applying 

a cell style with a background fill to every other row in the table; but if you later add or delete a 

row from the table, the banded rows effect might be lost. A table style, on the other hand, 

applies alternating row colors to the entire Excel table and adjusts the banded rows effect as 

needed if you add or delete rows. This is because a table style treats the table as a single object 

rather than a collection of cells. 
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• To apply a table style to a range of data: 

• Select the range. 

• In the Styles group on the Home tab, click the Format as Table button, and then click the 

style you want to apply. The ‘Format As Table’ dialog box opens, confirming the range you 

selected for the table and whether the table includes header rows. 

• Verify that the range displayed is the correct one and then verify that the ‘My table has 

headers’ check box contains a check mark to include the text labels in the table. 

• Click the OK button to apply the table style to the selected range.

• After you apply a table style, you can choose which table elements to include in the style. Table 

styles have the following six elements that can be turned on or off: 

• Header Row, which formats the first row of the table 

• Total Row, which inserts a new row at the bottom of the table that adds the column values 

• First Column, which formats the first column of the table 

• Last Column, which formats the last column of the table 

• Banded Rows, which formats alternating rows in different colors 

• Banded Columns, which formats alternating columns in different colors 
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• Highlighting a Cell Based on Its Value 

• Select the range in which you want to highlight cells that match a specified rule.

• In the Styles group on the Home tab, click the Conditional Formatting button, point to 

Highlight Cells Rules or Top/Bottom Rules, and then click the appropriate rule. 

• Select the appropriate options in the dialog box, and then click the OK button. 

• For example, to highlight positive numbers:

• Select the range to apply the conditional format rule.

• In the Styles group on the Home tab, click the Conditional Formatting button, point to 

Highlight Cells Rules, and then click Greater Than. The ‘Greater Than’ dialog box opens.

• Type 0 (a zero) in the ‘Format cells that are GREATER THAN’ box, click the with arrow, 

and then choose the formatting you want. Click the OK button to apply the rule.

• Conditional formats are dynamic, so that if the cell’s value changes, the cell’s format also 

changes as needed. Each conditional format has a set of rules that define how the formatting 

should be applied and under what conditions the format will be changed. 

• Excel has four conditional formats—data bars, highlighting, color scales, and icon sets. 

• The following Figure describes some of the ways that cells can be highlighted with conditional 

formats. 
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To clear a conditional format: 
• Select the relevant range.
• In the Styles group on the Home tab, click the Conditional Formatting button, point to Clear Rules, and 

then click Clear Rules from Selected Cells. 
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Conditional formatting is an excellent way to highlight important trends and data values to clients 

and colleagues. However, it should be used judiciously. An overuse of conditional formatting can 

sometimes obscure the very data values you want to emphasize. You’ll need to make decisions 

about what to highlight and how it should be highlighted. Keep in mind the following tips as you 

consider the best ways to effectively communicate your findings to others: 

• Document the conditional formats you use. If a bold, green font means that a number is in the 

top 10 percent of all, include that information in a legend in the worksheet. 

• Don’t clutter data with too much highlighting. Limit highlighting rules to one or two per data 

set. Highlights are designed to draw attention to points of interest. If you use too many, you’ll 

end up highlighting everything—and, therefore, nothing. 

• Use color sparingly in worksheets with highlights. It’s difficult to tell a highlight color from a 

regular fill color, especially when fill colors are used in every cell. 

• Consider alternatives to conditional formats. If you want to highlight the top 10 sales regions, it 

might be more effective to simply sort the data with the best-selling regions at the top of the 

list. 

Remember that the goal of highlighting is to provide a strong visual clue of important data or 

results. Careful use of conditional formatting helps readers to focus on the important points 

you want to make rather than be distracted by secondary issues and facts. 
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• Hiding rows, columns, and worksheets is a good way to manage a large volume of information; 

but it should never be used to hide data that is crucial to understanding a workbook. 

• Note that hiding a row or column does not affect the other formulas in the workbook. Formulas 

still show the correct value even if they reference a cell in a hidden row or column. 

• To hide and unhide worksheet rows: 

• Select the rows you want to hide. 

• In the Cells group on the Home tab, click the Format button, point to Hide & Unhide, and then 

click Hide Rows. The rows are hidden.

• To Unhide the hidden rows, select the two rows that come just before and after the hidden ones. 

• In the Cells group, click the Format button, point to Hide & Unhide, and then click Unhide 

Rows. The hidden rows reappear. 
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• Excel supports a wealth of print options, including the ability to set the page orientation as well 

as specify whether the page will include headers and footers. Print settings can be applied to 

an entire workbook or to individual sheets. 

• Because it is likely that other people, such as clients and colleagues, will see the printed version 

of your spreadsheet, you should take as much care in formatting the printed output as you do 

in formatting the contents of the electronic file. 

• To view a worksheet in Page Layout view:

• Click the Page Layout button on the status bar. The worksheet switches to Page Layout 

view. 

• Change the zoom level of the worksheet to 70% to view more of the page layout. See the 

following Figure. 

• It is likely that in the worksheet’s orientation, its contents do not fit on a single page and the 

tables break across pages. You can change the orientation from portrait to landscape so that 

the page is wide enough to fit all the table columns on one page. 
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• By default, all cells in the active worksheet containing text, formulas, or values are printed. The 

region that is sent to the printer from the active sheet is known as the print area. 

• To print part of a worksheet, you can define the print area, overriding the default setting. A 

print area can cover an adjacent or nonadjacent range in the current worksheet. 

• There are many different ways to define the print area, but it’s generally easiest to set the print 

area in Page Break Preview. 

• To switch to Page Break preview and set the print area: 

• Click the Page Break Preview button on the status bar. (If the Welcome to Page Break 

Preview dialog box opens, click the OK button).

• Change the zoom level of the worksheet to 70%.

• Select the range you want to print. 

• In the Page Setup group on the Page Layout tab, click the Print Area button, and then click 

Set Print Area. The print area changes to cover only the selected range. The rest of the 

worksheet content is shaded to indicate that it will not be part of the printout. 

• In the Page Setup group, click the Print Area button, and then click Clear Print Area. The 

print area is reset to cover the entire contents of the worksheet. 
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• Often the contents of a worksheet do not fit onto a single page. By default, Excel prints as much of 

the content that fits on single page without resizing the content, and then inserts automatic page 

breaks to continue printing the remaining worksheet content on successive pages. This can result in 

page breaks that leave a single column or row on a separate page or split worksheet content in 

awkward places such as within a table. 

• One way to fix this problem is to scale the printout by reducing the font size to fit on a single sheet 

of paper. However, if you have more than one or two columns or rows to fit onto the page, the 

resulting text is often too small to read comfortably. The better fix is usually to split the worksheet 

into logical segments, which you can do by inserting manual page breaks that specify exactly 

where the page breaks occur. A page break is inserted directly above and to the left of a selected 

cell, directly above a selected row, or to the left of a selected column. 

• To insert a page break: 

• Select the first cell below the row where you want to insert a page break.

• In the Page Setup group on the Page Layout tab, click the Breaks button, and then click Insert 

Page Break. 

• To remove a page break: 

• Select any cell below or to the right of the page break you want to remove.

• In the Page Setup group on the Page Layout tab, click the Breaks button, and then click 

Remove Page Break (or click Reset All Page Breaks to remove all the page breaks from the 

worksheet). © Stella Moysiadou - stm@aueb.gr
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• It is a good practice to include descriptive information, such as the company name, logo, and 

worksheet title on each page of a printout in case a page becomes separated from the other 

pages. You can repeat information, such as the company name, by specifying which rows or 

columns in the worksheet act as print titles. If a worksheet contains a large table, you can print 

the table’s column headings and row headings on every page of your printout by designating 

those initial columns and rows as print titles. 

• To define the print title for the pages:

• In the Page Setup group on the Page Layout tab, click the Print Titles button. 

• The Page Setup dialog box opens with the Sheet tab displayed. 

• Click the Rows to repeat at top box, move your pointer over the worksheet, and then select 

the range you want. 

• Click the OK button. 

• The Sheet tab in the Page Setup dialog box provides other print options, such as printing the 

gridlines or row and column headings. You can also print the worksheet in black and white or 

in draft quality. For a multiple page printout, you can specify whether the pages are ordered by 

going down the worksheet and then across, or across first and then down. 
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• Another way to repeat information on each printed page is with headers and footers. Headers and 

footers contain helpful and descriptive text that is usually not found within the worksheet, such as 

the workbook’s author, the current date, or the workbook filename. If the printout covers multiple 

pages, you can display the page number and the total number of pages in the printout to help ensure 

you and others have all the pages. 

• The header and footer each have three sections: a left section, a center section, and a right section. 

Within each section, you type the text you want to appear or insert elements such as the worksheet 

name or the current date and time. These header and footer elements are dynamic; if you rename the 

worksheet, for example, the name is automatically updated in the header or footer. 

• To insert a header and footer:

• In Page Layout view, change the zoom level of the worksheet to 90%. 

• Scroll to the top of the worksheet, and then click the left section of the header directly above 

cell A1. The Header & Footer Tools contextual tab appears on the Ribbon. 

• Type ‘Filename:’ in the left section of the header, press the spacebar, and then, in the Header & 

Footer Elements group on the Design tab, click the ‘File Name’ button. The code &[File], 

which displays the filename of the current workbook, is added into the left section of the 

header. 

• Press the Tab key twice to move to the right section of the header, and then click the Current 

Date button in the Header & Footer Elements group. The code &[Date] is added into the right 

section of the header. © Stella Moysiadou - stm@aueb.gr
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• Another way to fit a large worksheet on a single page is to reduce the size of the page margins. 

By default, Excel sets the page margins to between 0.7 and 0.75 inches, and allows for 0.3-inch 

margins around the page header and footer. You can reduce or increase these margins as needed 

by selecting from a set of predefined margin sizes or defining your own. 

• To set the page margins: 

• Click the Page Layout tab on the Ribbon. 

• In the Page Setup group, click the Margins button. A menu opens with a list of predefined 

margins. 

• Click Wide to set 1-inch margins around the printed content with 0.5-inch margins around 

the header and footer. The size of the margins around the page increases, but does not 

affect the content. Each of the three tables and the print titles still fit on single sheets. 
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• Workbook data is often placed in several worksheets. Using multiple worksheets makes it 

easier to group and summarize data. 

• Using multiple worksheets enables you to place summarized data first. Managers interested 

only in an overall picture can view the first worksheet of summary data without looking at the 

details available in the other worksheets. Others, of course, might want to view the supporting 

data in the individual worksheets that follow the summary worksheet. 

• Worksheet groups save you time and help improve consistency among the worksheets because 

you can perform an action once, yet affect multiple worksheets. 

• Grouping and Ungrouping Worksheets 

• To select an adjacent group, click the sheet tab of the first worksheet in the group, press 

and hold the Shift key, click the sheet tab of the last worksheet in the group, and then 

release the Shift key. 

• To select a nonadjacent group, click the sheet tab of one worksheet in the group, press and 

hold the Ctrl key, click the sheet tabs of the remaining worksheets in the group, and then 

release the Ctrl key. 

• To ungroup the worksheets, click the sheet tab of a worksheet not in the group or right-

click the sheet tab of one worksheet in the group, and then click Ungroup Sheets on the 

shortcut menu. 
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• When you enter a formula in the active worksheet (in this case, the Quarter 1 work- sheet), the 

formula is entered in the same cells in all the worksheets in the group.

The grouped worksheets must have the exact same organization and layout (rows and 

columns) for this to work. Otherwise, any formulas you enter in the active sheet will be 

incorrect in the other worksheets in the group and could overwrite existing data. 

• As with inserting formulas and text, any formatting changes you make to the active sheet are 

applied to all sheets in the group. 

• When you enter, edit, or format cells in a worksheet group, the changes you make to one 

worksheet are automatically applied to the other worksheets in the group. For example, if you 

delete a value from one cell, the content is also deleted from the same cell in all the worksheets 

in the group. Be cautious when editing a worksheet that is part of a group. If the layout and 

structure of the other grouped worksheets are not exactly the same, you may inadvertently 

overwrite data in some of the worksheets. Also, remember to ungroup the worksheet group 

after you finish entering data, formulas, and formatting. Otherwise, changes you intend to 

make in one worksheet will be made to all the worksheets in the group, potentially producing 

incorrect results. 
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• Using multiple worksheets to organize complex data can help make it simpler to understand and 

analyze as well as to navigate to specific data. For example, a workbook that contains data about a 

variety of products, stores, or regions could use a different worksheet for each product, store, or 

region. This organization provides a way to view discrete units of data that can be combined and 

summarized in another worksheet. 

• When you use multiple worksheets to organize similar types of data, the worksheets should have 

identical layouts. You can quickly group the worksheets with the identical layouts, and then enter 

the formulas, formatting, and labels in all of the grouped worksheets at once. This helps to ensure 

consistency and accuracy among the worksheets as well as make it faster to create the different 

worksheets needed. 

• Using multiple worksheets with identical layouts enables you to use 3-D references to quickly 

summarize the data in another worksheet. The summary worksheet provides an overall picture of the 

data that is detailed in the other worksheets. Often, managers are more interested in this big picture 

view. However, the supporting data is still available in the individual worksheets when a deeper 

analysis is needed. 

• So, when you are working with a large and complex worksheet filled with data, consider the 

different ways to organize it in multiple worksheets. Not only will you save time when entering 

and finding data, but also the data becomes more understandable, and connections and results 

become clearer. © Stella Moysiadou - stm@aueb.gr
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• By creating a worksheet group, you apply the same page layout settings to all the worksheets in 

the group at the same time. You can also print all the worksheets in the group at once. 
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• Select the sheet tabs of the worksheets you want to copy. 

• Right-click the sheet tabs, and then click Move or Copy on the shortcut menu. 

• Click the ‘To book’ arrow, and then click the name of an existing workbook or click (new 

• book) to create a new workbook for the worksheets. 

• In the ‘Before sheet’ box, click the worksheet you want to insert the new worksheet before. 

• Click the Create a copy check box to insert a check mark to copy the worksheets. 

• Click the OK button.
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• When two or more worksheets have identical row and column layouts, as do the quarterly 

worksheets in the New Mexico workbook, you can enter formulas with 3-D references to 

summarize those worksheets in another worksheet. The 3-D reference specifies not only the 

range of rows and columns, but also the range of worksheet names in which the cells appear. 

• The general syntax of a 3-D cell reference is: WorksheetRange!CellRange

• In this syntax, WorksheetRange is the range of worksheets you want to reference and is 

entered as FirstSheetName:LastSheetName with a colon separating the first and last 

worksheets in the worksheet range. 

• CellRange is the same cell or range in each of those worksheets that you want to reference. 

An exclamation mark (!) separates the worksheet range from the cell or range. 

• For example, the following formula adds the values in cell E13 in the worksheets between 

Quarter1 and Quarter4, including Quarter1 and Quarter4: =SUM(Quarter1:Quarter4!E13) 

• If worksheets named Quarter1, Quarter2, Quarter3, and Quarter4 are included in the 

workbook, the worksheet range Quarter1:Quarter4 references all four worksheets. 

Although the Quarter2 and Quarter3 worksheets aren’t specifically mentioned in this 3-D 

reference, all worksheets positioned within the starting and ending names are included in 

the calculation. 
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• The results of a formula using a 3-D reference reflect the current worksheets in the worksheet 

range. If you move a worksheet outside the referenced worksheet range or remove a worksheet 

from the workbook, the formula results will change. 

• For example, consider a workbook with four worksheets named Quarter1, Quarter2, Quarter3, 

and Quarter4. 

• If you move the Quarter3 worksheet after the Quarter4 worksheet, the worksheet range 

Quarter1:Quarter4 includes only the Quarter1, Quarter2, and Quarter4 worksheets. 

• Similarly, if you insert a new worksheet or move an existing worksheet within the 

worksheet range, the formula results reflect the change. 

• To continue the example, if you insert a Quarter5 worksheet before the Quarter4 

worksheet, the 3-D reference Quarter1:Quarter4 includes the Quarter5 worksheet. 

• When you create a formula, make sure that the 3-D cell reference reflects the appropriate 

worksheets. 

• Also, if you later insert or delete a worksheet within the 3-D reference, be aware of how doing 

so will affect the formula results. 
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• Click the cell where you want to enter the formula. 

• Type = to begin the formula, type the name of the function, and then type ( to indicate the 

beginning of the argument. 

• Click the sheet tab for the first worksheet in the worksheet range, press and hold the Shift key, 

and then click the tab for the last worksheet in the worksheet range. 

• Select the cell or range to reference, and then press the Enter key. 
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• When creating formulas in a workbook, you can reference data in other workbooks.

To do so, you must create a link between the workbooks. When two files are linked, the source 

file contains the data, and the destination file (sometimes called the dependent file) receives the data. 

• To create the link between destination and source files, you need to insert a formula in the 

workbook that references a specific cell or range in other workbooks. 

• The process for entering a formula with an external reference is the same as entering any other 

formula using references within the same worksheet or workbook. You can enter the formulas by 

typing them or using the point-and-click method. In most situations, you will use the point-and-click 

method to switch between the source files and destination files so that Excel enters the references to 

the workbook, worksheet, and cell using the correct syntax. 

• That reference, called an external reference, has the syntax

[WorkbookName]WorksheetName!CellRange where 

• WorkbookName is the filename of the workbook (including the file extension) enclosed in 

square brackets; 

• WorksheetName is the name of the worksheet that contains the data followed by an exclamation 

mark; and 

• CellRange is the cell or range that contains the data. 

• For example, the following formula references cell B6 in the Summary worksheet of the 

Colorado.xlsx workbook: =[Colorado.xlsx]Summary!B6
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• If the workbook name or the worksheet name contains one or more spaces, you must enclose 

the entire workbook name and worksheet name in single quotation marks. For example, the 

following formula references cell B6 in the Summary worksheet of the New Mexico.xlsx

workbook: ='[New Mexico.xlsx]Summary'!B6 

• When the source and destination workbooks are stored in the same folder, you need to include 

only the workbook name in the external reference. However, when the source and destination 

workbooks are located in different folders, the workbook reference must include the file’s 

complete location (also called the path). 

• For example, if the destination file is stored in C:\TicketSales and the source file is stored 

in C:\TicketSales\Domestic Sales, the complete reference in the destination file would be: 

='C:\TicketSales\Domestic Sales\[New Mexico.xlsx]Summary'!B6 

• The single quotation marks start at the beginning of the path and end immediately before 

the exclamation mark. 

• When you use the point-and-click method to build formulas with external references, Excel 

enters all of the required punctuation, including quotation marks. 

• You cannot use 3-D references here because you are referencing multiple workbooks and 3-D 

references can only be used to reference multiple worksheets in the same workbook. 
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• More than one person is usually involved in developing information that will be used in an 

organization’s decision-making process. If each person has access to only part of the data, 

everyone’s ability to see the whole picture and make good decisions is limited. Linking 

workbooks provides one way to pull together all of the data being compiled by different 

people or departments to support the decision-making process. 
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• As you work with a linked workbook, you might need to replace a source file or change where you 

stored the source and destination files. However, replacing or moving a file can affect the linked 

workbook. Keep in mind the following guidelines to manage your linked workbooks: 

• If you rename a source file, the destination workbook won’t be able to find it. A dialog box 

opens, indicating “This workbook contains one or more links that cannot be updated.” Click the 

Continue button to open the workbook with the most recent values, or click the Change Source 

button in the Edit Links dialog box to specify the new name of that linked source file. 

• If you move a source file to a different folder, the link breaks between the destination and 

source files. Click the Change Source button in the Edit Links dialog box to specify the new 

location of the linked workbook. 

• If you receive a replacement source file, you can swap the original source file with the 

replacement file. No additional changes are needed. 

• If you receive a destination workbook but the source files are not included, Excel will not 

be able to find the source files, and a dialog box opens with the message “This workbook 

contains one or more links that cannot be updated.” Click the Continue button to open the 

workbook with the most recent values, or click the Break Link button in the Edit Links dialog 

box to replace the external references with the existing values. 

• If you change the name of a destination file, you can open that renamed version destination 

file without affecting the source files or the original destination file. 
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• When workbooks are linked, it is important that the data in the destination file accurately reflects the 

contents of the source file. When data in a source file changes, you want the destination file to 

reflect those changes. 

• If both the source and destination files are open when you make a change, the destination file is 

updated automatically. 

• If the destination file is closed when you make a change in a source file, you choose whether to 

update the link to display the current values, or continue to display the older values from the 

destination file when you open the destination file. 

• As part of the Excel security system that attempts to protect against malicious software, links to 

other workbooks are not updated without your permission. 

• When you open a workbook with external reference formulas (the destination file), a Security 

Warning appears in the Information Bar, notifying you that the automatic update of links has 

been disabled. 

• If you “trust” the provider of the source file(s), you can enable the content, which allows the 

external reference formulas to function and updates the links in the destination workbook. 

• If you do not “trust” the provider of the source files or do not want the destination file updated 

at that time, do not enable the content. The old values in the destination workbook are displayed 

and the links to the source files remain disabled. 
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• When workbooks are linked, the Edit Links dialog box provides ways to manage the links. You can 

review the status of the links, update the data in the files, repair broken links, open the source file, 

and break the links, which converts all external reference formulas to their most recent values. 

• Click the Data tab on the Ribbon.

• In the Connections group, click the Edit Links button. The Edit Links dialog box opens. 
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• The Edit Links dialog box lists all of the files that the destination workbook is linked to so that you 

can update, change, open, or remove the links. The dialog box shows the following information 

about each link: 

• Source indicates the file to which the link points. 

• Type identifies the type of each source file. In this case, the type is an Excel worksheet but it 

could also be a Word document, a PowerPoint presentation, or some other type of file. 

• Update specifies the way values are updated from the source file. The letter A indicates the 

link is updated automatically when you open the workbook or when both the source and 

destination files are open simultaneously. The letter M indicates the link must be updated 

manually by the user, which is useful when you want to see the older data values before 

updating to the new data. To manually update the link and see the new data values, click the 

Update Values button. 

• Status shows whether Excel successfully accessed the link and updated the values from the 

source document (status is OK), or Excel has not attempted to update the links in this session 

(status is Unknown). 

• To convert all external reference formulas to their current values: 

• Click the Break Link button. A dialog box opens, alerting you that breaking links in the 

workbook permanently converts formulas and external references to their existing values. 

• Click the Break Links button. No links appear in the Edit Links dialog box. Click the Close 

button. © Stella Moysiadou - stm@aueb.gr
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• The Switch Windows button in the Window group on the View tab lists each open 

workbook so you can change which workbook is active. Another method is to click the Excel 

program button on the taskbar and then click the thumbnail of the workbook you want to make 

active. 

• You might also want to display all the open workbooks on your screen at the same time. 

This way, you can easily click among the open workbooks to create links without having to 

continually change the active workbook, as well as quickly compare the contents of worksheets 

in different workbooks. You can arrange workbooks in the following layouts: 

• Tiled, which divides the open workbooks evenly on the screen.

• Horizontal, which divides the open workbooks into horizontal bands. 

• Vertical, which divides the open workbooks into vertical bands.

• Cascade, which layers the open workbooks on the screen. 

• To arrange the workbooks:

• On the View tab, in the Window group, click the Arrange All button. 

• Select the layout in which you want to arrange the open workbooks. 

• When arranging multiple workbooks, uncheck the Windows of active workbook option. 

• When arranging multiple worksheets within one workbook, check the option. 

• Click the OK button. 
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• Rather than having to open each workbook individually, you can create a workspace to open 

multiple workbooks at one time, saving time and avoiding having to remember all the 

filenames and folder locations. 

• A workspace is an Excel file that saves information about all of the currently opened workbooks, 

such as their locations, window sizes, zoom magnifications, and other settings. 

• The workspace file has the file extension .xlw. 

• The workspace does not contain the workbooks themselves—only information about them. To use 

that set of workbooks, you open the workspace file. Excel then opens the workbooks and settings in 

the same configuration they were in when you saved the workspace file. 

• Even if a workbook is included in a workspace file, you can still open that workbook separately. 

• To create a workspace file: 

• Open the relevant workbooks, clicking the Don’t Update button in the dialog that opens indicating 

that the workbook contains links. 

• Switch to the workbook you want to appear first in the workspace you will create.

• Click the View tab on the Ribbon, and then click the Arrange All button in the Window group. The 

Arrange Windows dialog box opens. 

• Click the Cascade option button, and then click the OK button. The workbooks overlap each other, 

with the title bars visible. 
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• In the Window group, click the Save Workspace button. The Save Workspace dialog box opens and 

functions similarly to the Save As dialog box. 

• Type the name you want in the File name box, verify that Workspaces is selected in the Save as type 

box, specify the save location, and then click the Save button. A dialog box might open, prompting you 

to save your changes to the open workbook files, if you haven’t already done so. 

• If prompted to save changes, click the Save button. The workspace file is saved. The workspace file has 

the file extension .xlw. 

• To open the workspace file: 

• Close all four workbooks. 

• Click the File tab on the Ribbon, and then click the Open command in the navigation bar. The Open 

dialog box opens. The icon for the workspace file is different from the Excel workbook file icon. 

• Click the workspace file, and then click the Open button. A dialog box opens, indicating that the 

workbook contains links. 

• Click the Don’t Update button. The workbooks open and are arranged in a cascade layout, the same 

layout in which you saved them. You can work with the workbooks as usual. 

• Click a workbook title bar to bring it to the front of the cascaded workbooks. This is now the active 

workbook. 

• The workspace file provides a quick way to open a series of workbooks in a specific display. 

Because it doesn’t actually contain the workbooks, you must close each workbook separately, 

saving as needed. © Stella Moysiadou - stm@aueb.gr
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• A hyperlink is a link in a file, such as a workbook, to information within that file or another file. 

Hyperlinks can be placed in a worksheet and used to quickly jump to a specific cell or range within the 

active worksheet, another worksheet, or another workbook. Hyperlinks can also be used to jump to other 

files, such as a Word document or a PowerPoint presentation, or sites on the Web. 

• To insert a Hyperlink 

• Select the text, graphic, or cell in which you want to insert the hyperlink. 

• In the Links group on the Insert tab, click the Hyperlink button. 

• To link to a file or Web page, click Existing File or Web Page in the Link to list, and then select the 

file or Web page from the Look in box. 

• To link to a location in the current workbook, click Place in This Document in the Link to list, and 

then select the worksheet, cell, or range in the current workbook. 

• To link to a new document, click Create New Document in the Link to list, and then specify the 

filename and path of the new document. 

• To link to an email address, click E-mail Address in the Link to list, and then enter the email 

address of the recipient and a subject line for the message. 

• Click the OK button. 

• To edit a hyperlink, right click on it and then click Edit Hyperlink on the shortcut menu. The Edit 

Hyperlink dialog box opens; it has the same layout and information as the Insert Hyperlink dialog box. 

• To delete a hyperlink, right-click the hyperlink cell and then click Clear Contents. To delete the 

hyperlink but keep the text, right-click the hyperlink cell, and then click Remove Hyperlink. 
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• If you want to create a new workbook that has the same format as an existing workbook, you could save 

the existing workbook with a new name and replace the values with new data or blank cells. The 

potential drawback to this method is that you might forget to rename the original file and overwrite data 

you intended to keep. 

• A better method is to create a template workbook that includes all the text (row and column labels), 

formatting, and formulas but does not contain any data. The template workbook is a model from 

which you create new workbooks. 

• When you create a new workbook from a template, an unnamed copy of the template opens. You can 

then enter data as well as modify the existing content or structure as needed. Any changes or additions 

you make to the new workbook do not affect the template file; the next time you create a workbook 

based on the template, the original text, formatting, and formulas will be present. 

• To Create a Workbook Based on a Template 

• Click the File tab on the Ribbon, and then click the New tab in the navigation bar. 

• In the center pane, click a template category for the type of workbook you want to create, and then 

click a template. 

• In the right pane, check the preview, and then click the Download button. 

• Save the workbook with a new filename. 
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• A custom template is a workbook template you create that is ready to run with the formulas for all 

calculations included as well as all formatting. A template can use any Excel feature, including 

formulas, charts, data validation, cell protection, and macros. To create a custom template, you build the 

workbook with all the necessary labels, formatting, and data, and then you save the workbook as a 

template. The template includes everything but the variable data. 

• Before you create a template from an existing workbook, you should make sure that all the formulas 

work as intended, the numbers and text are entered correctly, and the worksheet is formatted 

appropriately. You should also remove any values and text that will change in each workbook created 

from the custom template. Be careful not to delete the formulas. When you are sure the workbook is 

complete and accurate, you save it as an Excel template file. You can store template files in any folder, 

but keep in mind that custom template files stored in the Templates folder are available on the New tab 

in Backstage view. 

• To Create a Workbook Based on a Template 

• Prepare the workbook: enter values, text, and formulas as needed; apply formatting; and replace 

data values with zeros or blank cells. 

• Click the File tab on the Ribbon, and then click the Save As command in the navigation bar. 

• In the File name box, enter the template name. 

• Click the Save as type button, and then click Excel Template. 

• Save the file in the Templates folder or select an alternative folder location. 

• Click the Save button. © Stella Moysiadou - stm@aueb.gr
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• After you have saved a template, you can access the template from the New tab in Backstage view. 

• If you saved the template file in the Templates folder, click the My templates button to open the 

New dialog box with the Personal Templates tab displayed to select the template you want to use. 

• If you saved the template to another location, you can use the New from existing button to create a 

new workbook from the file, much like creating a workbook based on a template found in the 

Templates folder. 

• The New from existing button opens a copy of the selected file, not the selected file. 

• Also, the copy of the workbook that opens has a number at the end of the filename, and is 

considered an unnamed file, which prevents anyone from inadvertently overwriting the original 

file. 
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• To ensure that correct data is entered and stored in a worksheet, you can use data validation. 

• Each validation rule defines criteria for the data that can be stored in a cell or range. You can also 

add input and error alert messages for the user to that cell or range. You specify the validation 

criteria, the input message, and the error alert for the active cell in the Data Validation dialog box. 

• When you create a validation rule, you specify the type of data allowed as well as a list or range of 

acceptable values (called validation criteria). For example, you might specify integers between 1 and 

100, or a list of codes such as Excellent, Good, Fair, and Poor. 
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• In the Data Tools group on the Data tab, click the Data Validation button. 

• Click the Settings tab. 

• Click the Allow arrow, click the type of data allowed in the cell, and then enter the validation 

criteria for that data. 

• Click the Input Message tab, and then enter a title and text for the input message. 

• Click the Error Alert tab, and then, if necessary, click the Show error alert after invalid data is 

entered check box to insert a check mark. 

• Select an alert style, and then enter the title and text for the error alert message. 

• Click the OK button. 
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• The built-in data validation rules are adequate for most simple needs. Sometimes, however, those 

rules just don’t fit your specific worksheet. In those cases, you need to create a custom validation 

rule that includes a formula. 

• To create a custom validation rule, open the Data Validation dialog box. On the Settings tab, 

click the Allow arrow, and then click Custom. You can then create the data validation formula. 

• The formula you specify must be in the form of a condition that returns either True or False. 

• If True is returned, the data entered is considered valid and accepted. 

• If False is returned, the entry is considered invalid and an error alert message is displayed. 

• For example, someone can use data validation to prevent the entry of dates that fall on Saturday or 

Sunday. 

• The WEEKDAY function returns a number (1 to 7) for the date entered in the cell, and then 

you create a formula to display an error alert if values of 1 (Sunday) or 7 (Saturday) are 

detected. 

• Assuming the date is entered in cell B2, the following formula returns False if either Saturday 

or Sunday is entered in cell B2:

=AND(WEEKDAY(B2)<>1,WEEKDAY(B2)<>7) 
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• Validation rules come into play only during data entry. If you add validation rules to a workbook 

that already contains data with erroneous values, Excel does not determine if any existing data is 

invalid. 

• To ensure the entire workbook contains valid data, you need to also verify any data previously 

entered in the workbook. You can use the Circle Invalid Data command to find and mark cells 

that contain invalid data. Red circles appear around any data that does not meet the validation 

criteria, making it simple to scan a worksheet for errors. After you correct the data in a cell, the 

circle disappears. 

• To display circles around invalid data, perform the following steps: 

• Apply validation rules to existing range. 

• In the Data Tools group on the Data tab, click the Data Validation button arrow, and then click 

Circle Invalid Data. Red circles appear around cells that contain invalid data. 

• To remove the circle from a single cell, enter valid data in the cell. 

• To hide all circles, in the Data Tools group on the Data tab, click the Data Validation button 

arrow, and then click Clear Validation Circles. 

• To ensure an error-free workbook, you should use the Circle Invalid Data command to verify 

data entered before you set up the validation criteria or to verify data in a workbook you 

inherited from someone else, such as a coworker. 
© Stella Moysiadou - stm@aueb.gr



PROTECTING A WORKSHEET

348

Microsoft Office 
Shipping, Finance & 
Management Skills

• Every cell in a workbook has a locked property that determines whether changes can be made to that cell. 

The locked property has no impact as long as the worksheet is unprotected. However, after you protect a 

worksheet, the locked property controls whether the cell can be edited. You unlock a cell by turning off the 

locked property. By default, the locked property is turned on for each cell, and worksheet protection is turned 

off. 

• So, unless you unlock cells in a worksheet before protecting the worksheet, all of the cells in the worksheet 

will be locked, and you won’t be able to make any changes in the worksheet. 

• Usually, you will want to protect the worksheet, but leave some cells unlocked. For example, you might 

want to lock cells that contain formulas and formatting so they cannot be changed, but unlock cells in which 

you want to enter data. 

• To protect some—but not all—cells in a worksheet, you first turn off the locked property of cells in which 

data can be entered. Then, you protect the worksheet to activate the locked property for the remaining cells. 

• Select the cells and ranges to unlock so that users can enter data in them. 

• In the Font group on the Home tab, click the Dialog Box Launcher. 

• In the Format Cells dialog box, click the Protection tab, click the Locked check box to remove the check 

mark, and then click the OK button. 

• In the Changes group on the Review tab, click the Protect Sheet button. 

• Enter a password (optional). 

• Select all of the actions you want to allow users to take when the worksheet is protected. 

• Click the OK button. 
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• Worksheet protection applies only to the contents of a worksheet, not to the worksheet itself. 

• To keep a worksheet from being modified, you need to protect the workbook. 

• You can protect both the structure and the windows of a workbook. 

• Protecting the structure prohibits users from renaming, deleting, hiding, or inserting 

worksheets. 

• Protecting the windows prohibits users from moving, resizing, closing, or hiding parts of the 

Excel window. 

• The default is to protect only the structure of the workbook, not the windows used to display it. 

• You can also add a password to the workbook protection. However, the same guideline applies 

here as for protecting worksheets:

• Add a password only if you are concerned that others might unprotect the workbook and 

modify it. If you add a password, keep in mind that it is case sensitive and you cannot 

unprotect the workbook without it. 

• To Protect a Workbook:

• In the Changes group on the Review tab, click the Protect Workbook button. 

• Click the check boxes to indicate whether you want to protect the workbook’s structure, 

windows, or both. 

• Enter a password (optional). 

• Click the OK button. © Stella Moysiadou - stm@aueb.gr
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• You can turn off worksheet protection at any time. This is often referred to as unprotecting the 

worksheet. 

• You need to unprotect a worksheet to edit its contents. If you assigned a password when you 

protected the worksheet, you would need to enter the password to remove worksheet protection. 

• Likewise, you can unprotect the workbook. If you need to insert a new worksheet or rename an 

existing worksheet, you can unprotect the protected workbook, make the changes to the structure, 

and apply workbook protection again. 

• To turn off worksheet protection: In the Changes group on the Review tab, click the Unprotect 

Sheet button. 

• To remove workbook protection, click the Protect Workbook button in the Changes group on the 

Review tab. 
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• Comments are often used in workbooks to: 

• (a) explain the contents of a particular cell, such as a complex formula; 

• (b) provide instructions to users; and 

• (c) share ideas and notes from several users collaborating on a project. 

• The username for your installation of Excel appears in bold at the top of the comments box. 

• If you collaborate on a workbook, the top of the comments boxes would show the name of each 

user who created that comment. 

• A small red triangle appears in the upper-right corner of a cell with a comment. The comment box 

appears when you point to a cell with a comment. 

• To Insert a Comment:

• Click the cell to which you want to attach a comment. 

• Right-click the cell, and then click Insert Comment on the shortcut menu. 

or 

• In the Comments group on the Review tab, click the New Comment button. 

• Type the comment into the box 
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• To enable several users to view and modify the same workbook, you can share the workbook. 

• A shared workbook can be edited simultaneously by more than one user when it is placed on a 

shared network folder, making it accessible to multiple users. 

• A shared workbook can also be edited sequentially by users who work on the file in turns. One 

advantage of sharing a workbook is that you can track the changes made by different people and 

the time that each change was made. 

• In a shared workbook, you can enter numbers and text, edit cells, move data, insert new rows and 

columns, and perform other usual editing tasks. 

• However, you cannot delete worksheets and ranges, insert ranges, merge and split cells, edit charts, 

or use the drawing tools. In general, you can do anything in the workbook that does not drastically 

change the layout or content to such an extent that Excel can no longer reconcile your edits with 

the edits from other users. 

• By default, Excel does not enable workbook sharing in order to prevent malicious software from 

opening and sharing personal information and sensitive data with the outside world. Before you 

can share a workbook, you must reset the privacy options. You set the privacy options for each 

workbook you wish to share, not the entire Excel program. 
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• To reset the privacy options for a workbook:

• Click the File tab on the Ribbon, and then click Options in the navigation bar. The Excel 

Options dialog box opens. 

• Click Trust Center in the left pane, and then click the Trust Center Settings button in the right 

pane. The Trust Center dialog box opens. 

• Click Privacy Options in the left pane, and then uncheck the Remove personal information 

from file properties on save check box in the Document-specific settings section. 

• Click the OK button in each dialog box to return to the workbook. 

• To enable workbook sharing: 

• Click the Review tab on the Ribbon, and then click the Share Workbook button in the Changes 

group. The Share Workbook dialog box opens with the Editing tab active. 

• Click the Allow changes by more than one user at the same time check box to insert a check 

mark. This allows others to access and edit this workbook. 

• Click the OK button. A dialog box opens indicating the workbook will be saved, which 

changes its status to shared. 

• Click the OK button. The workbook is saved and [Shared] appears on the title bar next to the 

workbook name. Close the workbook. 
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• When people make changes to different cells, Excel marks those edits into the shared workbook 

and notifies current users of the change. 

• Conflicts occur when users try to save different changes to the same cell. Suppose Jennifer and 

Alberto make different edits to cell B7. Alberto saves his workbook first and stores $770,857 in 

cell B7. However, Jennifer is working at the same time and enters $770,457 in cell B7. When 

Jennifer saves her workbook, the Resolve Conflicts dialog box opens, notifying her of the conflict 

in cell B7. From this dialog box, Jennifer can choose which edit to accept. She can repeat this 

process for each conflict. 

• The Resolve Conflicts dialog box appears only when conflicts arise in the edits that the coworkers 

make while working on the document simultaneously. 

• All users have equal authority to resolve conflicts. The last user to save the document is the one 

who sees the Resolve Conflicts dialog box. 

• Rejected edits are stored in a tracking log so any user can review and retrieve them. This feature 

is particularly useful when a large group is editing a workbook and more control over the final 

content is needed. 
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• In the Changes group on the Review tab, click the Track Changes button, and then click Highlight 

Changes. 

• Specify when, who, and where in the Highlight which changes section. 

• Click the Highlight changes on screen check box to see edits in comments. 

OR

• Click the List changes on a new sheet check box to view the tracking log. 

• Click the OK button. 

• Point to the highlighted cells to see the edits and/or view the tracking log in the History 

worksheet. 
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• Examining all the sheets in a workbook to find the highlighted changes can be time consuming, 

especially in workbooks with many worksheets. The tracking log provides a faster method to 

review the changes. When you create a tracking log, which appears on the History worksheet, it 

lists all the changes made to the workbook along with information about the date and time each 

change was made, the person who made the change, the location of the change, and the change 

itself. 

• To show the contents of the tracking log:

• In the Changes group on the Review tab, click the Track Changes button, and then click 

Highlight Changes. The Highlight Changes dialog box opens. 

• Click the List changes on a new sheet check box to insert a check mark. 

• Click the OK button. The History worksheet is created, detailing the history of the six changes 

made to the workbook in chronological order along with who made each change, where it was 

made, and what kind of change it was. 
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• In the Changes group on the Review tab, click the Track Changes button, and then click 

Accept/Reject Changes. 

• Specify when, by whom, and where changes are to be reviewed. 

• Click the OK button. 

• Proceed through the list of changes, clicking the Accept, Reject, Accept All, Reject All, or Close 

buttons. 
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• When two (or more) copies of the same workbook have different edits, you can merge the 

workbooks to create a single workbook that combines the edits from both files. The following 

conditions must be met to merge two workbooks: 

• The two workbooks must be copies of the same file, which must also be a shared workbook. 

• The two workbooks must have different filenames. 

• The two workbooks must either have the same password or not be password-protected. 

• The Track Changes feature must be turned on for both workbooks. 

• The tracking log must be kept from the time the two workbooks are made from the original 

common file. 

• To Merge the Workbooks 

• Customize the Quick Access Toolbar to display the Compare and Merge Workbooks button. 

• Open the workbook into which you want to merge the workbooks. 

• Click the Compare and Merge Workbooks button on the Quick Access Toolbar. 

• Select the workbook that you want to merge into the current document, and then click the OK 

button. 
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• On the Quick Access Toolbar, click the Customize Quick Access Toolbar button , and then click 

More Commands. 

• Click the Choose commands from arrow, and then click Commands Not in the Ribbon to display a 

list of all the Excel commands that do not appear on the Ribbon. 

• Click Compare and Merge Workbooks from the list of commands, and then click the Add button. 

The Compare and Merge Workbooks command button is added to the commands on the Quick 

Access Toolbar. 

• Click the OK button. 
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• The Documentation worksheet includes a description of the final workbook, its contents, and its 

purpose. You can also make this information available by modifying the workbook’s document 

properties, or metadata, which are the descriptive details about a file, including its author, title, and 

subject. The five types of document properties are: 

• Standard properties, which are properties associated with all Office files and include the author, 

title, and subject. 

• Automatically updated properties, which are properties usually associated with the file itself, 

such as the file size or the date the file was last edited. You cannot modify the automatically 

updated properties. 

• Custom properties, which are properties you define and create specifically for your workbook. 

• Organization properties, which are properties created for organizations using the Document 

Information Panel available with Microsoft InfoPath. 

• Document library properties, which are properties associated with documents in a document 

library on a Web site or in a public network folder. 

• Users can access document properties without opening the workbook, making it easier to find key 

files. For example, in a network folder with hundreds of files, your colleagues can quickly locate 

workbooks you authored or workbooks about a specific topic.
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• To add document 

properties to the 

workbook:

• Click the File tab on 

the Ribbon, and then 

click Info in the 

navigation bar to 

display information 

about the workbook in 

Backstage view.

• Click the Show All 

Properties link in the 

right pane.
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• To enter a custom property:

• At the top of the right pane of 

the Info tab in Backstage view, 

click the Properties button, and 

then click Advanced Properties. 

The Final Draft Properties dialog 

box opens. 

• Click the Custom tab, and then 

click a property in the Name box. 

Verify that the data type is 

correctly set. 

• Type the description you want in 

the Value box, and then click the 

Add button. The property is 

added to the Properties box. 
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• Before distributing the workbook, you may want to ensure it doesn’t contain sensitive or 

personal information. 

• Personal information can come from comments and annotations, document properties and 

metadata attached to the workbook, custom XML data stored within the XML code for the 

workbook file, headers and footers, hidden worksheets and cells, cells whose display styles make 

them invisible to the user, and server information inserted by saving a workbook on the Document 

Workspace site or within a Document Library. 

• To determine whether a workbook contains sensitive or personal information, you can use the 

Document Inspector, which searches the workbook to locate data and text that fit these 

categories. You can then remove any personal information, if necessary, with the Document 

Inspector. 

• To inspect the workbook:

• In the left pane of the Info tab in Backstage view, click the Check for Issues button, and then 

click Inspect Document.

• Click the Yes button in the dialog box that opens prompting you to save the file. 

• The Document Inspector dialog box opens. 

• Leave all of the check boxes checked, and then click the Inspect button. The inspection 

results appear in the dialog box. 
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• Hidden worksheets are often used to conceal source data and documentation that is useful to the 

author but is distracting or confusing to other users. 

• To show and hide the hidden worksheet:

• Right-click any sheet tab in the workbook, and click Unhide on the shortcut menu. The 

Unhide dialog box opens, displaying a list of all the hidden sheets in the workbook. 
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• You can encrypt a workbook to help secure its contents. Encryption is the process by which a file 

is encoded so that it cannot be opened without the proper password. The encryption password is 

different from the passwords to prevent users from editing a worksheet or the entire workbook. 

An encryption password prevents unauthorized users from even opening the file. Passwords 

can be up to 255 characters in length and can include numbers, symbols, and upper- and 

lowercase letters. 
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• To encrypt the workbook: 

• Click the File tab on the Ribbon, and then click Info in the navigation bar. 

• Click the Protect Workbook button, and then click the Encrypt with Password button. 

• Type a password in the Password box, and then click the OK button. 

• Retype the password in the password box, and then click the OK button. A password is now 

required to open this workbook. 

• Save and close the workbook, and then reopen the workbook. The Password dialog box 

opens, preventing the workbook from opening without the password. 
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MARKING A WORKBOOK AS FINAL

• A final workbook has the editing, typing, and proofing commands disabled or turned off. The 

user can only view the contents of the file, not change it. Also, the Status document property 

value changes to Final. 

• The Mark as Final command informs others that this workbook is intended to be the final 

version of the workbook. However, anyone can remove the Mark as Final status from the 

workbook by reapplying the Mark as Final command to deselect it. 

• To mark the financial report workbook as final:

• Click the File tab on the Ribbon, and then click Info in the navigation bar.

• Click the Protect Workbook button, and then click Mark as Final. A dialog box opens 

indicating that the workbook will be marked as final and then saved. 

• Click the OK button. A second dialog box opens indicating that the file has been marked 

as final. 

• Click the OK button. A marked-as-final workbook is displayed with [Read-Only] in the 

title bar. 

• Click a blank cell in the active worksheet to confirm that you cannot edit the workbook. 
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PROVIDING A DIGITAL SIGNATURE

• A digital signature is an electronic version of a written signature and provides a way to 

authenticate a workbook. Digital signatures cannot be forged. Also, a workbook signed with a 

digital signature cannot be altered without removing the signature, ensuring that the 

workbook received is the one that the user intended to send. 

• With a digital signature, other users know that the workbook comes from a trusted source 

and has not been altered since it was originally signed, and that its origin is accepted by all 

parties and can’t be repudiated by the signer. 

• To add a digital signature, you need a digital ID or digital certificate, which authenticates 

the source of the signature. If you do not have a digital certificate, you can get one from a 

third-party source or you can create your own. 

• The third-party source, also known as a certificate authority (CA), is a trusted entity that 

issues certificates as a service for companies and individuals. The CA may be a commercial 

service that requires payment. If you create your own certificate, it authenticates the file only 

for that computer and not for other users on other computers. 
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PROVIDING A DIGITAL SIGNATURE

• Το Add a Digital Signature to a Workbook:

• Click the File tab on the Ribbon, and then click Info in the navigation bar. 

• Click the Protect Workbook button, and then click Add a Digital Signature. 

• If requested, specify whether to create a third-party digital ID or a local digital ID. 

Provide descriptive information for the digital ID. 

• If no digital IDs are made, specify whether to create a third-party digital ID or a local 

digital ID. Provide descriptive information for the digital ID, and then click the Create 

button. 

• Enter a purpose for the digital signature, click the Sign button, and then click the OK 

button. 
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ENSURING BACKWARD COMPATIBILITY IN A WORKBOOK

• You will sometimes need to create a copy of a workbook that is compatible with earlier Excel 

versions to share with other users. The Compatibility Checker flags any content, formatting, or 

element in the workbook that cannot be transferred to earlier versions of Excel. 

• To run the Compatibility Checker:

• Click the File tab on the Ribbon, and then click Info in the navigation bar.

• Click the Check for Issues button, and then click Check Compatibility. The Compatibility 

Checker dialog box opens. 

• Read the summary of features not supported in the earlier versions of Excel, and then click 

the OK button. 

• Save the workbook with the save as type set to Excel 97-2003 Workbook. 

• Click the Yes button to continue saving the file, and then click the No button when prompted 

to convert the file to an Office Open XML format. Excel performs a last compatibility check, 

again finding that there will be minor differences in the format styles. 

• Click the Continue button in the Compatibility Checker dialog box. The Excel 2003 version 

of the workbook is saved. 

• Save and close the workbook. 
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AUTOMATING TASKS WITH MACROS

• Using a macro, you can automate any task you perform repeatedly. For example, you can 

create a macro to print a worksheet, insert a set of dates and values, or import data from a text file 

and store it in Excel. 

• Macros perform repetitive tasks consistently and faster than you can. And, after the macro is 

created and tested, you can be assured the tasks are done exactly the same way each time. 

• To create and run macros, you need to use the Developer tab. By default, this tab is not displayed 

on the Ribbon.

• To display the Developer tab on the Ribbon:

• Click the File tab on the Ribbon to open Backstage view, and then click the Options button in 

the navigation bar. The Excel Options dialog box opens. 

• In the left pane, click Customize Ribbon. 

• In the right pane, click the Developer check box to insert a check mark.

• Click the OK button. The Developer tab appears on the Ribbon. 
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RECORDING A MACRO

• You can create an Excel macro in one of two ways: You can use the macro recorder to record 

keystrokes and mouse actions as you perform them, or you can enter a series

of commands in the Visual Basic for Applications (VBA) programming language. 

• The macro recorder can record only those actions you perform with the keyboard or mouse. The 

macro recorder is a good choice for creating simple macros. For more sophisticated macros, you 

might need to write VBA code directly in the Visual Basic Editor. 

• Each macro must have a unique name that begins with a letter. The macro name can contain up 

to 255 characters, including letters, numbers, and the underscore symbol. The macro name cannot 

include spaces or special characters. It is helpful to use a descriptive name that describes the 

macro’s purpose. 

• You can assign a shortcut key to run the macro directly from the keyboard. Macro shortcut keys 

are used to run a macro. Assigning a shortcut key overrides the equivalent default Excel shortcut 

for the open workbook. For example, using the Ctrl+p keys to run a macro overrides the default 

Excel 2010 shortcut for printing a selected area while the workbook containing the macro is open. 

Some people find macro shortcut keys a quick way to run a macro; others dislike them because 

they override the original function of the shortcut key. It’s a personal preference. 
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RECORDING A MACRO

• A macro needs to be stored somewhere. By default, the macro is stored in the current workbook, 

making the macro available in only that workbook when it is open. Another option is to store the macro 

in the Personal Macro workbook, a hidden workbook named Personal.xlsb that opens whenever you 

start Excel, making the macro available any time you use Excel. The Personal Macro workbook stores 

commonly used macros that apply to many workbooks. It is most convenient for users on stand-alone 

computers. Finally, you can store the macro in a new workbook. Keep in mind that the new workbook 

must be open to use the macro. For example, an accountant might store a set of macros that help with 

end-of-the-month tasks in a separate workbook. 

• You can also add a description of the macro to briefly explain what it does. You can also include the 

name of the person to contact and the date it was created. 

• To Record a Macro:

• In the Code group on the Developer tab, click the Record Macro button.

• Enter a name for the macro, and then specify the location to store the macro.

• Specify a shortcut key (optional).

• Enter a description of the macro (optional).

• Click the OK button to start the macro recorder.

• Perform the tasks you want to automate.

• Click the Stop Recording button. 
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RECORDING A MACRO
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RUNNING A MACRO

• After you record a macro, you should run it to test whether it works as intended. Running a macro 

means Excel performs each of the steps in the same order as when it was recorded. 

• To run the macro you created, you can either use the shortcut key you specified or select the 

macro in the Macro dialog box. 

• The Macro dialog box lists all of the macros in the open workbooks. From this dialog box, you 

can select and run a macro, edit the macro with VBA, run the macro one step at a time so you can 

determine in which step an error occurs, or delete it. 

• To Run a Macro: 

• Press the shortcut key assigned to the macro. 

Or 

• In the Code group on the Developer tab, click the Macros button. 

• Select the macro from the list of macros.

• Click the Run button. 
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RUNNING A MACRO
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