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Agenda (1)

I. Introduction to STATA

II. Empirical Example 1 : Cross Sectional Data

 

•STATA Interface

•Data Management in STATA

•Example of a test in Finance for 60 students

•Probability density function

•Basic Distribution parameters (mean, standard deviation, skewness, kurtosis)
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Agenda (2)

IV. Empirical Example 3 : Transformations of data & plots - Time Series 
Data 

• Example of simple and continuous compounding returns for UK Market Index

III. Empirical Example 2 : Time Series Data 

•Example of monthly returns for equity indices of G7 countries

•Distribution parameters (covariance, correlation)
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Agenda (3)

V. Classical Linear Regression Model Estimation

VI. Multiple Linear Regression Model Estimation 

 

• Empirical Example 4 : CAPM model

➢ Model Estimation

➢Hypothesis Testing

➢Wald Test

➢Multiple Hypothesis : the F -test

• Empirical Example 5 : APT Model 

➢ Model Estimation

➢Hypothesis Testing

➢Wald Test

➢Multiple Hypothesis : the F -test

➢Stepwise procedure equation estimation

➢R-squared & F -Statistic
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Introduction to STATA
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STATA Interface

1.Open STATA from PC- lab

• Double Click on the STATA on the desktop of your pc 

Review Window

Command Window

Output Window

Variables 

Window

Data 

Editor



STATA Workshop, 2023

How to save your output – Log files

• Stata can record your session into a file called a log file but does not start a log 

automatically; you must tell Stata to record your session. 

• By default, the resulting log file contains what you type and what Stata produces 

in response, recorded in a format called Stata Markup and Control Language 

(SMCL).

• To start a log: click on File → Log → Begin 

• To temporarily stop logging: click on the Log button, and choose Suspend 

• To resume: click on the Log button, and choose Resume 

• To stop logging and close the file: click on the Log button, and choose Close 

• To print previous or current log: select File > View..., choose file, right-click on 

the Viewer, and select Print

• www.stata.com/manuals13/u15.pdf 

https://www.stata.com/manuals13/u15.pdf
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How to save your commands – Do files

• Rather than typing commands at the keyboard, you can create a text file 

containing commands and instruct Stata to execute the commands 

stored in that file. 

• Such files are called Do-files because the command that causes them to 

be executed is do

• To create a Do file: 

– Click the “New Do file editor” 

– Type in your commands

– Save the file\

• To execute a do file: 

– Type: do and then add the path of the do file

• E.g. "C:\Users\user\Desktop\Untitled.do"

– Or File → Do 

– Or click the button “Execute” in the Do file editor window

https://www.stata.com/

manuals13/u16.pdf 

https://www.stata.com/manuals13/u16.pdf
https://www.stata.com/manuals13/u16.pdf
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How to save your data – Data files (.dta)

• To save an unnamed dataset (or an old dataset under a new name):

1. select File > Save as...;

2. OR type “save filename” in the Command window

• To save a dataset that has been changed (overwriting the original data 

file)

1. select File > Save; 

2. OR click on the Save button; 

3. OR type “save, replace” in the Command window.

• To open a Stata dataset: 

1. Double-click on a Stata data file, which is a file whose extension is .dta. 

2. OR Select File > Open... or click on the Open button and navigate to the 

file.

3. OR type “use filename” in the Command window

www.stata.com/manuals/gsw5.pdf 

http://www.stata.com/manuals/gsw5.pdf
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Data

• Types of Data

a. Numeric data (i.e. number)

b. String data(i.e. text)

• Missing Values

• For numeric data: single dot (.)

• For string data: double quotes (‘‘ ’’) or dot double quotes (‘‘. ’’) 

• Useful commands for changing string into numeric or other type 

and vice versa: 

• encode (www.stata.com/manuals/dencode.pdf)

• destring (www.stata.com/manuals/u24.pdf#u24.2Categoricalstringvariables) 

• format (www.stata.com/manuals/dformat.pdf) 

http://www.stata.com/manuals/dencode.pdf
http://www.stata.com/manuals/u24.pdf#u24.2Categoricalstringvariables
http://www.stata.com/manuals/dformat.pdf
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Workfile

2. Go to File            Import             …..
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Empirical Example 1 :

               Cross Sectional Data
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Empirical Example 1 – Cross Sectional Data(1) 

1. Go to folder Empirical Examples           Example_1

2. Open xlsx file: example_1.xlsx 

3. Define the type of the data : Cross Sectional Data  

4. Define the number of observations of the sample: 60

5. Close xlsx file

• Shows the results of a test in Finance for 60 students

 (Source: “Econometrics for Financial Analysis”, A. G. Merikas, A. A. Merika)
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Empirical Example 1 – Cross Sectional Data(2) 
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Empirical Example 1 – Cross Sectional Data(3) 
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Empirical Example 1 – Cross Sectional Data(4) 
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Empirical Example 1 – Cross Sectional Data(5) 
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Empirical Example 1 – Cross Sectional Data(6) 
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Empirical Example 1 – Cross Sectional Data(7) 

Write the name of the variable (here is grade) 

Output Window
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Output Window

Empirical Example 1 – Cross Sectional Data(8) 
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• Write codebook in the command window

Empirical Example 1 – Cross Sectional Data(9) 
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• Graph 

Empirical Example 1 – Cross Sectional Data(10) 
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We can visualize the shape of distribution  

•Distinction between normal and non-normal distributions 

The above diagram shows the probability density function (pdf) of the variable 

“grade”.  In a first view resembles the “normal distribution” with pdf function :

                                                

2
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( ) exp
22

X
f X



 

 − 
= −  

   

Empirical Example 1 – Cross Sectional Data(11) 



STATA Workshop, 2023

Close the above window                Go to File           Save as…  

Empirical Example 1 – Cross Sectional Data(12) 

Go to Graphics       Distributional Graphs          Histogram
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Empirical Example 2 :

              Time Series Data
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1. Go to folder Empirical Examples           Example_2

2. Open .xlsx file: example_2.txt 

3. Define the type of the data : Time series data

4. Close .xlsx file

• Shows the monthly total simple returns(capital + dividends) in $ of the 

equity indices of G7 countries from 31/01/1980 – 31/10/2012 .  

(Source : DataStream)

 

Empirical Example 2- Time Series Data (1)
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5 . Open STATA from PC - lab

6.  Go to File            Import            Excel Spreadsheet 

7.  Browse example_2.xlsx

Empirical Example 2- Time Series Data (2)
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8. Go to Graphics     smoothing and densities         Kernel Density Function

Empirical Example 2- Time Series Data (3)
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Empirical Example 2- Time Series Data (4)
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File   Save as 9. File         Save as  

Empirical Example 2- Time Series Data (5)
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10. Data         Describe data          Summary Statistics

Empirical Example 2- Time Series Data (6)
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Empirical Example 2- Time Series Data (7)
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Command

Window

Go back to the ‘Summarize’ Window

Empirical Example 2- Time Series Data (8)
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For additional statistics measures

Empirical Example 2- Time Series Data (9)
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11. Statistics         Summaries…    Summary and descriptive Statistics

Empirical Example 2- Time Series Data (10)
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12. Select Correlations and Covariances

Empirical Example 2- Time Series Data (11)
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13. Go to Options and tick Display Covariances 

Empirical Example 2- Time Series Data (12)



STATA Workshop, 2023

14 . Close the above window                Go to File           Save as…  

We can here define 

• Covariance between X and Y variables

• Correlation between X and Y variables

 

( , ) ( ) ( ) ( )Cov X Y E XY E X E Y= −

( , )

ar( ) ( )

Cov X Y

V X Var Y
 =

Empirical Example 2- Time Series Data (13)
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Empirical Example 3 :

              Transformations of Data & Plots

Time Series Data
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Empirical Example 3 :  Transformation of data & Plots(1)

1.Go to folder  Example_3         Import the example_3.xlsx

• We present the price of  UK market index from 01/1965 – 06/2015   (Source : 
DataStream) 

2.Go to Command window and type the following

gen simpleret=(UKMarketIndex/UKMarketIndex[_n-1])-1

tsset Date

gen logret=ln(UKMarketIndex/UKMarketIndex[_n-1])
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Empirical Example 3 :  Transformation of data & Plots(2)
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Advantages

Disadvantages

• In Investments , the simple portfolio return  is a weighted average of the 
simple returns on the individual assets.

• However,  this is not feasible for log returns since the log of a sum is not 
the same as the sum of a log.

•  Are time additive.

•  Assets can be compared since the frequency of compounding return does not 

play any role.

1

n

pt i it

i

R wR
=

=

Continuous compounding or log- returns

Empirical Example 3 :  Transformation of data & Plots(3)
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Go to Graphics        Time-series Graphs           Line Plots

3.  Click on Create

Empirical Example 3 :  Transformation of data & Plots(4)
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Empirical Example 3 :  Transformation of data & Plots(5)
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Empirical Example 3 :  Transformation of data & Plots(6)
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Empirical Example 3 :  Transformation of data & Plots(7)
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Empirical Example 4 :

              Data transformation and setup

Panel Data
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Empirical Example 4 : Long and Wide datasets

1.Go to folder  Example_4         Import the example_4 workbook

• Prices and Dividend Yields for the share i (i=1,2,3) in year j (j=19,20,21) 

2.Is this Panel dataset long or wide? 

Think of the data as a collection of observations Xij, where i is the logical observation, or

group identifier, and j is the subobservation, or within-group identifier.

• Wide-form data are organized by logical

observation, storing all the data on a particular

observation in one row.

• Long-form data are organized by subobservation,

storing the data in multiple rows.
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Convert data between wide and long

Data > Create or change data > Other variable-transformation commands > 

Convert data between wide and long 

reshape long PRICE DY, i(i) j(YEAR)
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Declare Dataset to be Panel Data

• xtset panelvar declares the data

in memory to be a panel in which

the order of observations is

irrelevant.

• xtset panelvar timevar declares

the data to be a panel in which

the order of observations is

relevant.

– When you specify timevar, you

can then use Stata’s time-series

operators and analyze your data

with the ts commands without

having to tsset your data.

• Statistics > Longitudinal/panel

data > Setup and utilities >

Declare dataset to be panel data
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Classical Linear Regression 
Model Estimation
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Empirical Example 5 :

              Simple Linear Regression
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Open the file SandPhedge.dta

Simple Linear Regression
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Simple Linear Regression

Use summarize in the command window

Summary Statistics
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Simple Linear Regression

Go to Statistics     Linear models and related     Linear regression
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Simple Linear Regression
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Simple Linear Regression

Coefficients

In the command window you can type 

Regress dependent variable independent variable
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1. Hypothesis Testing – Critical value approach

0 : 0

: 0A

H

H





=



0 : 0

: 0A

H

H





=



Two –sided Test

Critical value approach

^

^
test statistic

SE

 



−
=

 
 
 

^

^

a a
test statistic

SE a

−
=

 
 
 

We do not reject the Null 

Hypothesis for a ; thus a is 

insignificant

We reject the Null 

Hypothesis for b ; thus b  is 

significant

a = 5% significance level

Simple Linear Regression
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2. Hypothesis Testing – Confidence interval approach

0 : 0

: 0A

H

H





=



0 : 0

: 0A

H

H





=



Two –sided Test

Confidence interval approach

(-0.052026,0.0533)

We do not reject the Null 

Hypothesis for a ; thus a is 

Insignificant,  since 0 lies

 within confidence interval

a = 5% significance level

^ ^

( )crita t SE a

^ ^

( )critt SE 
(0.995,1.01889)

We reject the Null 

Hypothesis for b ; thus b  is 

significant, since 0 does not 

lie within confidence interval

Simple Linear Regression
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3. Hypothesis Testing – p-value approach

0 : 0

: 0A

H

H





=



0 : 0

: 0A

H

H





=



Two –sided Test

P-value approach

a = 5% significance level

p-value is termed as the

“plausibility” of the Null Hypothesis; 

the smaller the p-value, the less plausible is the null 

hypothesis.

Is the largest significance level at which we fail to reject

 the null hypothesis.

Simple Linear Regression
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0 : 1

: 1A

H

H





=



Suppose now we want to test the null hypothesis that  

Go to Statistics         Proestimation        Tests      Test linear hypotheses          

Simple Linear Regression
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❑ F(1,132) : F-statistic with one restriction and T-k=134-2=132

❑We cannot reject the Null hypothesis since the

p-value=0.2160>0.05

Simple Linear Regression
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Simple Linear Regression
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Simple Linear Regression

❑ Open capm.dta
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Scatter plot

Simple Linear Regression
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❑ Type in the command window regress erford ersandp

Simple Linear Regression
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1. Hypothesis Testing – Critical value approach

0 : 0

: 0A

H

H





=
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0 : 0
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H
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
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Two –sided Test

Critical value approach

^

^
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a a
test statistic

SE a

−
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 
 

We do not reject the Null 

Hypothesis for a ; thus a is 

insignificant

We reject the Null 

Hypothesis for b ; thus b  is 

significant

a = 5% significance level

Simple Linear Regression
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2. Hypothesis Testing – Confidence interval approach

0 : 0

: 0A

H

H





=



0 : 0

: 0A

H

H





=



Two –sided Test

Confidence interval approach

(-0.052026,0.0533)

We do not reject the Null 

Hypothesis for a ; thus a is 

Insignificant,  since 0 lies

 within confidence interval

a = 5% significance level

^ ^

( )crita t SE a

^ ^

( )critt SE 
(0.995,1.01889)

We reject the Null 

Hypothesis for b ; thus b  is 

significant, since 0 does not 

lie within confidence interval

Simple Linear Regression
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3. Hypothesis Testing – p-value approach

0 : 0

: 0A

H

H





=



0 : 0

: 0A

H

H





=



Two –sided Test

P-value approach

a = 5% significance level

p-value is termed as the

“plausibility” of the Null Hypothesis; 

the smaller the p-value, the less plausible is the null 

hypothesis.

Is the largest significance level at which we fail to reject

 the null hypothesis.

Simple Linear Regression
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❑ F(1,133) : F-statistic with one restriction and T-k=135-2=133

❑ We reject the Null hypothesis since the p-value=0.000

Suppose now we want to test the null hypothesis that  

0 : 1

: 1A

H

H





=



Simple Linear Regression

Sata manual on testing linear hypotheses after estimation: 

www.stata.com/manuals/rtest.pdf 

http://www.stata.com/manuals/rtest.pdf
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Empirical Example 6 :

 Multivariate Linear Regression
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Multivariate Linear Regression

❑ Open macro.dta

❑ Run the regression
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6. Testing Multiple Hypothesis : The F- test

The t-test was used to test single- hypothesis (one coefficient hypothesis)

For more than one parameter hypothesis  we use F -  statistic

( , )
RRSS URSS T k

t statictic F m T k
URSS m

− −
− =  −

•URSS: Residual sum of squares from unrestricted regression

•RRSS : Residual sum of squares from restricted regression

•m : number of restrictions

•T : number of observations

•k : number of regressors in unrestricted regression 

2 2 (1, )

T k

T k

Z t

Z t F T k

−

− −

critF tReject the Null when 

Multivariate Linear Regression
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Test whether dprod dcredit dinflation dmoney dspread are 

jointly zero using F-test

The Null Hypothesis cannot be rejected

0 2 3 4 5 6

2 3 4 5 6

: 0 0 0 0 0

: 0 0 0 0 0A

H and and and and

H or or or or

    

    

= = = = =

    

Multivariate Linear Regression
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STATA Workshop II
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Agenda (1)

I. Testing for heteroskedasticity

II. Testing for serial correlation

 

➢Wald Test

➢Breusch-Pagan- Godfrey Test

➢ Durbin- Watson Test

➢Breusch-Godfrey Test

IV. Testing for multicollinearity

➢Correlation Matrix

➢Add/Remove of Explanatory variable

III. Testing for non normality

 

➢Jarque – Bera Test

➢Dummies
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Agenda (2)

V. Testing for linear relationship between Y and X

➢Ramsey RESET Test

VI. Univariate Time Series Modelling of US Home Prices

➢Autoregressive Process (AR)

➢Moving Average Process (MA)

➢ARMA model
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Assumptions underlying the CLR model

( )=0 The errors have zero mean (Mean Independence)tE u

2

tvar(u )=σ  The variance of the errors is constant (Homoskedasticity)

i jcov(u ,u )=0 The errors are linearly independent of one other

t tcov(u ,x )=0 There is no relationship between the error and the corresponding variate x

2

tu N(0,σ ) The errors are normally distributed (Normality)

CLRM

Violation of one of the above assumptions may lead to 

1. Biased coefficient estimates

2. Biased standard errors

3. Inappropriate distributions

Thus, we need to test and solve for these violations
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Statistical Distributions for diagnostic tests

The tests that detect any violation are based on the 

calculation of test statistic 

LM test

• Chi-squared distribution

• df equal to the number  of restrictions

Wald Test

• F-distribution

• df equal to ( , )m T k−

2 ( )
( , )

Am
F m T k

m


−
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1st Assumption: Mean Independence

( )=0 The errors have zero mean (Mean Independence)tE u

•If we include a constant term in the regression equation,

 this assumption will never be violated.

•If financial theory suggest a model without intercept then

a. R-squared may be negative (the sample average of y 

explains more of the variation in y than the explanatory 

variables x ).

b. Severe biases in slope coefficients.
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Testing for 
Heteroskedasticity
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2nd Assumption: Homoskedasticity

•You can plot the residuals with an explanatory variable; however, it is 

difficult to detect the presence or not of heteroskedasticity, since we do not 

know the form of the latter.

Thus, we use a number of tests that detect heteroskedasticity

here in STATA: White Test

2

tvar(u )=σ  The variance of the errors is constant (Homoskedasticity)
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Testing for heteroskedasticity

❑ Load macro.dta



STATA Workshop, 2023

Graphical Illustration of  possible heteroskedasticity

Testing for heteroskedasticity

In the command window write 

twoway (tsline resid)

If the residuals of the regression 

have systematically changing 

variability over the sample, that is 

a sign of heteroskedasticity 
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Correcting  for heteroskedasticity

White standard errors
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Testing for Serial 
Correlation/Autocorrelation
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3nd Assumption: No serial autocorrelation

•Errors are uncorrelated with one another

•If errors are not uncorrelated with one another, it would be stated 

that  they are autocorrelated or serially correlated. 

i jcov(u ,u )=0 The errors are linearly independent of one other
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Testing for serial correlation

The Durbin- Watson

 test statistic is 2.19, close to 2

How detect autocorrelation?? 

From the estimation output a simple test is Durbin –Watson Test 

Durbin – Watson(DW) is  a test for first order

 autocorrelation.(tests  the relationship between 

an error and its immediately  previous value).

Conditions for DW to be a valid Test

1. Existence of a constant term.

2. Non –stochastic regressors.

3. No lags of dependent variable.

1t t tu u v −= +

0 : 0(No Autocorrelation)

: 0(Autocorrelation)A

H

H





=



2(1 )DW  −
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Another more robust test than DW is  Breush – Godfrey Test

Specify the number of lags equal to12.

There is no an obvious answer to this, 

you can experiment on a range of 

number. You can relate the number of 

lags with the frequency of your data.

(for monthly data use 12, for quarterly  

data 4, etc) 

Testing for serial correlation
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Correction

Newey & West for both  heteroskedasticity and  autocorrelation
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Testing for Non- Normality
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Testing for Non- Normality
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Skewness and Kurtosis Test : A variation of Jarque Bera test

Null Hypothesis : Normality (Both Kurtosis and Skewness are

those of the normal distribution,                       and Kurtosis =3Skewness =0

Testing for Non- Normality
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What to do if evidence of non-normality is found?

•Central Limit Theory: The test statistics will asymptotically follow the appropriate 

distribution even in the absence of error normality ; the sample mean converges to a 

normal distribution.

•Financial/ Economic theory : One or two very extreme residuals cause a rejection of 

normality assumption (outliers)

A plausible solution : Use of dummy variables

Testing for Non- Normality
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Testing for Non- Normality
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Testing for Non- Normality
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A long way for residuals to follow a normal distribution…

Testing for Non- Normality
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Testing for Multicollinearity
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Testing for multicollinearity

How detect multicollinearity??  Two easy ways:

1. Use the correlation matrix of the explanatory variables

Implicit assumption: explanatory variables not correlated/orthogonal with one 

another. 
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• Problems if near Multicollinearity is present but ignored

1. R-squared will be high, but the individual coeff. will have high standard 

errors, so that  regression “looks good” as a whole, but the individual 

variables are not significant.

Remark: Multicollinearity does not affect  the value of R-squared in the 

regression.

2. Regression becomes very sensitive to small changes in the specification; 

add/remove an independent variable leads to large changes in the coeff. 

values or significances of other variables.

3. Wide confidence intervals for the parameters; inappropriate results for 

significance tests.

Testing for multicollinearity
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• Solutions to the problem of multicollinearity

1. Use of ridge Regressions

2. Use of Principal Component Analysis.

3. Ignorance of multicollinearity if the model is statistically appropriate.

4. Drop one of the collinear variables

5. Transform the highly correlated variables into a ratio and include the 

ratio and not the individual explanatory variables.

6. A sufficient history of data : longer run of data/ higher frequent 

data/pooled data.

Testing for multicollinearity
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Testing for linear relationship 
between Y and X
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Testing for linear relationship 

between Y and X

Linearity or not???

Ramsey RESET test : View       Stability Diagnostics        Ramsey RESET Test

Thus, we cannot reject the null hypothesis that the model 

has no omitted variables. In other words, we do not find 

strong evidence that the chosen linear functional form of the

model is incorrect.

0 :

:A

H Linearity

H Non Linearity−
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The end
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